Annotation leaks from nodegroup-level to shader level #63481

Open
opened 2019-04-11 10:42:04 +02:00 by user1 · 20 comments

System Information
Operating system:Linux Mint 19
Graphics card:Nvidia gt630

Blender Version
Broken: blender-2.80-99f1e3d57fa1-linux-glibc224-x86_64

Short description of error
Annotations inside a nodegroup layout also show in the mother layer (Shader editor)

screen1.png

**System Information** Operating system:Linux Mint 19 Graphics card:Nvidia gt630 **Blender Version** Broken: blender-2.80-99f1e3d57fa1-linux-glibc224-x86_64 **Short description of error** Annotations inside a nodegroup layout also show in the mother layer (Shader editor) ![screen1.png](https://archive.blender.org/developer/F6930611/screen1.png)
Author

Added subscriber: @user1

Added subscriber: @user1

#77294 was marked as duplicate of this issue

#77294 was marked as duplicate of this issue
Antonio Vazquez self-assigned this 2019-04-11 12:24:07 +02:00

I cannot reproduce on Windows 10

Could you download the build of today and test again? Yesterday I did a change to this.

I cannot reproduce on Windows 10 Could you download the build of today and test again? Yesterday I did a change to this.

Added subscriber: @ChristopherAnderssarian

Added subscriber: @ChristopherAnderssarian

See:
#63481 Annotation leaks from nodegroup-level to shader level.blend

  • Open and press tab

I'm guessing the expected behavior is to have a new annotation layer on to of the old one, with every new NodeGroup having its own annotation layer by default...but that feels more like a feature request...

In #63481#658608, @antoniov wrote:
Could you download the build of today..

Windows builder has currently stalled: https://builder.blender.org/admin/#/builders/11

See: [#63481 Annotation leaks from nodegroup-level to shader level.blend](https://archive.blender.org/developer/F6931842/T63481_Annotation_leaks_from_nodegroup-level_to_shader_level.blend) - Open and press tab I'm guessing the expected behavior is to have a new annotation layer on to of the old one, with every new NodeGroup having its own annotation layer by default...but that feels more like a feature request... > In #63481#658608, @antoniov wrote: > Could you download the build of today.. Windows builder has currently stalled: https://builder.blender.org/admin/#/builders/11
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Could you check again (since windows builders are up again)?

Could you check again (since windows builders are up again)?

blender-2.80.0-git.1b839e85e142-windows64 same behaviour as #63481#658801
Maybe if the alignment wasn't offset?

`blender-2.80.0-git.1b839e85e142-windows64` same behaviour as #63481#658801 Maybe if the alignment wasn't offset?

@antoniov Thoughts?

@antoniov Thoughts?

I'm unable to reproduce on my Windows System, maybe I'm doing something wrong.

I'm unable to reproduce on my Windows System, maybe I'm doing something wrong.

@antoniov What do you see when you press tab? (using #63481#658801)

AO.PNG NG.PNG

The explanation is in here #53633#476581, unless you would like to work on this.

@antoniov What do you see when you press tab? (using #63481#658801) | ![AO.PNG](https://archive.blender.org/developer/F7040780/AO.PNG) | ![NG.PNG](https://archive.blender.org/developer/F7040782/NG.PNG) | | -- | -- | The explanation is in here #53633#476581, unless you would like to work on this.
Member

Added subscriber: @DanielBystedt

Added subscriber: @DanielBystedt
Member

I can confirm that annotations in shader editor exists both inside and outside of nodegroup. I don't know if they were intended to NOT be shown with nodegroup hierarchy in mind though (eg bug or feature)

annotations.jpg
System Information
Operating system: Windows-10-10.0.17763-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 432.00

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2019-12-26 19:15, hash: d35a319687

I can confirm that annotations in shader editor exists both inside and outside of nodegroup. I don't know if they were intended to NOT be shown with nodegroup hierarchy in mind though (eg bug or feature) ![annotations.jpg](https://archive.blender.org/developer/F8246881/annotations.jpg) **System Information** Operating system: Windows-10-10.0.17763-SP0 64 Bits Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 432.00 **Blender Version** Broken: version: 2.82 (sub 6), branch: master, commit date: 2019-12-26 19:15, hash: `d35a319687`

By design, the annotations use the full node area and are not limited to the nodegroup. If you make an annotation in the nodegroup and collapse the group, the annotations will be still visible. This reuires a new feature that is not developed.

BTW, I had understood the bug was the annotation was visible outside the area, not outside the nodegroup and this is why I was unable to reproduce. If the bug is that the annotations is visible when the nodegroup is closed, the is not a bug.

By design, the annotations use the full node area and are not limited to the nodegroup. If you make an annotation in the nodegroup and collapse the group, the annotations will be still visible. This reuires a new feature that is not developed. BTW, I had understood the bug was the annotation was visible outside the area, not outside the nodegroup and this is why I was unable to reproduce. If the bug is that the annotations is visible when the nodegroup is closed, the is not a bug.

Changed status from 'Needs Developer To Reproduce' to: 'Archived'

Changed status from 'Needs Developer To Reproduce' to: 'Archived'

Closed due it's an Architecture design limitation. We can open a new ToDo task in the future to resolve this limitation.

Closed due it's an Architecture design limitation. We can open a new ToDo task in the future to resolve this limitation.
Member

Changed status from 'Archived' to: 'Confirmed'

Changed status from 'Archived' to: 'Confirmed'
Member

OK, sorry, if this considered a design limitation, then yes, should be closed according to https://code.blender.org/2019/12/tracker-curfew/

OK, sorry, if this considered a design limitation, then yes, should be closed according to https://code.blender.org/2019/12/tracker-curfew/

Added subscriber: @BartekMoniewski

Added subscriber: @BartekMoniewski

Added subscriber: @3di

Added subscriber: @3di
Philipp Oeser removed the
Interest
Grease Pencil
label 2023-02-09 15:19:59 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#63481
No description provided.