Keyframes and drivers on custom nodes properties seem not working #66392

Open
opened 2019-07-04 00:45:39 +02:00 by Lorenzo Celli · 31 comments

System Information
Operating system: Darwin-18.2.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) Iris(TM) Graphics 540 Intel Inc. 4.1 INTEL-12.4.7

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-02 22:33, hash: 50ccbe6bb2
Worked: (optional)

Short description of error
I'm not able to animate the properties of custom nodes. Keyframes do not work properly: when I set one all the others seem to disappear and only the last value set as a keyframe is shown on every time step.

Exact steps for others to reproduce the error

  1. Go to the text editor, import the 'Custom Nodes' template and run the script.
  2. Open the 'Custom Node Tree' area.
  3. Add a 'Custom Node', in the 'Some Nodes' category.
  4. Add a keyframe for 'my_float_prop' on frame 1.
  5. Change the frame, change 'my_float_prop' value and set a keyframe.
  6. Now I should see (at least it was like this in the last version) the property changing while scrolling through the timeline between the two keyframes I just set, but I don't. The property keeps the last value.
**System Information** Operating system: Darwin-18.2.0-x86_64-i386-64bit 64 Bits Graphics card: Intel(R) Iris(TM) Graphics 540 Intel Inc. 4.1 INTEL-12.4.7 **Blender Version** Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-02 22:33, hash: `50ccbe6bb2` Worked: (optional) **Short description of error** I'm not able to animate the properties of custom nodes. Keyframes do not work properly: when I set one all the others seem to disappear and only the last value set as a keyframe is shown on every time step. **Exact steps for others to reproduce the error** 1. Go to the text editor, import the 'Custom Nodes' template and run the script. 2. Open the 'Custom Node Tree' area. 3. Add a 'Custom Node', in the 'Some Nodes' category. 4. Add a keyframe for 'my_float_prop' on frame 1. 5. Change the frame, change 'my_float_prop' value and set a keyframe. 6. Now I should see (at least it was like this in the last version) the property changing while scrolling through the timeline between the two keyframes I just set, but I don't. The property keeps the last value.
Author

Added subscriber: @lorenzocelli

Added subscriber: @lorenzocelli

#78383 was marked as duplicate of this issue

#78383 was marked as duplicate of this issue

#74050 was marked as duplicate of this issue

#74050 was marked as duplicate of this issue
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Confirmed.

note: #63793, #63548 might be related...

Confirmed. note: #63793, #63548 might be related...

Added subscriber: @Sparazza

Added subscriber: @Sparazza

Added subscribers: @JacquesLucke, @TuomoKeskitalo

Added subscribers: @JacquesLucke, @TuomoKeskitalo

I found out that this bug (keyframing property values is not working for custom nodes) seem to exist also in Animation Nodes on Blender 2.80, FYI @JacquesLucke

I found out that this bug (keyframing property values is not working for custom nodes) seem to exist also in Animation Nodes on Blender 2.80, FYI @JacquesLucke

Hmm, it looks like the animated f-curve evaluates correctly in python console via D.node_groups['NodeTree'].animation_data.action.fcurves- [x].evaluate() even though value shown in node is not updated.

@lorenzocelli can you please test: is the animated value actually changing correctly, even though value is not shown updated on the node?

Hmm, it looks like the animated f-curve evaluates correctly in python console via D.node_groups['NodeTree'].animation_data.action.fcurves- [x].evaluate() even though value shown in node is not updated. @lorenzocelli can you please test: is the animated value actually changing correctly, even though value is not shown updated on the node?
Member

This is a fairly well known limitation. I'm not sure what is needed to make it work, but we should be able to figure that out.
For animation nodes, I usually advice people to not keyframe their nodes but create controller objects in the 3d view instead.

Should still be fixed though... Not sure if there is already another bug report for this.

This is a fairly well known limitation. I'm not sure what is needed to make it work, but we should be able to figure that out. For animation nodes, I usually advice people to not keyframe their nodes but create controller objects in the 3d view instead. Should still be fixed though... Not sure if there is already another bug report for this.
Author

@TuomoKeskitalo I tested it and to me it seems that the properties don't update at all, not in the UI and not by accessing them via python. The last keyframe you set just becomes the value for all frames, ignoring the other keyframes you set before

@TuomoKeskitalo I tested it and to me it seems that the properties don't update at all, not in the UI and not by accessing them via python. The last keyframe you set just becomes the value for all frames, ignoring the other keyframes you set before

It looks like this goes down to somewhere in depsgraph/animation sources of Blender. Beyond my skills, so I hope someone more experienced can help. At least the F-curve is there apparently OK. Thanks @lorenzocelli for confirmation.

It looks like this goes down to somewhere in depsgraph/animation sources of Blender. Beyond my skills, so I hope someone more experienced can help. At least the F-curve is there apparently OK. Thanks @lorenzocelli for confirmation.
Author

Anything new? Maybe I'm missing another similar bug report

Anything new? Maybe I'm missing another similar bug report
Author

Hello everybody! Any news?

Hello everybody! Any news?

Added subscriber: @dr.sybren

Added subscriber: @dr.sybren

In #66392#749929, @JacquesLucke wrote:
This is a fairly well known limitation.

In that case I'll change this task from a Bug to a To Do, and put it in the appropriate work board. It would be nice to lift such a limitation at some point, but that probably would require doing some proper design work.

> In #66392#749929, @JacquesLucke wrote: > This is a fairly well known limitation. In that case I'll change this task from a Bug to a To Do, and put it in the appropriate work board. It would be nice to lift such a limitation at some point, but that probably would require doing some proper design work.

Added subscriber: @RyanSouthall

Added subscriber: @RyanSouthall

Most of my addon's interface is in the form of nodes with their own properties, so I would very much like to see this capability reimplemented.

Most of my addon's interface is in the form of nodes with their own properties, so I would very much like to see this capability reimplemented.
Member

Added subscriber: @roquito17

Added subscriber: @roquito17

Added subscriber: @AhmedKamal

Added subscriber: @AhmedKamal

Added subscriber: @endrju555

Added subscriber: @endrju555

In #66392#749929, @JacquesLucke wrote:
This is a fairly well known limitation. I'm not sure what is needed to make it work, but we should be able to figure that out.
For animation nodes, I usually advice people to not keyframe their nodes but create controller objects in the 3d view instead.

Should still be fixed though... Not sure if there is already another bug report for this.

Hello! Can you tell more about this controllers setup? I can't find informations about how to set it up. I mean in Animation Nodes, because in Node Editor it works when I use drivers

> In #66392#749929, @JacquesLucke wrote: > This is a fairly well known limitation. I'm not sure what is needed to make it work, but we should be able to figure that out. > For animation nodes, I usually advice people to not keyframe their nodes but create controller objects in the 3d view instead. > > Should still be fixed though... Not sure if there is already another bug report for this. Hello! Can you tell more about this controllers setup? I can't find informations about how to set it up. I mean in Animation Nodes, because in Node Editor it works when I use drivers

In #66392#900690, @endrju555 wrote:
Hello! Can you tell more about this controllers setup? I can't find informations about how to set it up. I mean in Animation Nodes, because in Node Editor it works when I use drivers

This is a bug tracker, not a support forum. Please visit https://animation-nodes.com/ for info about Animation Nodes.

> In #66392#900690, @endrju555 wrote: > Hello! Can you tell more about this controllers setup? I can't find informations about how to set it up. I mean in Animation Nodes, because in Node Editor it works when I use drivers This is a bug tracker, not a support forum. Please visit https://animation-nodes.com/ for info about Animation Nodes.

Added subscriber: @ichlubna

Added subscriber: @ichlubna

Yes this is quite an annoying problem. I solved it by using bpy.app.handlers.frame_change_pre but...
EDIT: Seems like I just was able to call update but not to get the actual correct value from the property :-(.
EDIT2: Weird, in compositor for example I can see the good result but not when rendering even when using bpy.app.handlers.render_pre. Seems like when changing frame like when clicking or pressing arrow key the animated value is working but not during render. Is it related to #63548?

Yes this is quite an annoying problem. I solved it by using **bpy.app.handlers.frame_change_pre** but... EDIT: Seems like I just was able to call update but not to get the actual correct value from the property :-(. EDIT2: Weird, in compositor for example I can see the good result but not when rendering even when using bpy.app.handlers.render_pre. Seems like when changing frame like when clicking or pressing arrow key the animated value is working but not during render. Is it related to #63548?

Added subscriber: @matt.dougan

Added subscriber: @matt.dougan

Added subscriber: @rpopovici

Added subscriber: @rpopovici
Philipp Oeser changed title from Keyframes and animations on custom nodes properties seem not working to Keyframes and drivers on custom nodes properties seem not working 2020-11-17 17:28:48 +01:00
Member

Added subscriber: @JerahmyPocott

Added subscriber: @JerahmyPocott

Added subscriber: @Zeastin

Added subscriber: @Zeastin

Added subscriber: @TravisOBrien

Added subscriber: @TravisOBrien

Added subscriber: @Dval

Added subscriber: @Dval
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:36:41 +01:00
Philipp Oeser added the
Interest
Core
label 2023-02-10 11:09:57 +01:00
Sybren A. Stüvel added this to the Animation & Rigging project 2023-02-14 15:32:38 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
17 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#66392
No description provided.