Selected edges hard to see with wireframe display in 2.80 #67637

Closed
opened 2019-07-25 06:24:06 +02:00 by Campbell Barton · 14 comments

Selected edges in vertex select mode are quite hard to see:

This image shows 2.79 & 2.80 comparison with default theme, display options.

edges_hard_to_see.png

edges_hard_to_see.blend


Another example where edges are hard to see (when show edges is enabled - not default, but the geometry should still be visible).

screen.png

Selected edges in vertex select mode are quite hard to see: This image shows 2.79 & 2.80 comparison with default theme, display options. ![edges_hard_to_see.png](https://archive.blender.org/developer/F7627739/edges_hard_to_see.png) [edges_hard_to_see.blend](https://archive.blender.org/developer/F7627741/edges_hard_to_see.blend) ---- Another example where edges are hard to see (when show edges is enabled - not default, but the geometry should still be visible). ![screen.png](https://archive.blender.org/developer/F7720020/screen.png)
Author
Owner

Added subscriber: @ideasman42

Added subscriber: @ideasman42

Added subscriber: @mano-wii

Added subscriber: @mano-wii

I don't know if I missed anything, but the comparison doesn't seem fair because in Blender 2.8 the View3DOverlay.show_edges option is disabled.

I don't know if I missed anything, but the comparison doesn't seem fair because in Blender 2.8 the `View3DOverlay.show_edges` option is disabled.

Added subscribers: @WilliamReynish, @ZedDB

Added subscribers: @WilliamReynish, @ZedDB

Right, I think this was intentional to move the focus to verts in vertex select mode?
@WilliamReynish

Right, I think this was intentional to move the focus to verts in vertex select mode? @WilliamReynish

Here the default wireframe display looks like this:

Verts:
Screenshot 2019-08-01 at 15.35.58.png

Edges:
Screenshot 2019-08-01 at 15.36.28.png

Faces:
Screenshot 2019-08-01 at 15.38.26.png

Here the default wireframe display looks like this: Verts: ![Screenshot 2019-08-01 at 15.35.58.png](https://archive.blender.org/developer/F7641870/Screenshot_2019-08-01_at_15.35.58.png) Edges: ![Screenshot 2019-08-01 at 15.36.28.png](https://archive.blender.org/developer/F7641879/Screenshot_2019-08-01_at_15.36.28.png) Faces: ![Screenshot 2019-08-01 at 15.38.26.png](https://archive.blender.org/developer/F7641908/Screenshot_2019-08-01_at_15.38.26.png)

Added subscriber: @brecht

Added subscriber: @brecht

This seems more like a design discussion than bug report for now. If you guys can agree it's a bug, please triage as appropriate.

This seems more like a design discussion than bug report for now. If you guys can agree it's a bug, please triage as appropriate.
Author
Owner

This has highlight selected edges enabled - which isn't the default.

In #67637#742257, @WilliamReynish wrote:
Here the default wireframe display looks like this:

Verts:
Screenshot 2019-08-01 at 15.35.58.png

This has highlight selected edges enabled - which isn't the default. > In #67637#742257, @WilliamReynish wrote: > Here the default wireframe display looks like this: > > Verts: > ![Screenshot 2019-08-01 at 15.35.58.png](https://archive.blender.org/developer/F7641870/Screenshot_2019-08-01_at_15.35.58.png)
Author
Owner

In #67637#742586, @brecht wrote:
This seems more like a design discussion than bug report for now. If you guys can agree it's a bug, please triage as appropriate.

This seems borderline design issue/bug, if geometry is hard to see by default - it should be resolved with the same priorities assigned to bugs.

Note that there is another report related to this #68106 (Edge select color is blended wrong in vertex select mode).

> In #67637#742586, @brecht wrote: > This seems more like a design discussion than bug report for now. If you guys can agree it's a bug, please triage as appropriate. This seems borderline design issue/bug, if geometry is hard to see by default - it should be resolved with the same priorities assigned to bugs. Note that there is another report related to this #68106 (Edge select color is blended wrong in vertex select mode).

I'm fine either way, it's just that bugs with Needs Triage are the list to be handled by bug triagers, and this one was in an unclear state.

I'm fine either way, it's just that bugs with Needs Triage are the list to be handled by bug triagers, and this one was in an unclear state.

Added subscriber: @davis095381-2

Added subscriber: @davis095381-2

This issue was referenced by 0426866eb0

This issue was referenced by 0426866eb0967f92d521a4278dde8fe139e129c6
Author
Owner

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Campbell Barton self-assigned this 2019-09-09 22:04:31 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#67637
No description provided.