Improve Interior Face Selection Method #68401

Closed
opened 2019-08-08 08:46:57 +02:00 by RobHue · 9 comments

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.35

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: f6cb5f5449
Worked: (optional)

Short description of error
Select > Select By Trait > Interior Faces also selects outer faces

Exact steps for others to reproduce the error

Open up mengerSponge.blend
which contains a menger sponge at level 3; also contains a script to generate menger sponges

0.) go into edit mode
1.) select all
2.) merge by distance (aka remove doubles; merge dist: 0.0001m)
3.) deselect all
4.) Select > Select By Trait > Interior Faces

Result of Interior Face Selection: Does also select additional faces on the outside of the mesh (as shown below in picture01)

  • picture01 showing, that not only the interior faces are selected
    interiorFacesBug.png

  • picture02 showing, that interior face selection works for the menger sponge at level 1
    interFacesWorkingAtLevel1.png

**System Information** Operating system: Windows-10-10.0.17763 64 Bits Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.35 **Blender Version** Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: `f6cb5f5449` Worked: (optional) **Short description of error** Select > Select By Trait > Interior Faces also selects outer faces **Exact steps for others to reproduce the error** Open up [mengerSponge.blend](https://archive.blender.org/developer/F7654070/mengerSponge.blend) *which contains a menger sponge at level 3; also contains a script to generate menger sponges* 0.) go into edit mode 1.) select all 2.) merge by distance (aka remove doubles; merge dist: 0.0001m) 3.) deselect all 4.) Select > Select By Trait > Interior Faces **Result of Interior Face Selection:** Does also select additional faces on the outside of the mesh (as shown below in picture01) - picture01 showing, that not only the interior faces are selected ![interiorFacesBug.png](https://archive.blender.org/developer/F7654067/interiorFacesBug.png) - picture02 showing, that interior face selection works for the menger sponge at level 1 ![interFacesWorkingAtLevel1.png](https://archive.blender.org/developer/F7654080/interFacesWorkingAtLevel1.png)
Author

Added subscriber: @RobHue

Added subscriber: @RobHue

#68337 was marked as duplicate of this issue

#68337 was marked as duplicate of this issue
Author

Could also relate to the problem referred to in the blender source code comment:

C:\blender-git\blender\source\blender\editors\mesh\editmesh_select.c

/** \name Select Interior Faces
*

bool EDBM_select_interior_faces(BMEditMesh *em)

Could also relate to the problem referred to in the blender source code comment: ***C:\blender-git\blender\source\blender\editors\mesh\editmesh_select.c*** > > /** \name Select Interior Faces > * > * \note This algorithm is limited to single faces and could be improved, see: > * https://blender.stackexchange.com/questions/18916 > * \{ */ > > bool EDBM_select_interior_faces(BMEditMesh *em)
Campbell Barton changed title from Interior Face Selection also selects outer faces to Improver Interior Face Selection Method 2019-08-08 09:42:19 +02:00

Added subscriber: @ideasman42

Added subscriber: @ideasman42

This is a known todo, listed it here #63731 (Modeling Module)

This is a known todo, listed it here #63731 (Modeling Module)
Campbell Barton changed title from Improver Interior Face Selection Method to Improve Interior Face Selection Method 2019-08-08 09:45:27 +02:00
Author

The description of the Interior Face Selection Method does what it should be doing:
"Select faces where all edges have more than 2 face users" not sure what users are. Someone said that it could be also refered to as "connected faces".

So yes; it would be rather an improvement than a bug fix.

A more minimal example of interior face selection: (a simple plus made out of 5 boxes merged)
moreMinimalExampleOfInteriorFaceSelectionImprovement.blend

The description of the Interior Face Selection Method does what it should be doing: "Select faces where all edges have more than 2 face users" not sure what users are. Someone said that it could be also refered to as "connected faces". So yes; it would be rather an improvement than a bug fix. A more minimal example of interior face selection: (a simple plus made out of 5 boxes merged) [moreMinimalExampleOfInteriorFaceSelectionImprovement.blend](https://archive.blender.org/developer/F7654130/moreMinimalExampleOfInteriorFaceSelectionImprovement.blend)

Added subscribers: @dadriel, @EAW, @Patnard

Added subscribers: @dadriel, @EAW, @Patnard

This issue was referenced by a9dbc2ef4a

This issue was referenced by a9dbc2ef4a73a26e426704fd22eec630f9685566

Changed status from 'Open' to: 'Resolved'

Changed status from 'Open' to: 'Resolved'
Campbell Barton self-assigned this 2019-09-08 17:50:34 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#68401
No description provided.