Export FBX error with more then 2 layer parent object. #70799

Closed
opened 2019-10-14 06:03:22 +02:00 by Hazuki Aoi · 9 comments

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: f6cb5f5449
Worked: (optional)

Short description of error
When i export fbx file with more then 2 layer parent object, fbx will lost this object.
My object:
image.png

Export FBX:
image.png

Exact steps for others to reproduce the error
Error file is here:
exportError.blend

**System Information** Operating system: Windows-10-10.0.18362 64 Bits Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13 **Blender Version** Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: `f6cb5f5449` Worked: (optional) **Short description of error** When i export fbx file with more then 2 layer parent object, fbx will lost this object. My object: ![image.png](https://archive.blender.org/developer/F7815461/image.png) Export FBX: ![image.png](https://archive.blender.org/developer/F7815465/image.png) **Exact steps for others to reproduce the error** Error file is here: [exportError.blend](https://archive.blender.org/developer/F7815468/exportError.blend)
Author

Added subscriber: @hazukiaoi

Added subscriber: @hazukiaoi

Added subscriber: @mont29

Added subscriber: @mont29

As you can easily check by re-importing back same FBX into Blender, your third object is not lost at all.

Not sure what viewer you are using, but please at least check with either Blender itself, or some reference app like Maya…

As you can easily check by re-importing back same FBX into Blender, your third object is not lost at all. Not sure what viewer you are using, but please at least check with either Blender itself, or some reference app like Maya…

Also, please always try the latest build from our buildbot before reporting a bug.

Also, please always try the latest build from [our buildbot](https://builder.blender.org/download) before reporting a bug.
Author

I import the fbx into Unity, and the object is lost.
And I try to use 95f020c853d6-windows64 can reproduce this problem.
import unity:
image.png

in blender:
image.png

windows 3d viewer:
image.png

I import the fbx into Unity, and the object is lost. And I try to use 95f020c853d6-windows64 can reproduce this problem. import unity: ![image.png](https://archive.blender.org/developer/F7816928/image.png) in blender: ![image.png](https://archive.blender.org/developer/F7816933/image.png) windows 3d viewer: ![image.png](https://archive.blender.org/developer/F7816935/image.png)

Well then… Again, would be best to check with ref app like Maya (in the odd case that Unity would not support multi-level parenting), but besides that, I don’t know what to say… Afaik this has never been an issue before, nothing changed in that code since ages, I would expect it to have been reported already if that had been an issue. :/

Well then… Again, would be best to check with ref app like Maya (in the odd case that Unity would not support multi-level parenting), but besides that, I don’t know what to say… Afaik this has never been an issue before, nothing changed in that code since ages, I would expect it to have been reported already if that had been an issue. :/
Author

I try to use blender-2.82-a8d001fef5e8 to reproduce this problem.

  1. Create three box, and set parent one by one
    image.png
  2. Select all box to fbx and apply transform.
    image.png
  3. Import the fbx file into scene
    image.png
    image.png

So, the last child box dimensions become 0.02(before export all box dimensions is 2), and the position become too close 0,0,0
And I upload the export and re-import video here.
fbx export error.mp4

If the object whth only one layer parent, is all OK. But if more than one , after export it have a error translation.

And I import the fbx into maya and the problem as before.
And screenshot here.
![6JZUUJJZYW)Z]RV9CYRX53L.png](https://archive.blender.org/developer/F7824453/6JZUUJJZYW_Z_RV9CYRX53L.png)
JKJ4GJYNW0W%YQYOV3U$ZNS.png
R7%`X585X)GWRI@V}3CAV(K.png

I try to use blender-2.82-a8d001fef5e8 to reproduce this problem. 1. Create three box, and set parent one by one ![image.png](https://archive.blender.org/developer/F7824339/image.png) 2. Select all box to fbx and apply transform. ![image.png](https://archive.blender.org/developer/F7824342/image.png) 3. Import the fbx file into scene ![image.png](https://archive.blender.org/developer/F7824344/image.png) ![image.png](https://archive.blender.org/developer/F7824347/image.png) So, the last child box dimensions become 0.02(before export all box dimensions is 2), and the position become too close 0,0,0 And I upload the export and re-import video here. [fbx export error.mp4](https://archive.blender.org/developer/F7824351/fbx_export_error.mp4) If the object whth only one layer parent, is all OK. But if more than one , after export it have a error translation. And I import the fbx into maya and the problem as before. And screenshot here. ![6JZUUJJZYW)Z]RV9CYRX53L.png](https://archive.blender.org/developer/F7824453/6JZUUJJZYW_Z_RV9CYRX53L.png) ![JKJ4GJYNW0W%YQYOV3U$ZNS.png](https://archive.blender.org/developer/F7824455/JKJ4GJYNW0W_YQYOV3U_ZNS.png) ![R7%`X585X)GWRI@V}3CAV(K.png](https://archive.blender.org/developer/F7824459/R7__X585X_GWRI_V_3CAV_K.png)

Changed status from 'Open' to: 'Archived'

Changed status from 'Open' to: 'Archived'
Bastien Montagne self-assigned this 2019-10-16 15:18:40 +02:00

So… the '!EXPERIMENTAL! ' warning on that setting (Apply Transform) was removed by accident at some point, it has now been restored. Fact is, that feature/option is known to only work in a very limited cases, and parenting is not supported for that here. So thanks for the report, bug no bug here, just some known limitation.

So… the '!EXPERIMENTAL! ' warning on that setting (Apply Transform) was removed by accident at some point, it has now been restored. Fact is, that feature/option is known to only work in a very limited cases, and parenting is not supported for that here. So thanks for the report, bug no bug here, just some known limitation.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#70799
No description provided.