Automatic UV seam creation tool #71958

Open
opened 2019-11-27 04:16:16 +01:00 by Campbell Barton · 11 comments

Automatic seam creation tool, that balances various goals:

  • Keep angular and area distortion below a given threshold
  • Minimize total length of seams and number of islands
  • Prefer seams along sharp edges / features in the model
  • Prefer seams to be straight instead of jagged
  • Make seams symmetric when there is symmetry in the model
  • Prefer islands for naturally distinct parts of a model (arms, legs, ..)
  • Avoid too complex concave islands shapes that are difficult to pack

Resources:

Split out from #68889.

Automatic seam creation tool, that balances various goals: * Keep angular and area distortion below a given threshold * Minimize total length of seams and number of islands * Prefer seams along sharp edges / features in the model * Prefer seams to be straight instead of jagged * Make seams symmetric when there is symmetry in the model * Prefer islands for naturally distinct parts of a model (arms, legs, ..) * Avoid too complex concave islands shapes that are difficult to pack Resources: * [xatlas](https://github.com/jpcy/xatlas) * [UVAtlas](https://github.com/microsoft/UVAtlas) * [D-Charts: Quasi-Developable Mesh Segmentation](https://www.cs.ubc.ca/~vlady/dcharts/dcharts_eg.pdf) * .. various more papers can be found, also in the field of mesh segmentation Split out from #68889.
Author
Owner

Added subscriber: @ideasman42

Added subscriber: @ideasman42

Added subscriber: @1D_Inc

Added subscriber: @1D_Inc

Sounds like Smart UV project in 3d view -> seams from islands in UV editor.
изображение.png

Or is it something different?

Sounds like **Smart UV project** in 3d view -> **seams from islands** in UV editor. ![изображение.png](https://archive.blender.org/developer/F8304238/изображение.png) Or is it something different?
Contributor

Added subscriber: @KenzieMac130

Added subscriber: @KenzieMac130
Contributor

In #71958#859130, @1D_Inc wrote:
Sounds like Smart UV project in 3d view -> seams from islands in UV editor.
изображение.png

Or is it something different?

Smart UV project isn't exactly the most usable UV unwrapping solution on the market. Compared to recent advancements in UV unwrapping available in other tools (ex: Substance Painter/Houdini/InstaLOD), it really not any good.
The current "Smart" UV is just a dirty hack based on edge angles with no real consideration for the flow of a model's topology or best practices for unwrapping. The proposed tool should be much more robust than that.

> In #71958#859130, @1D_Inc wrote: > Sounds like **Smart UV project** in 3d view -> **seams from islands** in UV editor. > ![изображение.png](https://archive.blender.org/developer/F8304238/изображение.png) > > Or is it something different? Smart UV project isn't exactly the most usable UV unwrapping solution on the market. Compared to recent advancements in UV unwrapping available in other tools (ex: Substance Painter/Houdini/InstaLOD), it really not any good. The current "Smart" UV is just a dirty hack based on edge angles with no real consideration for the flow of a model's topology or best practices for unwrapping. The proposed tool should be much more robust than that.

Well, Smart UV is not a dirty hack, it is just simplest representation of a linear algorithm, that allow to work fast with heavy meshes, or when topology doesnot mean, having a predictable result)
It does it job nice, completing its goal, but the problem that such goal is not universal.

Anyway, it is nice to know that surface/topology tension dependent autoseaming tool was proposed, it will be very helpful)

Well, Smart UV is not a dirty hack, it is just simplest representation of a linear algorithm, that allow to work fast with heavy meshes, or when topology doesnot mean, having a predictable result) It does it job nice, completing its goal, but the problem that such goal is not universal. Anyway, it is nice to know that surface/topology tension dependent autoseaming tool was proposed, it will be very helpful)
Member

Changed status from 'Needs User Info' to: 'Confirmed'

Changed status from 'Needs User Info' to: 'Confirmed'
Contributor

Added subscriber: @Nika-Kutsniashvili

Added subscriber: @Nika-Kutsniashvili
Philipp Oeser removed the
Interest
Modeling
label 2023-02-09 15:29:33 +01:00
Daniel Bystedt added this to the Modeling project 2023-03-14 09:00:08 +01:00

See for example https://blendswap.com/blend/30606
Thanks @1D_Inc !

See for example https://blendswap.com/blend/30606 Thanks @1D_Inc !

@Chris_Blackbourn my .blend for testing.

I spend a week manually uv unwrapping this mesh. It was for a terrain so it had tiling textures that I wanted oriented correctly, and more importantly I wanted very little stretching.

A good autoseam creation tool that follows the sharp angles more cleanly would have saved me hours.

image
image

@Chris_Blackbourn my .blend for testing. I spend a week manually uv unwrapping this mesh. It was for a terrain so it had tiling textures that I wanted oriented correctly, and more importantly I wanted very little stretching. A good autoseam creation tool that follows the sharp angles more cleanly would have saved me hours. ![image](/attachments/c5fae48f-7181-4fb9-be81-8b46582be864) ![image](/attachments/ab081cf6-d3be-494e-96d0-66fe3a44a8dd)

Not sure, but seems to be related
https://blender.community/c/rightclickselect/K8Qn/

Not sure, but seems to be related https://blender.community/c/rightclickselect/K8Qn/
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#71958
No description provided.