Normal Maps causing crazy lag in Eevee #72168

Closed
opened 2019-12-04 16:34:33 +01:00 by Spencer Singer · 7 comments

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 960M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.36

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: 26bd5ebd42
Worked: (optional)

Short description of error
Whenever I decide to use Normal Maps in Eevee, it seems to cause crazy lag, even if the strength is set to 0 or the normal map is just a flat 1x1 pixel. Although if I change it to Bump Map, I get the results I do not want although it becomes lag-free. I find this to be very strange and it most likely is a bug so I thought it should be a good thing to report

Exact steps for others to reproduce the error

  1. Have a rigged model up and ready to go

  2. Add normal maps to it for the materials and BE SURE that the engine is set to Eevee.

  3. Go to material view or renderred view and mess around with the rig and you will notice some lag is present.

Blend File
https://sta.sh/0ypm0uslhvy

**System Information** Operating system: Windows-10-10.0.18362 64 Bits Graphics card: GeForce GTX 960M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.36 **Blender Version** Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: `26bd5ebd42` Worked: (optional) **Short description of error** Whenever I decide to use Normal Maps in Eevee, it seems to cause crazy lag, even if the strength is set to 0 or the normal map is just a flat 1x1 pixel. Although if I change it to Bump Map, I get the results I do not want although it becomes lag-free. I find this to be very strange and it most likely is a bug so I thought it should be a good thing to report **Exact steps for others to reproduce the error** 1. Have a rigged model up and ready to go 2. Add normal maps to it for the materials and BE SURE that the engine is set to Eevee. 3. Go to material view or renderred view and mess around with the rig and you will notice some lag is present. **Blend File** https://sta.sh/0ypm0uslhvy
Author

Added subscriber: @MLSpence

Added subscriber: @MLSpence
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Please attach an example .blend file where this issue occurs [including packed textures]
(This ensure we are all looking at the same thing when investigating...)

Please attach an example .blend file where this issue occurs [including packed textures] (This ensure we are all looking at the same thing when investigating...)
Author

In #72168#824112, @lichtwerk wrote:
Please attach an example .blend file where this issue occurs [including packed textures]
(This ensure we are all looking at the same thing when investigating...)

https://sta.sh/0ypm0uslhvy

Here ya go! (Sorry it’s a little big and I uploaded this one before so it’s a little easier for me to do it like this)

> In #72168#824112, @lichtwerk wrote: > Please attach an example .blend file where this issue occurs [including packed textures] > (This ensure we are all looking at the same thing when investigating...) https://sta.sh/0ypm0uslhvy Here ya go! (Sorry it’s a little big and I uploaded this one before so it’s a little easier for me to do it like this)
Member

Closed as duplicate of #60613

Closed as duplicate of #60613
Member

Added subscribers: @fclem, @EAW

Added subscribers: @fclem, @EAW
Member

It says that the file is no longer available when I try to download it.

I have merged this into a previous report (#60613) where @fclem explains that this a current know limitation.

It says that the file is no longer available when I try to download it. I have merged this into a previous report (#60613) where @fclem explains that this a current know limitation.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#72168
No description provided.