[Mantaflow] initial velocity ignored in the emission object #72949

Closed
opened 2020-01-07 13:30:12 +01:00 by michael campbell · 21 comments

System Information
Operating system: Windows-10-10.0.17134-SP0 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-01-06 20:54, hash: 3a35301fd1
Worked: (optional)

Short description of error
initial velocity ignored in the mantraflow emission object

Exact steps for others to reproduce the error

  • Open file and run simulation.
    liquid.blend
    (In the file the initial velocity is pointed to normal).
**System Information** Operating system: Windows-10-10.0.17134-SP0 64 Bits Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86 **Blender Version** Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-01-06 20:54, hash: `3a35301fd1` Worked: (optional) **Short description of error** initial velocity ignored in the mantraflow emission object **Exact steps for others to reproduce the error** - Open file and run simulation. [liquid.blend](https://archive.blender.org/developer/F8264307/liquid.blend) (In the file the initial velocity is pointed to normal).

Added subscriber: @3di

Added subscriber: @3di

#72516 was marked as duplicate of this issue

#72516 was marked as duplicate of this issue

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Germano Cavalcante changed title from initial velocity ignored in the mantraflow emission object when set to normal to [Mantaflow] initial velocity ignored in the emission object 2020-01-10 19:22:47 +01:00
Added subscribers: @Lumpengnom-3, @PeterBoos, @GottfriedHofmann, @filibis, @luca1995, @Lazza, @ScottWood, @laurijh
Sebastián Barschkis was assigned by Bastien Montagne 2020-01-14 14:48:04 +01:00

This is maybe something that requires some GUI and concept rethinking.
I managed to get an inflow working based upon a plane with a thickness of 1.0
Maybe initial velocities should only be for an inflow plane based, and not be for full meshes with a starting velocity.
I mean it makes more sense that a hoze provides a stream of liquid then a solid shape has certain speed on start.

Here is the file in wich it works for an inflow{F8278636}

This is maybe something that requires some GUI and concept rethinking. I managed to get an inflow working based upon a plane with a thickness of 1.0 Maybe initial velocities should only be for an inflow plane based, and not be for full meshes with a starting velocity. I mean it makes more sense that a hoze provides a stream of liquid then a solid shape has certain speed on start. Here is the file in wich it works for an inflow{[F8278636](https://archive.blender.org/developer/F8278636/Fluid_works.blend)}

I can confirm that a surface thickness of >0.0 circumvents the bug.

I can confirm that a surface thickness of >0.0 circumvents the bug.

Can you post a file showing to us how you did it? I've tried what you said but isn't working for me

Can you post a file showing to us how you did it? I've tried what you said but isn't working for me

In #72949#853014, @Lazza wrote:
Can you post a file showing to us how you did it? I've tried what you said but isn't working for me

Here you go: manta_initial.blend

> In #72949#853014, @Lazza wrote: > Can you post a file showing to us how you did it? I've tried what you said but isn't working for me Here you go: [manta_initial.blend](https://archive.blender.org/developer/F8288211/manta_initial.blend)

Added subscriber: @zeauro

Added subscriber: @zeauro

It looks like surface thickness is used as a multiplier of velocity for liquids.

It looks like surface thickness is used as a multiplier of velocity for liquids.

In #72949#853079, @zeauro wrote:
It looks like surface thickness is used as a multiplier of velocity for liquids.

I've tried what you wrote. It's not perfectly exact. Actually the surface thickness multiplies the initial velocity only. Infact it doesn't change the gravity force. By the way thank you! You really made it work. Now: Is it wanted? I mean, is the surface thinckness doing this because it is right? According to its description it should control the !!maximum distance from mesh surface to emit fluid!!. We will wait for @sebbas to tell us if it's all right.

> In #72949#853079, @zeauro wrote: > It looks like surface thickness is used as a multiplier of velocity for liquids. I've tried what you wrote. It's not perfectly exact. Actually the surface thickness multiplies the **initial velocity only**. Infact it doesn't change the gravity force. By the way thank you! You really made it work. Now: Is it wanted? I mean, is the surface thinckness doing this because it is right? According to its description it should control the !!maximum distance from mesh surface to emit fluid!!. We will wait for @sebbas to tell us if it's all right.

Added subscriber: @Rogo

Added subscriber: @Rogo

In #72949#853286, @Lazza wrote:

Actually the surface thickness multiplies the initial velocity only.

Surface thickness multiplies fluid collision probability as well. It's like two different parameters are driven by one slider.
I think #73161 is related to this one.

> In #72949#853286, @Lazza wrote: > >Actually the surface thickness multiplies the **initial velocity only**. Surface thickness multiplies fluid collision probability as well. It's like two different parameters are driven by one slider. I think #73161 is related to this one.

In a sense they're related they together decide fluid particle density maybe a factor would be easier if we think of fluid inflows as planes. Well this is how I understand it.

In a sense they're related they together decide fluid particle density maybe a factor would be easier if we think of fluid inflows as planes. Well this is how I understand it.

@sebbas Please divide those options: "Surface thickness" and influence of the effectors.

@sebbas Please divide those options: "Surface thickness" and influence of the effectors.

Would it not make more sense to just have options to emit from face, edges, vertices (with the ability to select all 3)? And then have an offset option in scene units. The initial velocity shouldn't really be anything to do with where the water is emitting from or how far from the object it starts.

Would it not make more sense to just have options to emit from face, edges, vertices (with the ability to select all 3)? And then have an offset option in scene units. The initial velocity shouldn't really be anything to do with where the water is emitting from or how far from the object it starts.

Added subscriber: @michael-123

Added subscriber: @michael-123

@michael-123 Campbell maybe it's time to think about units sizes and stamdardisation of units it can be a problem in STL experts and measureit add-on normally I keep printing stl standard as mm. The same goes for time in particles mayveas a default use 25fps and 1ms for particles recalculate.values based upon the FPS.

On side note there are also problems with object origin and fluid domain as well

@michael-123 Campbell maybe it's time to think about units sizes and stamdardisation of units it can be a problem in STL experts and measureit add-on normally I keep printing stl standard as mm. The same goes for time in particles mayveas a default use 25fps and 1ms for particles recalculate.values based upon the FPS. On side note there are also problems with object origin and fluid domain as well

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'

Closing this report since it seems no longer to be an issue. In summary, plane emission objects need to have some "thickness" (non zero) in order to emit fluid.

Closing this report since it seems no longer to be an issue. In summary, plane emission objects need to have some "thickness" (non zero) in order to emit fluid.

Update: I just committed cda81d5a4d which makes it easier to setup planar flow / obstacle objects. They now have some "thickness" by default and users will only have to mark them as "Is Planar" in the flow / effector settings (see also #73866).

Update: I just committed cda81d5a4d39 which makes it easier to setup planar flow / obstacle objects. They now have some "thickness" by default and users will only have to mark them as "Is Planar" in the flow / effector settings (see also #73866).
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
9 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#72949
No description provided.