Dynamic grid, texel size and pixel resolution #78389

Closed
opened 2020-06-28 20:18:40 +02:00 by Daniel Bystedt · 6 comments
Member

UI

{F8651863, height = 300}
UI Example UI from UV-editor

This design is related to
https://developer.blender.org/T78391

Settings in the uv editor for the following:

Dynamic grid size

  • How many units in UV-space is a grid unit. It can be handy with a dynamic grid size. Sometimes you need to snap to a texture atlas that is divided into a 6x6 grid within a 0-1 uv space. Note: The UV 0-1 space is always static (eg the true UV unit length is always the same).
image.png image.png
Dynamic grid = 4 (4 grids per UV unit) Dynamic grid = 2 (2 grids per UV unit)

Texel size:

  • How many units in uv space one unit in 3d space represents. This can be used to get consistent texture scale when using tiling textures.
  • Texel size should affect unwrap, but not packing since we usually want to pack into a specific area.

Sample texel size

  • Add operator for “Sample texel size, which sets texel size from selected object(s) in 3d view

Pixel resolution:

  • How big is a pixel in uv space when no image is assigned in the uv editor. This can be used for UV move up/down/left/right (described in other UV editing design).
{F8651868, height = 300} {F8651871, height = 300}
1 unit in 3d = 0.5 units in UV space (i.e Texel size = 0.5) Texel size = 0.5 (i.e edge length = orig length * Texel size
{F8651875, height = 300}}
The goal is to get consistent texture scale between objects and faces when unwrapping. The Texel size acts as a scale multiplier to the unwrapped uv’s
**UI** |{[F8651863](https://archive.blender.org/developer/F8651863/image.png), height = 300}| | -- | |UI Example UI from UV-editor| This design is related to https://developer.blender.org/T78391 **Settings in the uv editor for the following:** **Dynamic grid size** - How many units in UV-space is a grid unit. It can be handy with a dynamic grid size. Sometimes you need to snap to a texture atlas that is divided into a 6x6 grid within a 0-1 uv space. Note: The UV 0-1 space is always static (eg the true UV unit length is always the same). |![image.png](https://archive.blender.org/developer/F8651928/image.png) |![image.png](https://archive.blender.org/developer/F8651931/image.png) | | -- | -- | |Dynamic grid = 4 (4 grids per UV unit) | Dynamic grid = 2 (2 grids per UV unit)| **Texel size:** - How many units in uv space one unit in 3d space represents. This can be used to get consistent texture scale when using tiling textures. - Texel size should affect unwrap, but not packing since we usually want to pack into a specific area. **Sample texel size** - Add operator for “Sample texel size, which sets texel size from selected object(s) in 3d view **Pixel resolution:** - How big is a pixel in uv space when no image is assigned in the uv editor. This can be used for UV move up/down/left/right (described in other UV editing design). | {[F8651868](https://archive.blender.org/developer/F8651868/image.png), height = 300}|{[F8651871](https://archive.blender.org/developer/F8651871/image.png), height = 300} | | -- | -- | |1 unit in 3d = 0.5 units in UV space (i.e Texel size = 0.5)| Texel size = 0.5 (i.e edge length = orig length * Texel size| |{[F8651875](https://archive.blender.org/developer/F8651875/image.png), height = 300}} | | -- | |The goal is to get consistent texture scale between objects and faces when unwrapping. The Texel size acts as a scale multiplier to the unwrapped uv’s|
Author
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Author
Member

Added subscribers: @DanielBystedt, @ideasman42

Added subscribers: @DanielBystedt, @ideasman42

Added subscriber: @APEC

Added subscriber: @APEC

Added subscriber: @Idlero

Added subscriber: @Idlero

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Campbell Barton self-assigned this 2022-04-27 09:28:02 +02:00

Closing as this has been committed.

Closing as this has been committed.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#78389
No description provided.