Mantaflow: motion blur does not work on liquids cached with OpenVDB format #78442

Open
opened 2020-06-29 19:34:05 +02:00 by Steffen Dünner · 24 comments

System Information
Operating system: Linux-5.4.45-050445-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 450.36.06

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-29 16:20, hash: 5d31ef0820
Worked: 2.83.1

Short description of error
A FLIP fluid mesh no renders with motion blur in Cycles (despite the "Use Speed Vectors" option is checked) when OpenVDB cache is used.
image.png

Exact steps for others to reproduce the error

  • Open the attached blend file or create a super simple scene yourself by:
- add a cube as a fluid domain,
- add another cube inside it as inflow.
- Set both to be of fluid type.
- Under the "Mesh" options check "Use Speed Vectors"
- Activate motion blur in Cycles.
- Set cache type to OpenVDB
  • Go to frame 20 (where the falling liquid should show motion blur) and press F12
    No motion blur
    This exact workflow rendered with motion blur in 2.83.1 official
    Eevee also doesn't show motion blur
    If I open the cached VDB sequence in Houdini I can see a velocity field and vdb particles containing motion blur vectors.

Mantaflow_MB_Bug_v01.blend

**System Information** Operating system: Linux-5.4.45-050445-generic-x86_64-with-debian-buster-sid 64 Bits Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 450.36.06 **Blender Version** Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-29 16:20, hash: `5d31ef0820` Worked: 2.83.1 **Short description of error** A FLIP fluid mesh no renders with motion blur in Cycles (despite the "Use Speed Vectors" option is checked) when OpenVDB cache is used. ![image.png](https://archive.blender.org/developer/F8653966/image.png) **Exact steps for others to reproduce the error** - Open the attached blend file or create a super simple scene yourself by: ``` - add a cube as a fluid domain, - add another cube inside it as inflow. - Set both to be of fluid type. - Under the "Mesh" options check "Use Speed Vectors" - Activate motion blur in Cycles. - Set cache type to OpenVDB ``` - Go to frame 20 (where the falling liquid should show motion blur) and press F12 No motion blur This exact workflow rendered with motion blur in 2.83.1 official Eevee also doesn't show motion blur If I open the cached VDB sequence in Houdini I can see a velocity field and vdb particles containing motion blur vectors. [Mantaflow_MB_Bug_v01.blend](https://archive.blender.org/developer/F8653968/Mantaflow_MB_Bug_v01.blend)

Added subscriber: @SteffenD

Added subscriber: @SteffenD

#91365 was marked as duplicate of this issue

#91365 was marked as duplicate of this issue

#81654 was marked as duplicate of this issue

#81654 was marked as duplicate of this issue

#81202 was marked as duplicate of this issue

#81202 was marked as duplicate of this issue

Added subscriber: @mano-wii

Added subscriber: @mano-wii

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'

I cannot reproduce this with the current development versions of Blender: https://builder.blender.org/download/

See the blur at the bottom of the fluid:
fluid_sim_result.png

In the file I had to choose a cache format, otherwise the simulation was not baked.

Go to File → Defaults → Load Factory Settings and then load your file to see if you still can reproduce this issue.

I cannot reproduce this with the current development versions of Blender: https://builder.blender.org/download/ See the blur at the bottom of the fluid: ![fluid_sim_result.png](https://archive.blender.org/developer/F8655313/fluid_sim_result.png) In the file I had to choose a cache format, otherwise the simulation was not baked. Go to File → Defaults → Load Factory Settings and then load your file to see if you still can reproduce this issue.

Thanks for investigating.

I can reproduce the problem with both, my own compile of master and the very latest buildbot build (both on Linux).
Loading factory defaults doesn't help, caching to VDBs doesn't help as well BUT caching to "Uni Cache" works, even when setting the mode to "Replay" to use the "live" version.
So it looks like a problem (Linux only?) that likely started to appear when Sebbas changed the VDB caching to cache multiple fields / grids?

Thanks for investigating. I can reproduce the problem with both, my own compile of master and the very latest buildbot build (both on Linux). Loading factory defaults doesn't help, caching to VDBs doesn't help as well BUT caching to "Uni Cache" works, even when setting the mode to "Replay" to use the "live" version. So it looks like a problem (Linux only?) that likely started to appear when Sebbas changed the VDB caching to cache multiple fields / grids?

Changed status from 'Needs User Info' to: 'Needs Triage'

Changed status from 'Needs User Info' to: 'Needs Triage'

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

I can confirm with OpenVDB.

I can confirm with OpenVDB.

Nice! Good to hear that I'm not the only one ;)

Nice! Good to hear that I'm not the only one ;)

Added subscriber: @sebbas

Added subscriber: @sebbas

Small update: Since 6b6e2e742f motion blur works again when using "Uni" as the format for volumes. Motion blur support with OpenVDB remains to do.

EDIT: Motion blur with "Uni" caching seemed to work before too - in that case this was more of a clean up, e.g. the mesh file were written twice per frame under different names before.

Small update: Since 6b6e2e742ff4 motion blur works again when using "Uni" as the format for volumes. Motion blur support with OpenVDB remains to do. EDIT: Motion blur with "Uni" caching seemed to work before too - in that case this was more of a clean up, e.g. the mesh file were written twice per frame under different names before.

Added subscriber: @Mantissa

Added subscriber: @Mantissa

Added subscribers: @juang3d, @iss, @Lazza

Added subscribers: @juang3d, @iss, @Lazza
Germano Cavalcante changed title from Mantaflow no longer renders motion blur to Mantaflow: motion blur does not work on liquids cached with OpenVDB format 2020-10-13 23:15:17 +02:00

Added subscriber: @koko_ze

Added subscriber: @koko_ze

Added subscribers: @Yerus_Ovelha, @deadpin

Added subscribers: @Yerus_Ovelha, @deadpin

Added subscriber: @zebus3dream

Added subscriber: @zebus3dream

Added subscriber: @Rowan-Ibbeken

Added subscriber: @Rowan-Ibbeken

Has there been any progress on enabling motion blur for Open VDB volumes/liquids?

Has there been any progress on enabling motion blur for Open VDB volumes/liquids?

Mantaflow (fluid simulator) has no active developer at the moment. Moving those bugs as known issues so at least other users can find their issues already reported.

Mantaflow (fluid simulator) has no active developer at the moment. Moving those bugs as known issues so at least other users can find their issues already reported.

Added subscriber: @RomboutVersluijs

Added subscriber: @RomboutVersluijs

Aside from this, importing this ovb data results in nothing. I only see speed vectory and particles when i import the data.

Aside from this, importing this ovb data results in nothing. I only see speed vectory and particles when i import the data.
Philipp Oeser removed the
Interest
Nodes & Physics
label 2023-02-10 08:46:45 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
11 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#78442
No description provided.