eevee pixel artifacts, holdout mixed with lightpathnode, reinforced with bloom and Dof #81092

Closed
opened 2020-09-23 15:35:22 +02:00 by Tobias elixmann · 15 comments

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 445.87

Blender Version
Broken: version: 2.90.0, branch: master, commit date: 2020-08-31 11:26, hash: 0330d1af29
Broken in 2.90 and 2.91
Worked: 2.83.5 2.83.6

Short description of error
Eevee produced pixelartifacts when using a holdout-shader for composting. Reinforced by bloom and Dof.
The rendered Image differs with different camera-settings for f-Stop.

Exact steps for others to reproduce the error
see file: render f12, there is a bright spot in the rendered image. change f-stop to 2.1, the bright spot dissapears.
Using 'is camera-ray' or' is shadow-ray' in the nodetree both produced the pixelartifacts.

PixelFehler.blend

**System Information** Operating system: Windows-10-10.0.19041-SP0 64 Bits Graphics card: GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 445.87 **Blender Version** Broken: version: 2.90.0, branch: master, commit date: 2020-08-31 11:26, hash: `0330d1af29` Broken in 2.90 and 2.91 Worked: 2.83.5 2.83.6 **Short description of error** Eevee produced pixelartifacts when using a holdout-shader for composting. Reinforced by bloom and Dof. The rendered Image differs with different camera-settings for f-Stop. **Exact steps for others to reproduce the error** see file: render f12, there is a bright spot in the rendered image. change f-stop to 2.1, the bright spot dissapears. Using 'is camera-ray' or' is shadow-ray' in the nodetree both produced the pixelartifacts. [PixelFehler.blend](https://archive.blender.org/developer/F8912052/PixelFehler.blend)

Added subscriber: @TobiasElixmann

Added subscriber: @TobiasElixmann

Added subscriber: @mano-wii

Added subscriber: @mano-wii

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

I can confirm.
It is related to Boom, Depth of Field (from the camera) and Transparence.
If you disable any of these, the problem goes away.

I can confirm. It is related to Boom, Depth of Field (from the camera) and Transparence. If you disable any of these, the problem goes away.

Added subscriber: @fclem

Added subscriber: @fclem

Should be fixed by new Depth of Field when merged (D10238).

Should be fixed by new Depth of Field when merged ([D10238](https://archive.blender.org/developer/D10238)).

This issue was referenced by 000a340afa

This issue was referenced by 000a340afa67a12a38c103e19f7d52ed42c4492e

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Clément Foucault self-assigned this 2021-02-12 22:37:06 +01:00

Added subscriber: @brothermechanic

Added subscriber: @brothermechanic

Screenshot_20210331_010844.jpg
not fixed in 2.93-master
(in 2.92 all is perfect)

![Screenshot_20210331_010844.jpg](https://archive.blender.org/developer/F9915028/Screenshot_20210331_010844.jpg) not fixed in 2.93-master (in 2.92 all is perfect)

Screenshot_20210331_014644.jpg
temporarily fixed by replacing the Principled BSDF shader with the custom and turning off transparency mode to Opaque

![Screenshot_20210331_014644.jpg](https://archive.blender.org/developer/F9915075/Screenshot_20210331_014644.jpg) temporarily fixed by replacing the Principled BSDF shader with the custom and turning off transparency mode to Opaque

here is different: broken in 292 but fixed in 293

here is different: broken in 292 but fixed in 293

Different scene, New test:
292:
Blender292.png
293:
Blender293.png

Different scene, New test: 292: ![Blender292.png](https://archive.blender.org/developer/F9918929/Blender292.png) 293: ![Blender293.png](https://archive.blender.org/developer/F9918932/Blender293.png)

when i applyed the rotation of one object of the plane, the bright spot went away...

when i applyed the rotation of one object of the plane, the bright spot went away...

In #81092#1138744, @brothermechanic wrote:
Screenshot_20210331_010844.jpg
not fixed in 2.93-master
(in 2.92 all is perfect)

Looks like issue was fixed in latest git!
Thank you, blender developers!

> In #81092#1138744, @brothermechanic wrote: > ![Screenshot_20210331_010844.jpg](https://archive.blender.org/developer/F9915028/Screenshot_20210331_010844.jpg) > not fixed in 2.93-master > (in 2.92 all is perfect) Looks like issue was fixed in latest git! Thank you, blender developers!
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#81092
No description provided.