Apply modifiers on objects with shapekeys (with some exceptions) #86095

Open
opened 2021-02-28 17:28:13 +01:00 by Daniel Bystedt · 4 comments
Member

This feature request was discussed with Campbell Barton during meeting 2021-02-23

Currently it is not possible to apply modifiers to an object that has shapekeys, even though it would be technically possible for most modifiers. I suggest making it possible to apply modifiers to objects with shapekeys with some exceptions.

image.png

For example:

The subdivision and wire modifier does not modify the objects topology as the shape change. This modifier could be applied while still keeping the shape keys.


Screen capture example of how to apply modifiers and keep shapekeys.
apply modifiers with shape keys.mp4


Modifiers that can't be applied in a simple way when the object has shapekeys.

  • Boolean
  • Build
  • Decimate
  • Geometry nodes (in some cases. Easiest to just exclude this modifier)
  • Mirror (IF USING BISECT)
  • Remesh
  • Skin
  • Volume to mesh
  • Weld
  • Explode
  • Fluid
  • Ocean
  • Particle instance (Since source particle system density mapping can be applied in world space)
  • Particle system

image.png

When the user tries to apply any of these modifiers when the object has shape keys, the error message should be:
Modifier that changes topology based on shape cannot be applied to a mesh with shape keys

Note:
When applying a modifer of type "Modify" (for example "Data transfer"), the current shape should be used when applying the modifier (i.e. the resulting shape of all combination and values of the objects shape keys)

This feature request was discussed with Campbell Barton during meeting 2021-02-23 Currently it is not possible to apply modifiers to an object that has shapekeys, even though it would be technically possible for most modifiers. I suggest making it possible to apply modifiers to objects with shapekeys with some exceptions. ![image.png](https://archive.blender.org/developer/F9852542/image.png) For example: The subdivision and wire modifier does not modify the objects topology as the shape change. This modifier could be applied while still keeping the shape keys. --- Screen capture example of how to apply modifiers and keep shapekeys. [apply modifiers with shape keys.mp4](https://archive.blender.org/developer/F9852630/apply_modifiers_with_shape_keys.mp4) --- Modifiers that can't be applied in a simple way when the object has shapekeys. - Boolean - Build - Decimate - Geometry nodes (in some cases. Easiest to just exclude this modifier) - Mirror (**IF USING BISECT**) - Remesh - Skin - Volume to mesh - Weld - Explode - Fluid - Ocean - Particle instance (Since source particle system density mapping can be applied in world space) - Particle system ![image.png](https://archive.blender.org/developer/F9852666/image.png) When the user tries to apply any of these modifiers when the object has shape keys, the error message should be: ***Modifier that changes topology based on shape cannot be applied to a mesh with shape keys*** Note: When applying a modifer of type "Modify" (for example "Data transfer"), the current shape should be used when applying the modifier (i.e. the resulting shape of all combination and values of the objects shape keys)
Author
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Author
Member

Added subscriber: @DanielBystedt

Added subscriber: @DanielBystedt
Author
Member

Added subscriber: @ideasman42

Added subscriber: @ideasman42
Member

Added subscriber: @BClark

Added subscriber: @BClark
Philipp Oeser removed the
Interest
Modeling
label 2023-02-09 15:28:39 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#86095
No description provided.