LineArt; Crahes when I reopen a file #86900

Open
opened 2021-03-24 19:16:09 +01:00 by pafurijaz-4 · 10 comments

System Information
An old HP laptop with
Operating system: Linux Ubuntu 18.04.5 LTS
Graphics card: Mesa DRI Intel(R) HD Graphics 5500 (BDW GT2)

Blender Version
Broken: Blender 2.93.0 Alpha, 3ea1779365, master, 2021-03-23 18:34
Worked: (newest version of Blender that worked as expected)

Short description of error

Exact steps for others to reproduce the error
I added two GP LineArt on the scene and it worked and then I saved the scene, with new grease pencil modifiers activated, but when I try to reopen in Blender the same scene crashes every times and I'm not able to see anythings after waiting the processing until crashes without any report. the file is attached.

yach.tar.xz

**System Information** An old HP laptop with Operating system: Linux Ubuntu 18.04.5 LTS Graphics card: Mesa DRI Intel(R) HD Graphics 5500 (BDW GT2) **Blender Version** Broken: Blender 2.93.0 Alpha, 3ea1779365b5, master, 2021-03-23 18:34 Worked: (newest version of Blender that worked as expected) **Short description of error** **Exact steps for others to reproduce the error** I added two GP LineArt on the scene and it worked and then I saved the scene, with new grease pencil modifiers activated, but when I try to reopen in Blender the same scene crashes every times and I'm not able to see anythings after waiting the processing until crashes without any report. the file is attached. [yach.tar.xz](https://archive.blender.org/developer/F9908120/yach.tar.xz)
Author

Added subscriber: @pafurijaz-4

Added subscriber: @pafurijaz-4

Added subscribers: @ChengduLittleA, @antoniov

Added subscribers: @ChengduLittleA, @antoniov

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

I can confirm. The crasjh is in BKE_mesh_nurbs_displist_to_mdata()

Callstack:

BKE_mesh_from_nurbs_displist
mesh_new_from_curve_type_object
lineart_geometry_object_load
lineart_main_load_geometries
MOD_lineart_compute_feature_lines
generateStrokes(
BKE_gpencil_modifiers_calc
BKE_object_handle_data_update
BKE_object_eval_uber_data

@NicksBest Could you take a look?

I can confirm. The crasjh is in `BKE_mesh_nurbs_displist_to_mdata()` Callstack: ```BKE_mesh_nurbs_displist_to_mdata BKE_mesh_from_nurbs_displist mesh_new_from_curve_type_object lineart_geometry_object_load lineart_main_load_geometries MOD_lineart_compute_feature_lines generateStrokes( BKE_gpencil_modifiers_calc BKE_object_handle_data_update BKE_object_eval_uber_data ``` @NicksBest Could you take a look?
Antonio Vazquez changed title from Crahes when I reopen a file with LineArt settings to LineArt; Crahes when I reopen a file 2021-03-24 20:08:58 +01:00
YimingWu self-assigned this 2021-03-26 15:46:40 +01:00
Member

This looks like a curve object data issue. I'll investigate.

This looks like a curve object data issue. I'll investigate.
Author

Hi I have an other file with the same problem, this seem to me a problem related to adaptive modifiers but I really don't know why, this has only a line-art modifier on a simple mesh lines for the measures and also this don't works please before release the final version, resolve this bug, because this at the end save a corrupted file and that was impossible to reopen because goes in continuous bug crash, and the file is impossible to recovers with Blender 2.93. I successful opened on time but the thing is not replicable, and I don't understand why.

# Blender 2.93.0, Commit date: 2021-04-21 20:15, Hash 0f66dbea904f

# backtrace
./blender(BLI_system_backtrace+0x20) [0xa595c20]
./blender() [0xf6091a]
/lib/x86_64-linux-gnu/libc.so.6(+0x3f040) [0x7f6bb2aaf040]
./blender(BKE_mesh_nurbs_displist_to_mdata+0x836) [0x12d57e6]
./blender(BKE_mesh_from_nurbs_displist+0x261) [0x12d72c1]
./blender(BKE_mesh_new_from_object+0x27e) [0x12d76be]
./blender() [0x1eda3f5]
./blender(MOD_lineart_compute_feature_lines+0x53e) [0x1edb7be]
./blender() [0x1ecba3b]
./blender(BKE_gpencil_modifiers_calc+0x121) [0xf8fba1]
./blender(BKE_object_handle_data_update+0x394) [0xffaf74]
./blender(BKE_object_eval_uber_data+0x2f) [0xffb34f]
./blender() [0x86d54dc]
./blender() [0x86d5672]
./blender() [0x13060a5]
./blender() [0xa599823]
./blender() [0x13045d5]
./blender() [0x130488b]
./blender() [0x1305db7]
./blender() [0x12feb30]
./blender() [0x130028c]
./blender() [0x1300489]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x76db) [0x7f6bb41f46db]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x3f) [0x7f6bb2b9171f]

# Python backtrace

SubMarineCapsule_bug.blend

Hi I have an other file with the same problem, this seem to me a problem related to adaptive modifiers but I really don't know why, this has only a line-art modifier on a simple mesh lines for the measures and also this don't works please before release the final version, resolve this bug, because this at the end save a corrupted file and that was impossible to reopen because goes in continuous bug crash, and the file is impossible to recovers with Blender 2.93. I successful opened on time but the thing is not replicable, and I don't understand why. ``` # Blender 2.93.0, Commit date: 2021-04-21 20:15, Hash 0f66dbea904f # backtrace ./blender(BLI_system_backtrace+0x20) [0xa595c20] ./blender() [0xf6091a] /lib/x86_64-linux-gnu/libc.so.6(+0x3f040) [0x7f6bb2aaf040] ./blender(BKE_mesh_nurbs_displist_to_mdata+0x836) [0x12d57e6] ./blender(BKE_mesh_from_nurbs_displist+0x261) [0x12d72c1] ./blender(BKE_mesh_new_from_object+0x27e) [0x12d76be] ./blender() [0x1eda3f5] ./blender(MOD_lineart_compute_feature_lines+0x53e) [0x1edb7be] ./blender() [0x1ecba3b] ./blender(BKE_gpencil_modifiers_calc+0x121) [0xf8fba1] ./blender(BKE_object_handle_data_update+0x394) [0xffaf74] ./blender(BKE_object_eval_uber_data+0x2f) [0xffb34f] ./blender() [0x86d54dc] ./blender() [0x86d5672] ./blender() [0x13060a5] ./blender() [0xa599823] ./blender() [0x13045d5] ./blender() [0x130488b] ./blender() [0x1305db7] ./blender() [0x12feb30] ./blender() [0x130028c] ./blender() [0x1300489] /lib/x86_64-linux-gnu/libpthread.so.0(+0x76db) [0x7f6bb41f46db] /lib/x86_64-linux-gnu/libc.so.6(clone+0x3f) [0x7f6bb2b9171f] # Python backtrace ``` [SubMarineCapsule_bug.blend](https://archive.blender.org/developer/F10032739/SubMarineCapsule_bug.blend)
Member

This looks like still a curve displist problem. I'll see what I can do here.

This looks like still a curve `displist` problem. I'll see what I can do here.
Author

This file F9908120, with latest build, now freezes OS, any solutions before release on May 26?

This file [F9908120](https://archive.blender.org/developer/F9908120/yach.tar.xz), with latest build, now freezes OS, any solutions before release on May 26?
Member

I'll test... current solution is just to append the file into anther file and convert everything to mesh before you add line art.

I'll test... current solution is just to append the file into anther file and convert everything to mesh before you add line art.
Author

OK thanks, for now but I hope there is a solutions in some how in the future.

OK thanks, for now but I hope there is a solutions in some how in the future.
Philipp Oeser removed the
Interest
Grease Pencil
label 2023-02-09 15:19:40 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#86900
No description provided.