Failed assert when dragging object data-block into 3D View #87703

Closed
opened 2021-04-22 11:24:42 +02:00 by Julian Eisel · 10 comments
Member

System Information
Operating system: Linux-5.11.0-7612-generic-x86_64-with-glibc2.32 64 Bits
Graphics card: Radeon Vega Frontier Edition (VEGA10, DRM 3.40.0, 5.11.0-7612-generic, LLVM 11.0.0) AMD 4.6 (Core Profile) Mesa 21.0.0

Blender Version
Broken: version: 3.0.0 Alpha, 33d9a0c951

Short description of error
The object duplication triggered by dropping an object into a 3D View causes this:

BLI_assert failed: source/blender/blenkernel/intern/object.c:2773, BKE_object_duplicate(), at '(id_iter->tag & LIB_TAG_NEW) == 0'

Note that this doesn't happen for {key Shift D} object duplication because that uses LIB_ID_DUPLICATE_IS_SUBPROCESS, meaning the code-path with the assert is skipped.

Exact steps for others to reproduce the error

  • Factory startup in a debug build
  • In the outliner, click and drag any object into the 3D View
**System Information** Operating system: Linux-5.11.0-7612-generic-x86_64-with-glibc2.32 64 Bits Graphics card: Radeon Vega Frontier Edition (VEGA10, DRM 3.40.0, 5.11.0-7612-generic, LLVM 11.0.0) AMD 4.6 (Core Profile) Mesa 21.0.0 **Blender Version** Broken: version: 3.0.0 Alpha, 33d9a0c951 **Short description of error** The object duplication triggered by dropping an object into a 3D View causes this: ``` BLI_assert failed: source/blender/blenkernel/intern/object.c:2773, BKE_object_duplicate(), at '(id_iter->tag & LIB_TAG_NEW) == 0' ``` Note that this doesn't happen for {key Shift D} object duplication because that uses `LIB_ID_DUPLICATE_IS_SUBPROCESS`, meaning the code-path with the assert is skipped. **Exact steps for others to reproduce the error** * Factory startup in a debug build * In the outliner, click and drag any object into the 3D View
Author
Member

Added subscriber: @JulianEisel

Added subscriber: @JulianEisel

#87913 was marked as duplicate of this issue

#87913 was marked as duplicate of this issue
Author
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

Added subscriber: @ZedDB

Added subscriber: @ZedDB
I've bisected this down to: https://developer.blender.org/rB29c0b34b209e4fa0548a1ff0716751f1fcfb51d5
Author
Member

Added subscriber: @JacquesLucke

Added subscriber: @JacquesLucke
Author
Member

The bisected commit is in the release branch, so adding the release tag.

The bisected commit is in the release branch, so adding the release tag.

This issue was referenced by d56d5bfafc

This issue was referenced by d56d5bfafc16dfefcbcd62cbb9363e5d8483519c

This issue was referenced by 7124c66340

This issue was referenced by 7124c663407c4c0ccca167107799165c01950a1f
Author
Member

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Julian Eisel self-assigned this 2021-06-08 16:46:41 +02:00
Thomas Dinges added this to the 2.93 LTS milestone 2023-02-07 18:46:14 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#87703
No description provided.