arm64: Viewport and Timeline jump large distances when scrolling the pointer off screen using Shift-Middle Mouse #88386

Closed
opened 2021-05-19 02:25:49 +02:00 by Timothy Cook · 20 comments

System Information
Operating system: macOS-11.3.1-arm64-arm-64bit 64 Bits
Graphics card: Apple M1 Apple 4.1 Metal - 71.5.9

Blender Version
Broken: version: 2.93.0 Beta, branch: master, commit date: 2021-05-18 09:58, hash: aa06be9148
Also the 3.0 ARM Alpha is experiencing the same bug.

Worked: Don't remember the latest version of ARM that worked. The Intel version had this issue a month or so ago but has been resolved. Not sure if those changes got passed on to the ARM versions.
I waited on filing a bug report on count of Intel version getting resolved, so I assumed it would be passed onto the ARM versions.

Short description of error
Viewport and Timeline will jump large distances when scrolling the pointer off screen using Shift-Middle Mouse. View port will jump 60 to 70 meters and timeline may move 500 frames or more.

Exact steps for others to reproduce the error
Open default Blender (ARM) move mouse point off to the left of screen using Shift-Middle Mouse; Viewport will jump.
Hover mouse pointer over the timeline and scroll mouse off screen using Shift-Middle Mouse; Timeline will jump several hundred frames.

I want to add that it's getting worse. You don't have to coerce the edge to make the entire viewport jump, you just move the pointer past the edge.
I also want to remind that this doesn't happen in the Intel version for Mac, as it has been resolved.
It only happens in the Arm 2.93 & 3.0 versions now.

Including video: It shows Viewport jump and Timeline jump.

Viewport Jump.mov

**System Information** Operating system: macOS-11.3.1-arm64-arm-64bit 64 Bits Graphics card: Apple M1 Apple 4.1 Metal - 71.5.9 **Blender Version** Broken: version: 2.93.0 Beta, branch: master, commit date: 2021-05-18 09:58, hash: `aa06be9148` Also the 3.0 ARM Alpha is experiencing the same bug. Worked: Don't remember the latest version of ARM that worked. The Intel version had this issue a month or so ago but has been resolved. Not sure if those changes got passed on to the ARM versions. I waited on filing a bug report on count of Intel version getting resolved, so I assumed it would be passed onto the ARM versions. **Short description of error** Viewport and Timeline will jump large distances when scrolling the pointer off screen using Shift-Middle Mouse. View port will jump 60 to 70 meters and timeline may move 500 frames or more. **Exact steps for others to reproduce the error** Open default Blender (ARM) move mouse point off to the left of screen using Shift-Middle Mouse; Viewport will jump. Hover mouse pointer over the timeline and scroll mouse off screen using Shift-Middle Mouse; Timeline will jump several hundred frames. I want to add that it's getting worse. You don't have to coerce the edge to make the entire viewport jump, you just move the pointer past the edge. I also want to remind that this doesn't happen in the Intel version for Mac, as it has been resolved. It only happens in the Arm 2.93 & 3.0 versions now. Including video: It shows Viewport jump and Timeline jump. [Viewport Jump.mov](https://archive.blender.org/developer/F10145857/Viewport_Jump.mov)
Author

Added subscriber: @CookItOff

Added subscriber: @CookItOff

#87820 was marked as duplicate of this issue

#87820 was marked as duplicate of this issue
Member

Added subscriber: @ankitm

Added subscriber: @ankitm
Member

Event logs my help identify the cause

  • Run /path/to/Blender.app/Contents/MacOS/Blender --debug-all > ~/Downloads/mouse_jump_logs.txt 2>&1
  • Do the bare minimum activity that shows the bug and quit Blender
  • Share the log file.

https://docs.blender.org/manual/en/latest/advanced/command_line/arguments.html#debug-options
https://docs.blender.org/manual/en/latest/advanced/command_line/launch/macos.html#details

Event logs my help identify the cause - Run `/path/to/Blender.app/Contents/MacOS/Blender --debug-all > ~/Downloads/mouse_jump_logs.txt 2>&1` - Do the bare minimum activity that shows the bug and quit Blender - Share the log file. https://docs.blender.org/manual/en/latest/advanced/command_line/arguments.html#debug-options https://docs.blender.org/manual/en/latest/advanced/command_line/launch/macos.html#details
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Author

Looks like it’s similar to or same as this bug report filed for Linux.
https://developer.blender.org/T86033

Looks like it’s similar to or same as this bug report filed for Linux. https://developer.blender.org/T86033
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Just found this btw.: #75528 (Continuous Grab occasionally jumping when going across region border at high mouse polling rate)

Just found this btw.: #75528 (Continuous Grab occasionally jumping when going across region border at high mouse polling rate)
Author

Yeah, it looks to be the same. I want to add, as I posted in the description, that it seems to be resolved on the Intel MacOS versions but still an issue on the ARM64 builds.

Yeah, it looks to be the same. I want to add, as I posted in the description, that it seems to be resolved on the Intel MacOS versions but still an issue on the ARM64 builds.

Added subscriber: @AgentSam-2

Added subscriber: @AgentSam-2
Author

Added a video last week showing the bug. Any news on this?
Intel version of Blender on M1 works fine with Rosetta.
ARM version of Blender on the same machine has the bug.
Using same mouse and computer, only diffrrncyis the Blender versions.

Not sure what a log would show since I’m not performing any action minus moving the viewport.

Thanks!

Added a video last week showing the bug. Any news on this? Intel version of Blender on M1 works fine with Rosetta. ARM version of Blender on the same machine has the bug. Using same mouse and computer, only diffrrncyis the Blender versions. Not sure what a log would show since I’m not performing any action minus moving the viewport. Thanks!
Author

In #88386#1162644, @ankitm wrote:
Event logs my help identify the cause

  • Run /path/to/Blender.app/Contents/MacOS/Blender --debug-all > ~/Downloads/mouse_jump_logs.txt 2>&1
  • Do the bare minimum activity that shows the bug and quit Blender
  • Share the log file.

https://docs.blender.org/manual/en/latest/advanced/command_line/arguments.html#debug-options
https://docs.blender.org/manual/en/latest/advanced/command_line/launch/macos.html#details

@ankitm sorry but I didn't know you were part of the development team :) . I thought it was common knowledge that you can't pan the mouse off screen with Shift-MMB while in debug mode from Terminal or CMD line, so the info you're asking for can't be performed for my bug.
That's why I haven't provide the debug report, because it's impossible to perform the action needed with (--debug-all)

Best thing I can think of to provide is a video of the action, which I did. If you need something else let me know.

> In #88386#1162644, @ankitm wrote: > Event logs my help identify the cause > - Run `/path/to/Blender.app/Contents/MacOS/Blender --debug-all > ~/Downloads/mouse_jump_logs.txt 2>&1` > - Do the bare minimum activity that shows the bug and quit Blender > - Share the log file. > > https://docs.blender.org/manual/en/latest/advanced/command_line/arguments.html#debug-options > https://docs.blender.org/manual/en/latest/advanced/command_line/launch/macos.html#details @ankitm sorry but I didn't know you were part of the development team :) . I thought it was common knowledge that you can't pan the mouse off screen with Shift-MMB while in debug mode from Terminal or CMD line, so the info you're asking for can't be performed for my bug. That's why I haven't provide the debug report, because it's impossible to perform the action needed with (--debug-all) Best thing I can think of to provide is a video of the action, which I did. If you need something else let me know.
Member

Changed status from 'Needs User Info' to: 'Needs Triage'

Changed status from 'Needs User Info' to: 'Needs Triage'
Member

Added subscribers: @Roderick-Hietbrink, @someuser

Added subscribers: @Roderick-Hietbrink, @someuser
Ankit Meel changed title from Viewport and Timeline will jump large distances when scrolling the pointer off screen using Shift-Middle Mouse ARM64 to arm64: Viewport and Timeline jump large distances when scrolling the pointer off screen using Shift-Middle Mouse 2021-06-04 16:33:50 +02:00
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

Added subscribers: @jenkm, @PrototypeNM1

Added subscribers: @jenkm, @PrototypeNM1

@jenkm You around to poke at this issue again? I think it could be solved once and for all by using the cursor offsets as in the GHOST_kGrabHide case for the GHOST_kGrabWrap case in GHOST_SystemCocoa.mm.

@jenkm You around to poke at this issue again? I think it could be solved once and for all by using the cursor offsets as in the `GHOST_kGrabHide` case for the `GHOST_kGrabWrap` case in `GHOST_SystemCocoa.mm`.

This issue was referenced by 6489f2212b

This issue was referenced by 6489f2212b96fc7d2ab5abd23e487dd76e7b7c07

This issue was referenced by 215734bc52

This issue was referenced by 215734bc522a8db532a626f460b85b66b0aa0a4c

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Germano Cavalcante self-assigned this 2021-08-12 13:53:14 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#88386
No description provided.