Grease Pencil Line Art Modifier - Incorrect baking with camera markers #88464

Closed
opened 2021-05-21 16:05:57 +02:00 by Simon Meloche · 13 comments

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 457.30

Blender Version
Broken: version: 2.93.0 Beta, branch: master, commit date: 2021-05-20 18:41, hash: 6a0906c09a

Short description of error
When using Bake Line Art on a Line Art Modifier in a scene with multiple cameras assigned to camera markers on the timeline, the POV of only one of the cameras is used to calculate the Line Art, giving incorrect lines on the other camera views. This bug happens only after baking the line art, as it is correctly shown/calculated before baking.

Exact steps for others to reproduce the error

  • Open attached .blend file

  • The 'LineArt-Baked' collection contains baked line art of the 'LineArt-src' collection. It is incorrectly baked using only one camera POV.

  • The 'LineArt-src' collection also contains a Line Art object that is not baked, which correctly calculates the lines.

  • To reproduce, select the 'Line Art - NotBaked' object.

  • In the modifiers, under the baking tab, click on the 'Bake Line Art' button.

  • The baked line art will now be calculated based on only the active camera, instead of switching along with the markers.

{F10134068, size=full}
BlenderBug_2.93_210521_LineArt.blend

**System Information** Operating system: Windows-10-10.0.19041-SP0 64 Bits Graphics card: GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 457.30 **Blender Version** Broken: version: 2.93.0 Beta, branch: master, commit date: 2021-05-20 18:41, hash: `6a0906c09a` **Short description of error** When using Bake Line Art on a Line Art Modifier in a scene with multiple cameras assigned to camera markers on the timeline, the POV of only one of the cameras is used to calculate the Line Art, giving incorrect lines on the other camera views. This bug happens only after baking the line art, as it is correctly shown/calculated before baking. **Exact steps for others to reproduce the error** * Open attached .blend file * The 'LineArt-Baked' collection contains baked line art of the 'LineArt-src' collection. It is incorrectly baked using only one camera POV. * The 'LineArt-src' collection also contains a Line Art object that is not baked, which correctly calculates the lines. * To reproduce, select the 'Line Art - NotBaked' object. * In the modifiers, under the baking tab, click on the 'Bake Line Art' button. * The baked line art will now be calculated based on only the active camera, instead of switching along with the markers. {[F10134068](https://archive.blender.org/developer/F10134068/GreasePencilLineArt_CameraMarkers.jpg), size=full} [BlenderBug_2.93_210521_LineArt.blend](https://archive.blender.org/developer/F10134056/BlenderBug_2.93_210521_LineArt.blend)
Author

Added subscriber: @Simux

Added subscriber: @Simux

Added subscriber: @ChengduLittleA

Added subscriber: @ChengduLittleA
Member

Ok I see... baking currently does not take in to account for camera changes... I'll fix it.

Ok I see... baking currently does not take in to account for camera changes... I'll fix it.

This issue was referenced by 0a7bd3b6d2

This issue was referenced by 0a7bd3b6d24a38ffa6678ef9c1d1854c6c6f27b9
Member

Changed status from 'Needs Triage' to: 'Resolved'

Changed status from 'Needs Triage' to: 'Resolved'
YimingWu self-assigned this 2021-05-25 10:57:02 +02:00
Author

That was quick! Thanks for the fix, great work

That was quick! Thanks for the fix, great work
Author

Was this fix ported to the new 2.93? I am still getting incorrect baking using 2.93.0 and the test file provided.

Was this fix ported to the new 2.93? I am still getting incorrect baking using 2.93.0 and the test file provided.

Added subscriber: @antoniov

Added subscriber: @antoniov

@Simux have you tested in 3.0?

@Simux have you tested in 3.0?
Member

Added subscriber: @Jeroen-Bakker

Added subscriber: @Jeroen-Bakker
Member

Maybe we can also have this fix for 2.93 bug sprint. @Jeroen-Bakker Do you think?

Maybe we can also have this fix for 2.93 bug sprint. @Jeroen-Bakker Do you think?
Author

In #88464#1173972, @antoniov wrote:
@Simux have you tested in 3.0?

Tested today in 2.93.1 release candidate and in 3.0 alpha and both still have the issue.

> In #88464#1173972, @antoniov wrote: > @Simux have you tested in 3.0? Tested today in 2.93.1 release candidate and in 3.0 alpha and both still have the issue.
Member

Just checked and that commit somehow was lost due to the change of custom camera code. Will fix it.

Just checked and that commit somehow was lost due to the change of custom camera code. Will fix it.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#88464
No description provided.