Insert key dropdown on keymap doesn't show keying sets anymore #89560

Open
opened 2021-06-30 19:17:03 +02:00 by Luciano Muñoz Sessarego · 17 comments

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 466.77

Blender Version
Broken: version: 2.93.2 Release Candidate, branch: master, commit date: 2021-06-23 12:44, hash: 03d5c8b4ed
Worked: 2.92

Short description of error
when trying to assign a default keying set to the insert key menu, it doesnt show the list anymore just a dropdown that says default

2.92
2021-06-30 10_05_54-Settings.png

2.93+
2021-06-30 10_05_19-Blender.png

Exact steps for others to reproduce the error
open blender, go to settings > keymap
search for "insert keyframe"
expand the "insert keyframe menu" under pose mode
click the keyingset dropdown... all you get is default.

**System Information** Operating system: Windows-10-10.0.19041-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 466.77 **Blender Version** Broken: version: 2.93.2 Release Candidate, branch: master, commit date: 2021-06-23 12:44, hash: `03d5c8b4ed` Worked: 2.92 **Short description of error** when trying to assign a default keying set to the insert key menu, it doesnt show the list anymore just a dropdown that says default 2.92 ![2021-06-30 10_05_54-Settings.png](https://archive.blender.org/developer/F10206806/2021-06-30_10_05_54-Settings.png) 2.93+ ![2021-06-30 10_05_19-Blender.png](https://archive.blender.org/developer/F10206805/2021-06-30_10_05_19-Blender.png) **Exact steps for others to reproduce the error** open blender, go to settings > keymap search for "insert keyframe" expand the "insert keyframe menu" under pose mode click the keyingset dropdown... all you get is default.
Author
Member

Added subscriber: @LucianoMunoz

Added subscriber: @LucianoMunoz
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

Added subscribers: @ideasman42, @dr.sybren

Added subscribers: @ideasman42, @dr.sybren

Bisecting shows that this issue was caused by 919558854d. @ideasman42 could you take a look at this?

Bisecting shows that this issue was caused by 919558854d. @ideasman42 could you take a look at this?
Campbell Barton self-assigned this 2022-03-08 12:39:21 +01:00

This issue was referenced by e55f4657f7

This issue was referenced by e55f4657f7b7ae8ac915eefd633d08ae56bb3574

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'

Committed support for built-in keying sets however this isn't the intended way to bind keys as these values aren't stable (changes to the default keying sets may brake the key-bindings).

This report highlights a usability issues setting key bindings to keying sets, submitted D14289 to address this.

Committed support for built-in keying sets however this isn't the intended way to bind keys as these values aren't stable (changes to the default keying sets may brake the key-bindings). This report highlights a usability issues setting key bindings to keying sets, submitted [D14289](https://archive.blender.org/developer/D14289) to address this.

This issue was referenced by 56dba4df3c

This issue was referenced by 56dba4df3c7b939a853139c09a2a4e71409e9680

Changed status from 'Resolved' to: 'Archived'

Changed status from 'Resolved' to: 'Archived'

Reverted the fix as there is an operator that's intended for binding keys, applying D14289 avoids users attempting to bind keys to an operator that doesn't properly support it.

Reverted the fix as there is an operator that's intended for binding keys, applying [D14289](https://archive.blender.org/developer/D14289) avoids users attempting to bind keys to an operator that doesn't properly support it.

Changed status from 'Archived' to: 'Confirmed'

Changed status from 'Archived' to: 'Confirmed'

Reverting the fix should reopen this bug report, not archive it.

Reverting the fix should reopen this bug report, not archive it.
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:35:33 +01:00
Author
Member

Hello, any chance anyone can take a look at this the bug persists.

Hello, any chance anyone can take a look at this the bug persists.

Reverted the fix as there is an operator that's intended for binding keys, applying D14289 avoids users attempting to bind keys to an operator that doesn't properly support it.

@ideasman42 could you shed some light on this? What does it mean in practice for this particular issue?

> Reverted the fix as there is an operator that's intended for binding keys, applying [D14289](https://archive.blender.org/developer/D14289) avoids users attempting to bind keys to an operator that doesn't properly support it. @ideasman42 could you shed some light on this? What does it mean in practice for this particular issue?
Sybren A. Stüvel added this to the Animation & Rigging project 2023-04-14 12:36:46 +02:00

@dr.sybren the problem with exposing this operator in the key-map is the values of the enum are dynamic (see ANIM_keying_sets_enum_itemf), this means the internal indices stored in the key-map may change depending on the users scene & selection. It also means loading a key-map could fail if the enum value used happens to be missing from the users Blend file.

We can always define things that work sometimes/unreliably as "good enough", and support them but in this case an operator was specifically added to workaround this problem. Supporting the original functionality amounts to hard-coding keying set values which happen to match the default startup file, then hoping the user doesn't change the default keying-sets.

So I'd suggest to consider using anim.keyframe_insert_menu from a keymap to directly insert key-frames on a keying-set to be deprecated functionality as it was never properly supported and consider how to communicate this users so they know to use anim.keyframe_insert_by_name instead.

Without making bigger changes to the UI/key-map editor - the tool-tip for the keying set could note that a different operator should be used to support inserting key-frames for keying set directly.

An alternative could be to show a warning for all dynamic-enums in the keymap editor, noting that the value used in the key-map may not be available at run-time, although in this particular case it doesn't point to the preferred operator.

@dr.sybren the problem with exposing this operator in the key-map is the values of the enum are dynamic (see `ANIM_keying_sets_enum_itemf`), this means the internal indices stored in the key-map may change depending on the users scene & selection. It also means loading a key-map could fail if the enum value used happens to be missing from the users Blend file. We can always define things that work sometimes/unreliably as "good enough", and support them but in this case an operator was specifically added to workaround this problem. Supporting the original functionality amounts to hard-coding keying set values which happen to match the default startup file, then hoping the user doesn't change the default keying-sets. So I'd suggest to consider using `anim.keyframe_insert_menu` from a keymap to directly insert key-frames on a keying-set to be deprecated functionality as it was never properly supported and consider how to communicate this users so they know to use `anim.keyframe_insert_by_name` instead. Without making bigger changes to the UI/key-map editor - the tool-tip for the keying set could note that a different operator should be used to support inserting key-frames for keying set directly. An alternative could be to show a warning for all dynamic-enums in the keymap editor, noting that the value used in the key-map may not be available at run-time, although in this particular case it doesn't point to the preferred operator.

@LucianoMunoz can you check the following works as expected?

  • In the key-map editor, select the operator to anim.keyframe_insert_by_name.
  • Select the keying set from the list or type in it's ID.

Note that this can also be performed from the insert-keyframe menu, RMB on the menu item and select "Add Shortcut".

@LucianoMunoz can you check the following works as expected? - In the key-map editor, select the operator to `anim.keyframe_insert_by_name`. - Select the keying set from the list or type in it's ID. Note that this can also be performed from the insert-keyframe menu, RMB on the menu item and select "Add Shortcut".

@LucianoMunoz with the changes to keying in 4.1, is this still relevant?

@LucianoMunoz with [the changes to keying in 4.1](https://developer.blender.org/docs/release_notes/4.1/animation_rigging/#keying), is this still relevant?
Sybren A. Stüvel added
Status
Needs Information from User
and removed
Status
Confirmed
labels 2024-03-21 09:40:05 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#89560
No description provided.