Curve based rig broken since 2.93 #89564

Closed
opened 2021-06-30 20:10:57 +02:00 by hector rojo · 10 comments

System Information
Operating system: Windows-8.1-6.3.9600-SP0 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 368.39

Blender Version
Broken: version: 2.93.2 Release Candidate, branch: master, commit date: 2021-06-23 12:44, hash: 03d5c8b4ed
Worked: 2.92
Caused by d851fc3ad6

Short description of error
Curve based rig broken, a few bones start "jumpin", when moving main bone (named "master") far from [0,0,0].

Exact steps for others to reproduce the error
Just move "master" bone in Z direction pasing 360 units, then move any "green" bone (soga_curva_cuelga_1... soga_curva_cuelga_3) and you'll see that bone start jumpin; this worked until 2.92 but since 2.93 it seems is broken now.
rope_broken_rig_moving_away_from_000.blend

**System Information** Operating system: Windows-8.1-6.3.9600-SP0 64 Bits Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 368.39 **Blender Version** Broken: version: 2.93.2 Release Candidate, branch: master, commit date: 2021-06-23 12:44, hash: `03d5c8b4ed` Worked: 2.92 Caused by d851fc3ad6 **Short description of error** Curve based rig broken, a few bones start "jumpin", when moving main bone (named "master") far from [0,0,0]. **Exact steps for others to reproduce the error** Just move "master" bone in Z direction pasing 360 units, then move any "green" bone (soga_curva_cuelga_1... soga_curva_cuelga_3) and you'll see that bone start jumpin; this worked until 2.92 but since 2.93 it seems is broken now. [rope_broken_rig_moving_away_from_000.blend](https://archive.blender.org/developer/F10206854/rope_broken_rig_moving_away_from_000.blend)
Author

Added subscriber: @hector.rojo.cg

Added subscriber: @hector.rojo.cg
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Philipp Oeser self-assigned this 2021-07-01 12:29:14 +02:00
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Confirmed, will check

Confirmed, will check
Philipp Oeser removed their assignment 2021-07-01 13:29:11 +02:00
Member

Added subscriber: @ZedDB

Added subscriber: @ZedDB
Member

Caused by d851fc3ad6

@ZedDB : mind checking?

Caused by d851fc3ad6 @ZedDB : mind checking?

This issue was referenced by 654967b0e0

This issue was referenced by 654967b0e0ce27ff12cff815dde98b2e566abe89

This issue was referenced by a0bb6bb4d6

This issue was referenced by a0bb6bb4d69d4494c1bc75f0aa2be20a12aa5718

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Sebastian Parborg self-assigned this 2021-11-26 18:25:28 +01:00

Sadly this didn't make it into Blender 3.0.
It will be in the 3.1 release.

Sadly this didn't make it into Blender 3.0. It will be in the 3.1 release.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#89564
No description provided.