blender 2.93.1 fails to build with python 3.10.0b4 (upcoming python 3.10) #89931

Closed
opened 2021-07-18 07:05:12 +02:00 by Mamoru TASAKA · 5 comments

blender 2.93.1 fails to build with python 3.10.0 beta 4 (released 2021-07-10).
Error messages are:

/builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c: In function 'mathutils_array_hash':
/builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:98:24: error: incompatible type for argument 1 of '_Py_HashDouble'
   98 |     y = _Py_HashDouble((double)(array[i++]));
      |                        ^~~~~~~~~~~~~~~~~~~~
      |                        |
      |                        double
In file included from /usr/include/python3.10/Python.h:90,
                 from /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:21:
/usr/include/python3.10/pyhash.h:10:38: note: expected 'PyObject *' {aka 'struct _object *'} but argument is of type 'double'
   10 | PyAPI_FUNC(Py_hash_t) _Py_HashDouble(PyObject *, double);
      |                                      ^~~~~~~~~~
/builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:98:9: error: too few arguments to function '_Py_HashDouble'
   98 |     y = _Py_HashDouble((double)(array[i++]));
      |         ^~~~~~~~~~~~~~
In file included from /usr/include/python3.10/Python.h:90,
                 from /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:21:
/usr/include/python3.10/pyhash.h:10:23: note: declared here
   10 | PyAPI_FUNC(Py_hash_t) _Py_HashDouble(PyObject *, double);
      |                       ^~~~~~~~~~~~~~

python 3.10 release schedule is https://www.python.org/dev/peps/pep-0619/

Perhaps this is due to the following change:
a07da09ad5 (diff-457f8bf30255da716d2a556ad1bef2dff5d77ed1511f3328da22c600bb477042R10)
https://bugs.python.org/issue43475

numpy changed like this: ad2a73c18d

blender 2.93.1 fails to build with python 3.10.0 beta 4 (released 2021-07-10). Error messages are: ``` /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c: In function 'mathutils_array_hash': /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:98:24: error: incompatible type for argument 1 of '_Py_HashDouble' 98 | y = _Py_HashDouble((double)(array[i++])); | ^~~~~~~~~~~~~~~~~~~~ | | | double In file included from /usr/include/python3.10/Python.h:90, from /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:21: /usr/include/python3.10/pyhash.h:10:38: note: expected 'PyObject *' {aka 'struct _object *'} but argument is of type 'double' 10 | PyAPI_FUNC(Py_hash_t) _Py_HashDouble(PyObject *, double); | ^~~~~~~~~~ /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:98:9: error: too few arguments to function '_Py_HashDouble' 98 | y = _Py_HashDouble((double)(array[i++])); | ^~~~~~~~~~~~~~ In file included from /usr/include/python3.10/Python.h:90, from /builddir/build/BUILD/blender-2.93.1/source/blender/python/mathutils/mathutils.c:21: /usr/include/python3.10/pyhash.h:10:23: note: declared here 10 | PyAPI_FUNC(Py_hash_t) _Py_HashDouble(PyObject *, double); | ^~~~~~~~~~~~~~ ``` python 3.10 release schedule is https://www.python.org/dev/peps/pep-0619/ Perhaps this is due to the following change: https://github.com/python/cpython/commit/a07da09ad5bd7d234ccd084a3a0933c290d1b592#diff-457f8bf30255da716d2a556ad1bef2dff5d77ed1511f3328da22c600bb477042R10 https://bugs.python.org/issue43475 numpy changed like this: https://github.com/numpy/numpy/commit/ad2a73c18dcff95d844c382c94ab7f73b5571cf3
Author

Added subscriber: @mtasaka

Added subscriber: @mtasaka
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123

This issue was referenced by 690fa2ba86

This issue was referenced by 690fa2ba86a05b3196a8bc4f78df47f3d5da9b51

This issue was referenced by 6fe00939b0

This issue was referenced by 6fe00939b0a471cc149ea5b3c63ca57b049b4a37

Changed status from 'Needs Triage' to: 'Resolved'

Changed status from 'Needs Triage' to: 'Resolved'
Campbell Barton self-assigned this 2021-08-09 14:59:29 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#89931
No description provided.