Make Links > Objects to Scene: Does not changes origing point color. We have no visual indication! #90472

Open
opened 2021-08-06 02:44:51 +02:00 by Julio Cargnin Pereira · 12 comments

System Information
Operating system: Linux-5.11.0-7620-generic-x86_64-with-glibc2.31 64 Bits
Graphics card: NVIDIA GeForce RTX 3080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 470.57.02

Blender Version
Broken: version: 2.93.2, branch: master, commit date: 2021-08-03 05:58, hash: 1eb06de260
Worked: (newest version of Blender that worked as expected)

Short description of error

2021-08-06_09-15.png

In 2.79 it was visually distinguishable per scene linked objects by a bluish tinted origin point but this behavior is missing since 2.8 series has started (for no apparent reason).

This visual feedback is very important. It basically tells you:
Hey! If you touch me, you change me in all scenes I'm living at! Be aware!

And the fact now I have remember what can I touch and what I can't, since my project is increasing in complexity, is overwhelming.
You might say: use library overrides then! But no, these are different features and both accomplish different purposes and they can keep coexisting. (unless we could now make a library override for a datablock in the same file, but that is not the case).

Also, the 2.93 manual states the expected behavior:
2021-08-06_09-22.png
But this is not the case anymore for a while!
I have been silently waiting for this to be fixed but its time to ask our dear developers to take a look onto this. Please, bring it back!
Or maybe even enabling the ability to define a different outline color too. (honestly a tinted dot for me is enough)

Best regards,
Julio.

**System Information** Operating system: Linux-5.11.0-7620-generic-x86_64-with-glibc2.31 64 Bits Graphics card: NVIDIA GeForce RTX 3080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 470.57.02 **Blender Version** Broken: version: 2.93.2, branch: master, commit date: 2021-08-03 05:58, hash: `1eb06de260` Worked: (newest version of Blender that worked as expected) **Short description of error** ![2021-08-06_09-15.png](https://archive.blender.org/developer/F10269380/2021-08-06_09-15.png) In 2.79 it was visually distinguishable per scene linked objects by a bluish tinted origin point but this behavior is missing since 2.8 series has started (for no apparent reason). This visual feedback is very important. It basically tells you: Hey! If you touch me, you change me in all scenes I'm living at! Be aware! And the fact now I have remember what can I touch and what I can't, since my project is increasing in complexity, is overwhelming. You might say: use library overrides then! But no, these are different features and both accomplish different purposes and they can keep coexisting. (unless we could now make a library override for a datablock in the same file, but that is not the case). Also, the 2.93 manual states the expected behavior: ![2021-08-06_09-22.png](https://archive.blender.org/developer/F10269383/2021-08-06_09-22.png) But this is not the case anymore for a while! I have been silently waiting for this to be fixed but its time to ask our dear developers to take a look onto this. Please, bring it back! Or maybe even enabling the ability to define a different outline color too. (honestly a tinted dot for me is enough) Best regards, Julio.

Added subscriber: @CosmoMidias

Added subscriber: @CosmoMidias
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Philipp Oeser self-assigned this 2021-08-06 11:07:53 +02:00
Member

Can confirm, will check.

Can confirm, will check.
Member

@CosmoMidias : please check D12153 (patch has two side-effects which I am unsure about, maybe you can comment there?)

@CosmoMidias : please check [D12153](https://archive.blender.org/developer/D12153) (patch has two side-effects which I am unsure about, maybe you can comment there?)

In #90472#1202866, @lichtwerk wrote:
@CosmoMidias : please check D12153 (patch has two side-effects which I am unsure about, maybe you can comment there?)

Thanks Philipp for the prompt triage and investigation.
I will follow the progress on the indicated thread.

> In #90472#1202866, @lichtwerk wrote: > @CosmoMidias : please check [D12153](https://archive.blender.org/developer/D12153) (patch has two side-effects which I am unsure about, maybe you can comment there?) Thanks Philipp for the prompt triage and investigation. I will follow the progress on the indicated thread.

We found more inconsistencies on the visual feedback of linked files per scene and linked libraries.

For example:
blender27.jpeg
We used to have bluish origin point and a screaming bluish outline indicating its a lib link on selected.

OTOH, 2.8 Series:
28a.jpeg
We've lost the bluish outline, but the bluish origin is there for this condition. Until that...

28b.jpeg
...the object is activated and, damn... we lost the feedback again. Origin has turned orange!

So I could keep illustrating here more inconsistencies from the previous behaviors but um summary 2.8 series that I believe should be treated seriously are:

  • linked object per scene (CTRL + L) don't have any distinguishable visual feedback, origins are not tinted in blue.
  • origins are turning orange as soon as object is activated no matter if its a linked per scene state or a lib link state.
  • bluish outline is not present in case its a link lib.

I'm not gonna mention the green outline we used to have when a object becomes a group (Ctrl + G) in 2.7
because, I feel, that functionality is falling into a limbo since collections and library overrides arrived.
But that should be addressed somewhere soon if possible as 3.0 in rising on the horizon.
Let's push some love into these UX issues... they have been haunting me for a while now. Go Blender!

We found more inconsistencies on the visual feedback of linked files per scene and linked libraries. For example: ![blender27.jpeg](https://archive.blender.org/developer/F10273078/blender27.jpeg) We used to have bluish origin point and a screaming bluish outline indicating its a lib link on selected. OTOH, 2.8 Series: ![28a.jpeg](https://archive.blender.org/developer/F10273080/28a.jpeg) We've lost the bluish outline, but the bluish origin is there for this condition. Until that... ![28b.jpeg](https://archive.blender.org/developer/F10273082/28b.jpeg) ...the object is activated and, damn... we lost the feedback again. Origin has turned orange! So I could keep illustrating here more inconsistencies from the previous behaviors but um summary 2.8 series that I believe should be treated seriously are: - linked object per scene (CTRL + L) don't have any distinguishable visual feedback, origins are not tinted in blue. - origins are turning orange as soon as object is activated no matter if its a linked per scene state or a lib link state. - bluish outline is not present in case its a link lib. I'm not gonna mention the green outline we used to have when a object becomes a group (Ctrl + G) in 2.7 because, I feel, that functionality is falling into a limbo since collections and library overrides arrived. But that should be addressed somewhere soon if possible as 3.0 in rising on the horizon. Let's push some love into these UX issues... they have been haunting me for a while now. Go Blender!
Member

Thx checking again @CosmoMidias

Yes, these things have partially been mentioned in D12153.
There is still an issue regarding the check (it was relying on usercount in 2.79 which is now not feasible in 2.8) so it is a bit uncertain on how to do this best/most efficient.
Will set to Design to reflect that.

Thx checking again @CosmoMidias Yes, these things have partially been mentioned in [D12153](https://archive.blender.org/developer/D12153). There is still an issue regarding the check (it was relying on usercount in 2.79 which is now not feasible in 2.8) so it is a bit uncertain on how to do this best/most efficient. Will set to `Design` to reflect that.
Philipp Oeser removed their assignment 2021-10-25 13:32:51 +02:00
Member

Hm, since D12153 is not finished (and I am unsure if I can wrap this up in a performant manner), I will step down for now (to not block others that might have a better idea on this issue)

Hm, since [D12153](https://archive.blender.org/developer/D12153) is not finished (and I am unsure if I can wrap this up in a performant manner), I will step down for now (to not block others that might have a better idea on this issue)

Added subscriber: @fclem

Added subscriber: @fclem

@lichtwerk have you talked to some other developer about this issue? Maybe @fclem have an idea? I've heard he works on eevee refactor and may have some overlays jobss under his umbrella... It's annoying the absence of any visual indication for linked assets between scenes in the same file like we had before 2.8 series... Or maybe propose a new way to inform that? Don't need to revive the previous behavior if it has technical limitations now.

@lichtwerk have you talked to some other developer about this issue? Maybe @fclem have an idea? I've heard he works on eevee refactor and may have some overlays jobss under his umbrella... It's annoying the absence of any visual indication for linked assets between scenes in the same file like we had before 2.8 series... Or maybe propose a new way to inform that? Don't need to revive the previous behavior if it has technical limitations now.
Philipp Oeser removed the
Interest
EEVEE & Viewport
label 2023-02-09 15:13:22 +01:00
Bastien Montagne added this to the Core project 2023-02-09 15:42:54 +01:00
Bastien Montagne removed this from the Core project 2023-02-09 18:20:37 +01:00

Hello guys! Any chances to have this features restored with the latest Viewport Overlays improvements? - Thanks!

Hello guys! Any chances to have this features restored with the latest Viewport Overlays improvements? - Thanks!
Clément Foucault added the
Interest
Overlay
label 2023-10-30 12:59:34 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#90472
No description provided.