Constant crash on startup. #91108

Closed
opened 2021-09-01 11:32:05 +02:00 by Guido · 17 comments

System Information
Operating system: macOS-11.5.2-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 5700 XT OpenGL Engine ATI Technologies Inc. 4.1 ATI-4.6.20

Blender Version
Broken: version: 3.0.0 Alpha, branch: cycles-x, commit date: 2021-09-01 5:20, hash: 50b5cbb484cd Intel

Worked: version: 3.0.0 Alpha, branch: cycles-x, commit date: 2021-08-30 14:00, hash: 60aebfceaa Intel

Short description of error
Crash at startup
blender.crash.txt
apple crash log.txt

Exact steps for others to reproduce the error
Install and start up blender hash: 50b5cbb484cd. It will crash right away. Redownloaded, reinstalled and rebooted the system. --> Still crashing.

**System Information** Operating system: macOS-11.5.2-x86_64-i386-64bit 64 Bits Graphics card: AMD Radeon Pro 5700 XT OpenGL Engine ATI Technologies Inc. 4.1 ATI-4.6.20 **Blender Version** Broken: version: 3.0.0 Alpha, branch: cycles-x, commit date: 2021-09-01 5:20, hash: `50b5cbb484cd` Intel Worked: version: 3.0.0 Alpha, branch: cycles-x, commit date: 2021-08-30 14:00, hash: `60aebfceaa` Intel **Short description of error** Crash at startup [blender.crash.txt](https://archive.blender.org/developer/F10360178/blender.crash.txt) [apple crash log.txt](https://archive.blender.org/developer/F10360182/apple_crash_log.txt) **Exact steps for others to reproduce the error** Install and start up blender hash: `50b5cbb484cd`. It will crash right away. Redownloaded, reinstalled and rebooted the system. --> Still crashing.
Author

Added subscriber: @Nurb2Kea

Added subscriber: @Nurb2Kea
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Member

Cant read much out of that crash log tbh.

Is this also an issue in master builds? Or just the cycles-x branch?

Cant read much out of that crash log tbh. Is this also an issue in master builds? Or just the cycles-x branch?
Author

Nope,

blender-3.0.0-alpha+master.838b6ec48af6-darwin.x86_64-release works fine.
Just the -cycles branch I guess.
Mostly using the cycles branch and for compairison the master branch if there is a problem.

Nope, blender-3.0.0-alpha+master.838b6ec48af6-darwin.x86_64-release works fine. Just the -cycles branch I guess. Mostly using the cycles branch and for compairison the master branch if there is a problem.
Member

Changed status from 'Needs User Info' to: 'Archived'

Changed status from 'Needs User Info' to: 'Archived'
Member

Added subscriber: @Sergey

Added subscriber: @Sergey
Member

OK, thx getting back and having an eye on the branch.
Just raising awareness to @Sergey here, but in general we are not tracking bugs on feature branches on this bugtracker.
Thus will close.

OK, thx getting back and having an eye on the branch. Just raising awareness to @Sergey here, but in general we are not tracking bugs on feature branches on this bugtracker. Thus will close.
Author

Since when ??
The last 3 similar issues got solved right here. The last weeks !

And sure you do, or why was Brecht Van Lommel working to solve those problems with me?

So just forward this if you don't want to look after it. Easy as that.
That's the bugreport to fill and hasn't chaged for branches anytime. So don't fool me!

If not I will file the bug again with your comment/note attached.

Thanks

Since when ?? The last 3 similar issues got solved right here. The last weeks ! And sure you do, or why was Brecht Van Lommel working to solve those problems with me? So just forward this if you don't want to look after it. Easy as that. That's the bugreport to fill and hasn't chaged for branches anytime. So don't fool me! If not I will file the bug again with your comment/note attached. Thanks
Member

In infrastructure/blender-buildbot#88388#1162815, @Sergey wrote:
We are not currently open for reports about cycles-x branch.

> In infrastructure/blender-buildbot#88388#1162815, @Sergey wrote: > We are not currently open for reports about cycles-x branch.
Member

Added subscriber: @brecht

Added subscriber: @brecht
Member

@Sergey, @brecht: feel free to reopen, I think a clear guideline on feature-branch-reports could help, asked in chat also https://blender.chat/channel/blender-triagers?msg=7FdSgHsvQC4KmcEM9 (happy to do the necessary steps if we are restrictive, also happy if we generally accept them, also happy to just ping an appropriate dev [but close report nonetheless])

@Sergey, @brecht: feel free to reopen, I think a clear guideline on feature-branch-reports could help, asked in chat also https://blender.chat/channel/blender-triagers?msg=7FdSgHsvQC4KmcEM9 (happy to do the necessary steps if we are restrictive, also happy if we generally accept them, also happy to just ping an appropriate dev [but close report nonetheless])
Author

Well,

let's see, what does that say to me :" May 19 2021, 1:37 PM"
Also it has to do with the buildbot like last weeks when it wasn't well implemented.

Now it's September and Sergey is nothing else doing than working on cycles-x as Brecht Van Lommel too.
If you follow their profile here.

Your quote here from Sergey is from May. They are fixing bugs via bugreport since the announcement and public experimental builds.
Otherwise wouldn't make sense to upload almost every day a new cycles-x build to test and report BUT not taking bugreports in consideration.

Am I wrong here?

I'm asking here because the last time a developer told me another funny story that wasn't right and closed another similar bugreport too. After one question of me, it was reopened and fixed the same day.
Simply it's just not starting up at all.

So just forward it to someone else.

Thanks in advance, again.

Well, let's see, what does that say to me :" May 19 2021, 1:37 PM" Also it has to do with the buildbot like last weeks when it wasn't well implemented. Now it's September and Sergey is nothing else doing than working on cycles-x as Brecht Van Lommel too. If you follow their profile here. Your quote here from Sergey is from May. They are fixing bugs via bugreport since the announcement and public experimental builds. Otherwise wouldn't make sense to upload almost every day a new cycles-x build to test and report BUT not taking bugreports in consideration. Am I wrong here? I'm asking here because the last time a developer told me another funny story that wasn't right and closed another similar bugreport too. After one question of me, it was reopened and fixed the same day. Simply it's just not starting up at all. So just forward it to someone else. Thanks in advance, again.

Added subscriber: @dfelinto

Added subscriber: @dfelinto

@Nurb2Kea thanks for your report, but I just cleared with Brecht and, as Philipp pointed out, they do not want users to report bugs here yet. And he has been actively closing those reports.

Sorry if this was not more clearly communicated.

@Nurb2Kea thanks for your report, but I just cleared with Brecht and, as Philipp pointed out, they do not want users to report bugs here yet. And he has been actively closing those reports. Sorry if this was not more clearly communicated.

We have never accepted bug reports for branches besides master and release as far as I know, regardless if that's cycles-x or some more obscure branch. I don't think it's practical for triagers to keep track of this.

#90650 was fixed before I saw the bug report, so was closed as resolved, which I guess gave the wrong impression that we do accept such reports.

We have never accepted bug reports for branches besides master and release as far as I know, regardless if that's `cycles-x` or some more obscure branch. I don't think it's practical for triagers to keep track of this. #90650 was fixed before I saw the bug report, so was closed as resolved, which I guess gave the wrong impression that we do accept such reports.
Author

Thanks for the information.
Makes no sense to me but ...

I would file those reports instead of closing.

Anyways that's the last reports I saved from some more of me got solved this way.

https://developer.blender.org/T90517
https://developer.blender.org/T90418
https://developer.blender.org/T90650

Also the problem is that Pablo says in his weekly show, to file reports via blender (incl. branches) as well as on right click select where you even get less respose and to write directly to the developers.
Maybe you developers tell the users via Pablo or blender.org, where, when, what to report.
Wastes less time for the developers and the users to test & fill out those reports for nothing.

Thanks, nuff said!

Thanks for the information. Makes no sense to me but ... I would file those reports instead of closing. Anyways that's the last reports I saved from some more of me got solved this way. https://developer.blender.org/T90517 https://developer.blender.org/T90418 https://developer.blender.org/T90650 Also the problem is that Pablo says in his weekly show, to file reports via blender (incl. branches) as well as on right click select where you even get less respose and to write directly to the developers. Maybe you developers tell the users via Pablo or blender.org, where, when, what to report. Wastes less time for the developers and the users to test & fill out those reports for nothing. Thanks, nuff said!
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#91108
No description provided.