Missing Face Set Operators #92944

Open
opened 2021-11-08 21:42:01 +01:00 by Joseph Eagar · 15 comments
Member

This task is a todo list for missing face set operators. - [x] means operator works on either a user-picked face set or all of them. A single arrow means conversion operator in one direction already exist (so, Mask to Face Set already exists).

  • Face Set- <-> Vertex Groups
  • Face Set- <-> Face Maps
  • Face Set- -> UV Seams
  • Face Set- -> Mask
  • Make Disconnected Face Sets Unique
  • Separate By Face Sets
  • Face Set- <-> Material Slots
  • Face Maps <-> Face Sets
This task is a todo list for missing face set operators. - [x] means operator works on either a user-picked face set or all of them. A single arrow means conversion operator in one direction already exist (so, Mask to Face Set already exists). - Face Set- [x] `<->` Vertex Groups - Face Set- [x] `<->` Face Maps - Face Set- [x] `->` UV Seams - Face Set- [x] `->` Mask - Make Disconnected Face Sets Unique - Separate By Face Sets - Face Set- [x] `<->` Material Slots - Face Maps `<->` Face Sets
Joseph Eagar self-assigned this 2021-11-08 21:42:01 +01:00
Author
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Author
Member

Added subscriber: @JosephEagar

Added subscriber: @JosephEagar
First-time contributor

Added subscriber: @TonatiuhdeSanJulian

Added subscriber: @TonatiuhdeSanJulian
First-time contributor

Vertex colors to face sets: so we can use colors of the existing color paint to mask in a very advance way.

Face sets from different density topology areas. And the a way to populate with a especific topological density a face set.

Vertex colors to face sets: so we can use colors of the existing color paint to mask in a very advance way. Face sets from different density topology areas. And the a way to populate with a especific topological density a face set.
Member

Added subscriber: @Mets

Added subscriber: @Mets
Member

I think before spending a lot more dev time on face sets maps, it would be nice to have a design as to their purpose. As far as I understand their current implementation, they can only be used by addons, and those addons could very well just interpret vertex groups as face sets maps by inspecting the topology. The difference between face maps and face sets is even more esoteric.

Also, I think (hope) all of these things will be refactored during the Attribute Edit phase of the Geometry Nodes project, but I could be wrong. But definitely something to double check before you burn a lot of time into this.

I think before spending a lot more dev time on face ~~sets~~ maps, it would be nice to have a design as to their purpose. As far as I understand their current implementation, they can only be used by addons, and those addons could very well just interpret vertex groups as face ~~sets~~ maps by inspecting the topology. The difference between face maps and face sets is even more esoteric. Also, I think (hope) all of these things will be refactored during the Attribute Edit phase of the Geometry Nodes project, but I could be wrong. But definitely something to double check before you burn a lot of time into this.
First-time contributor

In #92944#1251021, @Mets wrote:
I think before spending a lot more dev time on face sets, it would be nice to have a design as to their purpose. As far as I understand their current implementation, they can only be used by addons, and those addons could very well just interpret vertex groups as face sets by inspecting the topology. The different between face maps and face sets is even more esoteric.

Face sets are highly used in sculpt mode, it is an essential tool, every 3d sculptor can say that to you. That is why Joseph want them to be as a complete tool as it can be.

> In #92944#1251021, @Mets wrote: > I think before spending a lot more dev time on face sets, it would be nice to have a design as to their purpose. As far as I understand their current implementation, they can only be used by addons, and those addons could very well just interpret vertex groups as face sets by inspecting the topology. The different between face maps and face sets is even more esoteric. Face sets are highly used in sculpt mode, it is an essential tool, every 3d sculptor can say that to you. That is why Joseph want them to be as a complete tool as it can be.
Member

Sorry, I meant face maps, whose existence is so confusing that I still can't get it right.
So my comment only pertains to

2 Face Set- [x] <-> Face Maps
8 Face Maps <-> Face Sets

Sorry, I meant face maps, whose existence is so confusing that I still can't get it right. So my comment only pertains to > 2 Face Set- [x] <-> Face Maps > 8 Face Maps <-> Face Sets
Member

Added subscriber: @DanielGrauer

Added subscriber: @DanielGrauer
Philipp Oeser removed the
Interest
Sculpt, Paint & Texture
label 2023-02-10 09:11:44 +01:00
Member

@JosephEagar
Not sure if this can be closed. Most of these can be achieved with exisiting operators or geometry nodes.
Some are not even needed since the Face Sets attribute can now be directly accessed.

@JosephEagar Not sure if this can be closed. Most of these can be achieved with exisiting operators or geometry nodes. Some are not even needed since the Face Sets attribute can now be directly accessed.
Julien Kaspar added
Status
Needs Info from Developers
and removed
Status
Confirmed
labels 2023-07-04 09:58:51 +02:00
Author
Member

I saw some users trying to implement some of these with combinations of geometry nodes and scripts on BlenderArtists. It's way too much work.

I saw some users trying to implement some of these with combinations of geometry nodes and scripts on BlenderArtists. It's way too much work.
Member

Just to be clear though. From that list many wouldn't be needed.

  • The primary use case of Vertex Group conversion is to use them for modifiers. In that case, Geometry Nodes offers more options, including using the Face Sets directly, right?
  • Face Maps are essentially depricated and are a generic attribute now. So that's geometry nodes territory.
  • UV Seams and UV maps should be handled by #109773
  • Face Sets can already be filled with a Mask with Expand. No extra operator needed there.
  • "Make Disconnected Face Sets Unique" is already implemented with "Initialize by Face Set Boundaries"
  • I don't know of the use case of converting Face Sets to Material Slots. Would be good to get some info there.
Just to be clear though. From that list many wouldn't be needed. - The primary use case of **Vertex Group** conversion is to use them for modifiers. In that case, Geometry Nodes offers more options, including using the Face Sets directly, right? - **Face Maps** are essentially depricated and are a generic attribute now. So that's geometry nodes territory. - **UV Seams** and **UV maps** should be handled by #109773 - Face Sets can already be filled with a **Mask** with Expand. No extra operator needed there. - "**Make Disconnected Face Sets Unique**" is already implemented with "Initialize by Face Set Boundaries" - I don't know of the use case of converting Face Sets to Material Slots. Would be good to get some info there.
Member

Geometry Nodes offers more options, including using the Face Sets directly, right?

Geometry nodes can't use the .sculpt_face_set attribute directly (except the future node group operators, not the modifier). So we should have an operator to copy face set values to an face domain integer attribute (that could also be a node group operator, depending on the timeline).

>Geometry Nodes offers more options, including using the Face Sets directly, right? Geometry nodes can't use the `.sculpt_face_set` attribute directly (except the future node group operators, not the modifier). So we should have an operator to copy face set values to an face domain integer attribute (that could also be a node group operator, depending on the timeline).
Member

What could be really useful then is to have operators to

  • save masks and face sets as named attributes
  • create masks and face sets from named attributes

This back and forth conversion can offer options for quick use with geometry nodes as well as the ability to store mask and face sets for later use.
For example, the use of "initialize face sets by uv seams" is done because it's a convenient way to store face sets atm. If face sets could just be saved directly, that could be a better way.

The use cases for converting face sets to material slot and vertex groups are not clear to me atm.

What could be really useful then is to have operators to - save masks and face sets as named attributes - create masks and face sets from named attributes This back and forth conversion can offer options for quick use with geometry nodes as well as the ability to store mask and face sets for later use. For example, the use of "initialize face sets by uv seams" is done because it's a convenient way to store face sets atm. If face sets could just be saved directly, that could be a better way. The use cases for converting face sets to material slot and vertex groups are not clear to me atm.
Author
Member

The purpose of converting to material slots is to interface with remesher addons, I imagine addon authors will eventually update them to read face set data directly.

One thing we could do is just make face sets a normal attribute. Almost all of the .sculpt_XXX attributes are temporary ones. We could make all non-temporary sculpt attributes public, so .sculpt_face_set could become paint_face_set or something (remember we want to eventually support face sets in all paint modes). We could do something similar for the persistent base attributes (e.g. .sculpt_persistent_co could be sculpt_persistent_co or something). I dunno.

The purpose of converting to material slots is to interface with remesher addons, I imagine addon authors will eventually update them to read face set data directly. One thing we could do is just make face sets a normal attribute. Almost all of the `.sculpt_XXX` attributes are temporary ones. We could make all non-temporary sculpt attributes public, so `.sculpt_face_set` could become `paint_face_set` or something (remember we want to eventually support face sets in all paint modes). We could do something similar for the persistent base attributes (e.g. `.sculpt_persistent_co` could be `sculpt_persistent_co` or something). I dunno.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#92944
No description provided.