Curve Guide force field causes crash #93338

Closed
opened 2021-11-23 22:21:29 +01:00 by Pierre Puentes · 12 comments

System Information
Operating system: Linux-5.15.2-2-MANJARO-x86_64-with-glibc2.33 64 Bits
Graphics card: NVIDIA GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 495.44

Blender Version
Broken: version: 2.93.5, branch: makepkg (modified), commit date: 2021-10-05 12:04, hash: a791bdabd0
Worked: 2.92

Caused by cf2baa585c

Short description of error
When curve Path Animation is disabled Curve Guide force field will crash

Exact steps for others to reproduce the error
#93338.blend
Open file and play animation

**System Information** Operating system: Linux-5.15.2-2-MANJARO-x86_64-with-glibc2.33 64 Bits Graphics card: NVIDIA GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 495.44 **Blender Version** Broken: version: 2.93.5, branch: makepkg (modified), commit date: 2021-10-05 12:04, hash: `a791bdabd0` Worked: 2.92 Caused by cf2baa585c **Short description of error** When curve Path Animation is disabled Curve Guide force field will crash **Exact steps for others to reproduce the error** [#93338.blend](https://archive.blender.org/developer/F11954978/T93338.blend) Open file and play animation
Author

Added subscriber: @pierreee1

Added subscriber: @pierreee1

Added subscriber: @iss

Added subscriber: @iss

This works when you enable Path Animation in curve properties. But currently this causes to crash when it's not enabled, so I will re-use this report for crash

This works when you enable Path Animation in curve properties. But currently this causes to crash when it's not enabled, so I will re-use this report for crash
Richard Antalik changed title from Curve Guide force field doesn't work with SVG curves to Curve Guide force field causes crash 2021-11-24 05:28:37 +01:00

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

Crashed on

accum_len_arr was NULL

>	blender.exe!BKE_where_on_path(const Object * ob, float ctime, float * r_vec, float * r_dir, float * r_quat, float * r_radius, float * r_weight) Line 280	C

 	blender.exe!do_guides(Depsgraph * depsgraph, ParticleSettings * part, ListBase * effectors, ParticleKey * state, int index, float time) Line 2435	C
 	blender.exe!basic_integrate(ParticleSimulationData * sim, int p, float dfra, float cfra) Line 2329	C
 	blender.exe!dynamics_step(ParticleSimulationData * sim, float cfra) Line 3956	C
 	blender.exe!system_step(ParticleSimulationData * sim, float cfra, const bool use_render_params) Line 4602	C
 	blender.exe!particle_system_update(Depsgraph * depsgraph, Scene * scene, Object * ob, ParticleSystem * psys, const bool use_render_params) Line 4954	C
 	blender.exe!deformVerts(ModifierData * md, const ModifierEvalContext * ctx, Mesh * mesh, float[3] * vertexCos, int numVerts) Line 233	C
 	blender.exe!BKE_modifier_deform_verts(ModifierData * md, const ModifierEvalContext * ctx, Mesh * me, float[3] * vertexCos, int numVerts) Line 1069	C
 	blender.exe!mesh_calc_modifiers(Depsgraph * depsgraph, Scene * scene, Object * ob, const bool use_deform, const bool need_mapping, const CustomData_MeshMasks * dataMask, const int index, const bool use_cache, const bool allow_shared_mesh, Mesh * * r_deform, Mesh * * r_final, GeometrySet * * r_geometry_set) Line 1055	C++
 	blender.exe!mesh_build_data(Depsgraph * depsgraph, Scene * scene, Object * ob, const CustomData_MeshMasks * dataMask, const bool need_mapping) Line 1895	C++
 	blender.exe!makeDerivedMesh(Depsgraph * depsgraph, Scene * scene, Object * ob, BMEditMesh * em, const CustomData_MeshMasks * dataMask) Line 2025	C++
 	blender.exe!BKE_object_handle_data_update(Depsgraph * depsgraph, Scene * scene, Object * ob) Line 204	C
 	blender.exe!BKE_object_eval_uber_data(Depsgraph * depsgraph, Scene * scene, Object * ob) Line 396	C
 	blender.exe!blender::deg::DepsgraphNodeBuilder::build_object_data_geometry::__l2::<lambda>(Depsgraph * depsgraph) Line 1486	C++
 	[External Code]	
 	blender.exe!blender::deg::`anonymous namespace'::evaluate_node(const blender::deg::`anonymous-namespace'::DepsgraphEvalState * state, blender::deg::OperationNode * operation_node) Line 120	C++
 	blender.exe!blender::deg::`anonymous namespace'::deg_task_run_func(TaskPool * pool, void * taskdata) Line 132	C++
 	blender.exe!Task::operator()() Line 179	C++
 	blender.exe!tbb::internal::function_task<Task>::execute() Line 1060	C++
 	[External Code]	
 	blender.exe!tbb::task::wait_for_all() Line 821	C++
 	blender.exe!tbb::internal::task_group_base::wait() Line 168	C++
 	blender.exe!tbb_task_pool_work_and_wait(TaskPool * pool) Line 254	C++
 	blender.exe!BLI_task_pool_work_and_wait(TaskPool * pool) Line 501	C++
 	blender.exe!blender::deg::deg_evaluate_on_refresh(blender::deg::Depsgraph * graph) Line 408	C++
 	blender.exe!deg_flush_updates_and_refresh(blender::deg::Depsgraph * deg_graph) Line 61	C++
 	blender.exe!DEG_evaluate_on_framechange(Depsgraph * graph, float frame) Line 90	C++
 	blender.exe!BKE_scene_graph_update_for_newframe_ex(Depsgraph * depsgraph, const bool clear_recalc) Line 2652	C
 	blender.exe!BKE_scene_graph_update_for_newframe(Depsgraph * depsgraph) Line 2700	C
 	blender.exe!ED_update_for_newframe(Main * bmain, Depsgraph * depsgraph) Line 1802	C
 	blender.exe!screen_animation_step_invoke(bContext * C, wmOperator * UNUSED_op, const wmEvent * event) Line 4757	C
 	blender.exe!wm_operator_invoke(bContext * C, wmOperatorType * ot, wmEvent * event, PointerRNA * properties, ReportList * reports, const bool poll_only, bool use_last_properties) Line 1347	C
 	blender.exe!wm_handler_operator_call(bContext * C, ListBase * handlers, wmEventHandler * handler_base, wmEvent * event, PointerRNA * properties, const unsigned char * kmi_idname) Line 2361	C
 	blender.exe!wm_handlers_do_keymap_with_keymap_handler(bContext * C, wmEvent * event, ListBase * handlers, wmEventHandler_Keymap * handler, wmKeyMap * keymap, const bool do_debug_handler) Line 2714	C
 	blender.exe!wm_handlers_do_intern(bContext * C, wmWindow * win, wmEvent * event, ListBase * handlers) Line 3041	C
 	blender.exe!wm_handlers_do(bContext * C, wmEvent * event, ListBase * handlers) Line 3176	C
 	blender.exe!wm_event_do_handlers(bContext * C) Line 3774	C
 	blender.exe!WM_main(bContext * C) Line 655	C
 	blender.exe!main(int argc, const unsigned char * * UNUSED_argv_c) Line 562	C
 	[External Code]	
Crashed on `accum_len_arr` was NULL ``` > blender.exe!BKE_where_on_path(const Object * ob, float ctime, float * r_vec, float * r_dir, float * r_quat, float * r_radius, float * r_weight) Line 280 C blender.exe!do_guides(Depsgraph * depsgraph, ParticleSettings * part, ListBase * effectors, ParticleKey * state, int index, float time) Line 2435 C blender.exe!basic_integrate(ParticleSimulationData * sim, int p, float dfra, float cfra) Line 2329 C blender.exe!dynamics_step(ParticleSimulationData * sim, float cfra) Line 3956 C blender.exe!system_step(ParticleSimulationData * sim, float cfra, const bool use_render_params) Line 4602 C blender.exe!particle_system_update(Depsgraph * depsgraph, Scene * scene, Object * ob, ParticleSystem * psys, const bool use_render_params) Line 4954 C blender.exe!deformVerts(ModifierData * md, const ModifierEvalContext * ctx, Mesh * mesh, float[3] * vertexCos, int numVerts) Line 233 C blender.exe!BKE_modifier_deform_verts(ModifierData * md, const ModifierEvalContext * ctx, Mesh * me, float[3] * vertexCos, int numVerts) Line 1069 C blender.exe!mesh_calc_modifiers(Depsgraph * depsgraph, Scene * scene, Object * ob, const bool use_deform, const bool need_mapping, const CustomData_MeshMasks * dataMask, const int index, const bool use_cache, const bool allow_shared_mesh, Mesh * * r_deform, Mesh * * r_final, GeometrySet * * r_geometry_set) Line 1055 C++ blender.exe!mesh_build_data(Depsgraph * depsgraph, Scene * scene, Object * ob, const CustomData_MeshMasks * dataMask, const bool need_mapping) Line 1895 C++ blender.exe!makeDerivedMesh(Depsgraph * depsgraph, Scene * scene, Object * ob, BMEditMesh * em, const CustomData_MeshMasks * dataMask) Line 2025 C++ blender.exe!BKE_object_handle_data_update(Depsgraph * depsgraph, Scene * scene, Object * ob) Line 204 C blender.exe!BKE_object_eval_uber_data(Depsgraph * depsgraph, Scene * scene, Object * ob) Line 396 C blender.exe!blender::deg::DepsgraphNodeBuilder::build_object_data_geometry::__l2::<lambda>(Depsgraph * depsgraph) Line 1486 C++ [External Code] blender.exe!blender::deg::`anonymous namespace'::evaluate_node(const blender::deg::`anonymous-namespace'::DepsgraphEvalState * state, blender::deg::OperationNode * operation_node) Line 120 C++ blender.exe!blender::deg::`anonymous namespace'::deg_task_run_func(TaskPool * pool, void * taskdata) Line 132 C++ blender.exe!Task::operator()() Line 179 C++ blender.exe!tbb::internal::function_task<Task>::execute() Line 1060 C++ [External Code] blender.exe!tbb::task::wait_for_all() Line 821 C++ blender.exe!tbb::internal::task_group_base::wait() Line 168 C++ blender.exe!tbb_task_pool_work_and_wait(TaskPool * pool) Line 254 C++ blender.exe!BLI_task_pool_work_and_wait(TaskPool * pool) Line 501 C++ blender.exe!blender::deg::deg_evaluate_on_refresh(blender::deg::Depsgraph * graph) Line 408 C++ blender.exe!deg_flush_updates_and_refresh(blender::deg::Depsgraph * deg_graph) Line 61 C++ blender.exe!DEG_evaluate_on_framechange(Depsgraph * graph, float frame) Line 90 C++ blender.exe!BKE_scene_graph_update_for_newframe_ex(Depsgraph * depsgraph, const bool clear_recalc) Line 2652 C blender.exe!BKE_scene_graph_update_for_newframe(Depsgraph * depsgraph) Line 2700 C blender.exe!ED_update_for_newframe(Main * bmain, Depsgraph * depsgraph) Line 1802 C blender.exe!screen_animation_step_invoke(bContext * C, wmOperator * UNUSED_op, const wmEvent * event) Line 4757 C blender.exe!wm_operator_invoke(bContext * C, wmOperatorType * ot, wmEvent * event, PointerRNA * properties, ReportList * reports, const bool poll_only, bool use_last_properties) Line 1347 C blender.exe!wm_handler_operator_call(bContext * C, ListBase * handlers, wmEventHandler * handler_base, wmEvent * event, PointerRNA * properties, const unsigned char * kmi_idname) Line 2361 C blender.exe!wm_handlers_do_keymap_with_keymap_handler(bContext * C, wmEvent * event, ListBase * handlers, wmEventHandler_Keymap * handler, wmKeyMap * keymap, const bool do_debug_handler) Line 2714 C blender.exe!wm_handlers_do_intern(bContext * C, wmWindow * win, wmEvent * event, ListBase * handlers) Line 3041 C blender.exe!wm_handlers_do(bContext * C, wmEvent * event, ListBase * handlers) Line 3176 C blender.exe!wm_event_do_handlers(bContext * C) Line 3774 C blender.exe!WM_main(bContext * C) Line 655 C blender.exe!main(int argc, const unsigned char * * UNUSED_argv_c) Line 562 C [External Code] ```
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Philipp Oeser self-assigned this 2021-11-25 13:25:44 +01:00
Member

Caused by cf2baa585c, think I got a fix...
(will also tag #animation_rigging , since this involves anim paths)

Caused by cf2baa585c, think I got a fix... (will also tag #animation_rigging , since this involves anim paths)

This issue was referenced by c2971eea84

This issue was referenced by c2971eea8434f6487ffa6e77d604c775a97b13ef

This issue was referenced by ffddf9e5c9

This issue was referenced by ffddf9e5c9175d25078ca441b21e5eb478ecd106
Member

Added subscriber: @ZedDB

Added subscriber: @ZedDB
Member

Will need to tag with High priority since it is a crash regression with a culprit commit identified, but in my opinion, this does not have to be solved for 3.0 (since it has been around 2.93 as well).

CC @ZedDB

Will need to tag with High priority since it is a crash regression with a culprit commit identified, but in my opinion, this does not have to be solved for 3.0 (since it has been around 2.93 as well). CC @ZedDB
Member

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#93338
No description provided.