Linked libraries+Cloth objects+LineArt -> Blender crashes #95832

Open
opened 2022-02-17 11:48:02 +01:00 by Carlos Lopez · 8 comments

System Information
Operating system: "Linux Mint 20.1 Ulyssa"

Graphics card: NVIDIA Corporation TU106 [GeForce RTX 2060]

Blender Version Blender 3.0.0, Commit date: 2021-12-02 18:35, Hash f1cca30557

Short description of error
Linked libraries+Cloth objects+LineArt -> Blender crashes

I'm in kind complex project. There're characters (roughly meshed, and bad rigged, but working), with 'clothed' hair, and all of them LineArted.
Many of the scene files work ok, so they've not much characters. But I don't know why, some of them can't render more of a bunch of frames, even they crash when calculating something (i don't know if's about either cloth, collisions or LineArt modifiers, or whatever.
Memory looks ok, a little is used.
I attach both files: a scene, and the characters source (personajes.blend).

  • Load 's4 pl1 coleAna.blend'
  • Just 'Play' and wait.

For me, it crashes after 5 frames or so.

A simpler backtrace:

backtrace

/home/klopes/soft/blender3/blender(BLI_system_backtrace+0x20) [0xb0b3460]
/home/klopes/soft/blender3/blender() [0x10babdb]
/lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7fdfaf178210]
/home/klopes/soft/blender3/blender() [0x2349478]
/home/klopes/soft/blender3/blender() [0x234a454]
/home/klopes/soft/blender3/blender() [0xb0b71dd]
/home/klopes/soft/blender3/blender() [0x14b5b05]
/home/klopes/soft/blender3/blender() [0x14b5dbb]
/home/klopes/soft/blender3/blender() [0x14a49b7]
/home/klopes/soft/blender3/blender() [0x14af7f0]
/home/klopes/soft/blender3/blender() [0x14b182c]
/home/klopes/soft/blender3/blender() [0x14b1a29]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x9609) [0x7fdfaf874609]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x43) [0x7fdfaf254293]

  • Python backtrace
**System Information** Operating system: "Linux Mint 20.1 Ulyssa" Graphics card: NVIDIA Corporation TU106 [GeForce RTX 2060] **Blender Version** Blender 3.0.0, Commit date: 2021-12-02 18:35, Hash f1cca3055776 **Short description of error** Linked libraries+Cloth objects+LineArt -> Blender crashes I'm in kind complex project. There're characters (roughly meshed, and bad rigged, but working), with 'clothed' hair, and all of them LineArted. Many of the scene files work ok, so they've not much characters. But I don't know why, some of them can't render more of a bunch of frames, even they crash when calculating something (i don't know if's about either cloth, collisions or LineArt modifiers, or whatever. Memory looks ok, a little is used. I attach both files: a scene, and the characters source (personajes.blend). - Load 's4 pl1 coleAna.blend' - Just 'Play' and wait. For me, it crashes after 5 frames or so. A simpler backtrace: # backtrace /home/klopes/soft/blender3/blender(BLI_system_backtrace+0x20) [0xb0b3460] /home/klopes/soft/blender3/blender() [0x10babdb] /lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7fdfaf178210] /home/klopes/soft/blender3/blender() [0x2349478] /home/klopes/soft/blender3/blender() [0x234a454] /home/klopes/soft/blender3/blender() [0xb0b71dd] /home/klopes/soft/blender3/blender() [0x14b5b05] /home/klopes/soft/blender3/blender() [0x14b5dbb] /home/klopes/soft/blender3/blender() [0x14a49b7] /home/klopes/soft/blender3/blender() [0x14af7f0] /home/klopes/soft/blender3/blender() [0x14b182c] /home/klopes/soft/blender3/blender() [0x14b1a29] /lib/x86_64-linux-gnu/libpthread.so.0(+0x9609) [0x7fdfaf874609] /lib/x86_64-linux-gnu/libc.so.6(clone+0x43) [0x7fdfaf254293] - Python backtrace
Author

Added subscriber: @klopes-4

Added subscriber: @klopes-4
Author
[s4 pl1 coleAna.blend](https://archive.blender.org/developer/F12871095/s4_pl1_coleAna.blend) [personajes.blend](https://archive.blender.org/developer/F12871096/personajes.blend)
Member

Added subscriber: @lichtwerk

Added subscriber: @lichtwerk
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Can confirm, will check.

Can confirm, will check.
Member

Added subscriber: @ChengduLittleA

Added subscriber: @ChengduLittleA
Member

Seems to be a threading issue in lineart (or at least triggered by lineart).
For me, starting blender from the commandline with --threads 1 gets rid of the crash

1  lineart_geometry_object_load                                                                                                                              lineart_cpu.c 1729 0x5b4ed70      
2  lineart_object_load_worker                                                                                                                                lineart_cpu.c 1984 0x5b4fe6c      
3  Task::operator()                                                                                                                                          task_pool.cc  164  0x103ebffb     
4  tbb::internal::function_task<Task>::execute                                                                                                               task.h        1059 0x103ecce6     
5  tbb::internal::custom_scheduler<tbb::internal::IntelSchedulerTraits>::process_bypass_loop(tbb::internal::context_guard_helper<false>&, tbb::task *, long)                    0x42e4d65      
6  tbb::internal::custom_scheduler<tbb::internal::IntelSchedulerTraits>::local_wait_for_all(tbb::task&, tbb::task *)                                                            0x42e501b      
7  tbb::internal::arena::process(tbb::internal::generic_scheduler&)                                                                                                             0x42d3c17      
8  tbb::internal::market::process(rml::job&)                                                                                                                                    0x42dea50      
9  tbb::internal::rml::private_worker::run()                                                                                                                                    0x42e0a8c      
10 tbb::internal::rml::private_worker::thread_routine(void *)                                                                                                                   0x42e0c89      
11 start_thread                                                                                                                                                                 0x7ffff7a900e7 
12 clone3      

CC @ChengduLittleA

Seems to be a threading issue in lineart (or at least triggered by lineart). For me, starting blender from the commandline with `--threads 1` gets rid of the crash ``` 1 lineart_geometry_object_load lineart_cpu.c 1729 0x5b4ed70 2 lineart_object_load_worker lineart_cpu.c 1984 0x5b4fe6c 3 Task::operator() task_pool.cc 164 0x103ebffb 4 tbb::internal::function_task<Task>::execute task.h 1059 0x103ecce6 5 tbb::internal::custom_scheduler<tbb::internal::IntelSchedulerTraits>::process_bypass_loop(tbb::internal::context_guard_helper<false>&, tbb::task *, long) 0x42e4d65 6 tbb::internal::custom_scheduler<tbb::internal::IntelSchedulerTraits>::local_wait_for_all(tbb::task&, tbb::task *) 0x42e501b 7 tbb::internal::arena::process(tbb::internal::generic_scheduler&) 0x42d3c17 8 tbb::internal::market::process(rml::job&) 0x42dea50 9 tbb::internal::rml::private_worker::run() 0x42e0a8c 10 tbb::internal::rml::private_worker::thread_routine(void *) 0x42e0c89 11 start_thread 0x7ffff7a900e7 12 clone3 ``` CC @ChengduLittleA
YimingWu self-assigned this 2022-02-19 14:47:13 +01:00
Member

Thanks for the report. I'll take a look with provided files.

Thanks for the report. I'll take a look with provided files.
Sergey Sharybin added
Module
Grease Pencil
and removed
Module
VFX & Video
labels 2023-02-13 18:07:14 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#95832
No description provided.