Action Constraint BUG - "Child of" Constraint on driving bone, local transform values don't drive action like a traditionally parented bone. #95896

Open
opened 2022-02-19 19:13:52 +01:00 by Tyler Walker · 8 comments

System Information
Operating system: Windows 11
Graphics card: RTX 2070

Blender Version
Broken: 3.0.0 Master
Worked: Never

Short description of error
With an action constraint driven by a local space transformation channel, rotation of any parent bone in the chain breaks evaluation.

Exact steps for others to reproduce the error
I've just made a simple 3 bone rig to test this action constraint issue and found the root cause.
Action Constraint Rotation Test.blend

Turns out the problem only happens when a Child of Constraint is used on the bone driving the action constraint. When you use a bone with a true parent to drive the action constraint this behaves as expected.

Blender_ [G__My Drive__Commissions_Koop - Jeremiah Bethune_Modular Stylized Character_Action Constraint Rotation Test.blend] 2022-02-19 17-32-06_Trim.mp4

The same problem is illustrated in this file in a character rig application:
ModularStylilzed_Character.blend
Blender_ Constraint Example Koop 2022-02-19 09-42-54.mp4

Upon rotation of any parent bone in the chain, the constraint is not evaluated the same. Even though the local transformation is exactly the same on the hand bone (which drives the action constraint). Example with root bone rotated 45 degrees:
image.png

Here's what the constraint setup looks like:
image.png

This problem happens whether I select "Local" or "Local with Parent" for the target transform type.

**System Information** Operating system: Windows 11 Graphics card: RTX 2070 **Blender Version** Broken: 3.0.0 Master Worked: Never **Short description of error** With an action constraint driven by a local space transformation channel, rotation of any parent bone in the chain breaks evaluation. **Exact steps for others to reproduce the error** I've just made a simple 3 bone rig to test this action constraint issue and found the root cause. [Action Constraint Rotation Test.blend](https://archive.blender.org/developer/F12877097/Action_Constraint_Rotation_Test.blend) Turns out the problem only happens when a Child of Constraint is used on the bone driving the action constraint. When you use a bone with a true parent to drive the action constraint this behaves as expected. [Blender_ [G__My Drive__Commissions_Koop - Jeremiah Bethune_Modular Stylized Character_Action Constraint Rotation Test.blend] 2022-02-19 17-32-06_Trim.mp4](https://archive.blender.org/developer/F12877101/Blender___G__My_Drive__Commissions_Koop_-_Jeremiah_Bethune_Modular_Stylized_Character_Action_Constraint_Rotation_Test.blend__2022-02-19_17-32-06_Trim.mp4) The same problem is illustrated in this file in a character rig application: [ModularStylilzed_Character.blend](https://archive.blender.org/developer/F12876154/ModularStylilzed_Character.blend) [Blender_ Constraint Example Koop 2022-02-19 09-42-54.mp4](https://archive.blender.org/developer/F12876161/Blender__Constraint_Example_Koop_2022-02-19_09-42-54.mp4) Upon rotation of any parent bone in the chain, the constraint is not evaluated the same. Even though the local transformation is exactly the same on the hand bone (which drives the action constraint). Example with root bone rotated 45 degrees: ![image.png](https://archive.blender.org/developer/F12876157/image.png) Here's what the constraint setup looks like: ![image.png](https://archive.blender.org/developer/F12876155/image.png) This problem happens whether I select "Local" or "Local with Parent" for the target transform type.
Author

Added subscriber: @tyler.tofu

Added subscriber: @tyler.tofu
Author

This comment was removed by @tyler.tofu

*This comment was removed by @tyler.tofu*
Tyler Walker changed title from Action Constraint - Local Space With/Without Parent breaks w/Parent Rotation to Action Constraint BUG - "Child of" Constraint on driving bone, local transform values don't match traditionally parented driving bone. 2022-02-20 07:50:42 +01:00
Author

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Tyler Walker changed title from Action Constraint BUG - "Child of" Constraint on driving bone, local transform values don't match traditionally parented driving bone. to Action Constraint BUG - "Child of" Constraint on driving bone, local transform values don't drive action like a traditionally parented bone. 2022-02-20 07:52:46 +01:00
Author

Changed status from 'Confirmed' to: 'Needs Triage'

Changed status from 'Confirmed' to: 'Needs Triage'
Member

Added subscriber: @OmarEmaraDev

Added subscriber: @OmarEmaraDev
Member

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'
Member

It seems the Target's local space location is considered to be that after constraints are applied on the target bone. The documentation states for Local Space that:

Only transformations applied to the object or bone itself are taken into account.

So either the behavior is wrong or the documentation should clarify that by stating that constraints are taken into account. Tagging the appropriate module for clarification.

It seems the Target's local space location is considered to be that after constraints are applied on the target bone. The documentation states for Local Space that: > Only transformations applied to the object or bone itself are taken into account. So either the behavior is wrong or the documentation should clarify that by stating that constraints are taken into account. Tagging the appropriate module for clarification.
Author

In #95896#1311020, @OmarEmaraDev wrote:
It seems the Target's local space location is considered to be that after constraints are applied on the target bone. The documentation states for Local Space that:

Only transformations applied to the object or bone itself are taken into account.

So either the behavior is wrong or the documentation should clarify that by stating that constraints are taken into account. Tagging the appropriate module for clarification.

> In #95896#1311020, @OmarEmaraDev wrote: > It seems the Target's local space location is considered to be that after constraints are applied on the target bone. The documentation states for Local Space that: >> Only transformations applied to the object or bone itself are taken into account. > So either the behavior is wrong or the documentation should clarify that by stating that constraints are taken into account. Tagging the appropriate module for clarification.
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:35:11 +01:00
Sybren A. Stüvel added this to the Animation & Rigging project 2023-02-14 15:33:51 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#95896
No description provided.