Grease Pencil modifier "line art" won't draw objects with Geometry Nodes Instances. #98424

Open
opened 2022-05-27 08:30:11 +02:00 by Luciano Muñoz Sessarego · 10 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 471.96

Blender Version
Broken: version: 3.3.0 Alpha, branch: master, commit date: 2022-05-25 21:21, hash: dc6fe73e70
image.png

Worked: Blender 3.2
image.png

Short description of error
Grease Pencil modifier "line art" won't draw objects with Geometry Nodes Instances.

Exact steps for others to reproduce the error

  • New scene.
  • Keep the cube.
  • Don't delete it.
  • Add an empty Grease Pencil Object.
  • Don't delete the cube.
  • Add a Line Art Modifier to the Grease Pencil Object,
  • Switch Source to Object, and select the cube.
  • Assign the default layer and material.
  • You should be seeing something like this

image.png

  • Add geometry nodes nodes to the cube.
  • yes keep the damn cube.
  • here is the simplest setup that involves instances that I could think of

image.png

  • as you can see in the viewport the grease pencil line art has dissapeared completely.

Thanks for looking into it.

**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 471.96 **Blender Version** Broken: version: 3.3.0 Alpha, branch: master, commit date: 2022-05-25 21:21, hash: `dc6fe73e70` ![image.png](https://archive.blender.org/developer/F13113035/image.png) Worked: Blender 3.2 ![image.png](https://archive.blender.org/developer/F13113043/image.png) **Short description of error** Grease Pencil modifier "line art" won't draw objects with Geometry Nodes Instances. **Exact steps for others to reproduce the error** - New scene. - Keep the cube. - Don't delete it. - Add an empty Grease Pencil Object. - Don't delete the cube. - Add a Line Art Modifier to the Grease Pencil Object, - Switch Source to Object, and select the cube. - Assign the default layer and material. - You should be seeing something like this ![image.png](https://archive.blender.org/developer/F13113050/image.png) - Add geometry nodes nodes to the cube. - yes keep the damn cube. - here is the simplest setup that involves instances that I could think of ![image.png](https://archive.blender.org/developer/F13113055/image.png) - as you can see in the viewport the grease pencil line art has dissapeared completely. Thanks for looking into it.
Author
Member

Added subscriber: @LucianoMunoz

Added subscriber: @LucianoMunoz

Added subscriber: @frogstomp-4

Added subscriber: @frogstomp-4

@LucianoMunoz try adding "realize instances" node before output
image.png

@LucianoMunoz try adding "realize instances" node before output ![image.png](https://archive.blender.org/developer/F13113071/image.png)
Author
Member

Yes that works, thanks !
but that's not the point tho. :)

Yes that works, thanks ! but that's not the point tho. :)

@LucianoMunoz this is expected behaviour. You need to use realize instances also if you want to use modifiers on geometry nodes outputs.

Bevel modifier in this case would not produce any effect if you didn't use realize instances.
image.png

@LucianoMunoz this is expected behaviour. You need to use realize instances also if you want to use modifiers on geometry nodes outputs. Bevel modifier in this case would not produce any effect if you didn't use realize instances. ![image.png](https://archive.blender.org/developer/F13113165/image.png)
Member

Added subscribers: @ChengduLittleA, @OmarEmaraDev

Added subscribers: @ChengduLittleA, @OmarEmaraDev
Member

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

@ChengduLittleA Not sure if this is due to a change in LineArt or GN? Let me know if you want me to bisect.

@ChengduLittleA Not sure if this is due to a change in LineArt or GN? Let me know if you want me to bisect.
Member

@frogstomp-4 I think the point is that it used to work up until recently, so it is not an intrinsic limitation.

@frogstomp-4 I think the point is that it used to work up until recently, so it is not an intrinsic limitation.
YimingWu self-assigned this 2022-05-27 09:43:15 +02:00
Member

Hi! This is due to a recent change in how line art loads objects (which is still wrong but we don't have a viable way in terms of depsgraph usage, basically we can't actually iterate objects and instance during line art evaluation). I'm not that familiar with depsgraph to present a very solid solution for it, but there will be a solution to come.

I actually want to revert back to the original object iterator since that's how line art has been doing stuff all this time, though it's incorrect and theoretically could cause access conflicts in depsgraph, we actually didn't have any(?) bug reports regarding line art crashes that's determined to be caused by this, and I myself haven't experienced this sort of crashes either (which is probably why I or GP guys never knew the way we are doing stuff is technically wrong).

Hi! This is due to a recent change in how line art loads objects (which is still wrong but we don't have a viable way in terms of depsgraph usage, basically we can't actually iterate objects and instance during line art evaluation). I'm not that familiar with depsgraph to present a very solid solution for it, but there will be a solution to come. I actually want to revert back to the original object iterator since that's how line art has been doing stuff all this time, though it's incorrect and theoretically could cause access conflicts in depsgraph, we actually didn't have any(?) bug reports regarding line art crashes that's determined to be caused by this, and I myself haven't experienced this sort of crashes either (which is probably why I or GP guys never knew the way we are doing stuff is technically wrong).
Sergey Sharybin added
Module
Grease Pencil
and removed
Module
VFX & Video
labels 2023-02-13 18:08:49 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#98424
No description provided.