If this needs to be inlined, add a comment explaining why, otherwise use normal_quad_v3
.
picky having code comments phrased as questions tends to make them less clear,
Firstly, this is a welcome additions which users will appreciate.
picky, for booleans defines that aren't defines by CMake, we often have USE_
as a prefix to differentiate them from defines that represent enum/values... etc.
While there are cases in Blender where both 0-100 percentages and factors are used, I generally prefer to use 0..1 for influence factors, this property can use PROP_FACTOR
with a maximum of 2.0.
For clarity: instead of checking s.topo_influnce != 0
replace this with a boolean, e.g. s.use_topo_influnce
.
picky use NOTE:
see tags
in https://developer.blender.org/docs/handbook/guidelines/c_cpp/#comments
See related comments to magic numbers, re: .99
.
picky Find
-> Calculate
, since find typically relates to a lookup/search - where the value may not be found.
See related comment on defining & commenting magic numbers.
It's good to define magic numbers and comment them to help others follow the logic.
Since the code in this function requires const-cast, it's better not to make them const.
Incidentally this PR prompted a more general cleanup: 093a3abbd42d978dec25d9255b5e08cfd2a0c6fd As some of the issues mentioned in review were found in other operators.
Indeed, there is such kind of a problem in software that set box selection by default - workflow-wise box selection blocks picking actions, delimiting them by threshold, and thresholds is not…
Committed to main, made some minor changes, skip hidden vertices & replace magic numbers with the enum ID's.