If that's convention then I'll switch the file to do this - though I do believe that in general readability is improved if you consider how files are usually read from top to bottom. We don't have…
In this particular case, I think it helps organize the file a bit better, letting the data_init
function be one of the first things you read.
As a side note, if you decide to test this PR locally, the default
Bend
deformation type behaves extremely weird for both Dyntopo and MultiresBut this isn't something this PR…
Note to self to remove this extra unique_ptr
- it's likely causing an extra allocation here.
The original code going back to when this brush was first implemented also uses initial_vert
here for this check instead of boundary_initial_vert
, despite the intention seemingly being to check the found boundary. I haven't done adequate testing to determine if this change should actually be made yet.