Sean Kim Sean-Kim
  • Joined on 2023-12-14
Sean Kim created branch subdivide-undo-push in Sean-Kim/blender 2024-11-16 03:18:22 +01:00
Sean Kim pushed to cleanup-subdivide-op at Sean-Kim/blender 2024-11-15 02:10:54 +01:00
ef3a72cfb2 Cleanup: Avoid setting multires level twice when subdividing
Sean Kim created branch cleanup-subdivide-op in Sean-Kim/blender 2024-11-15 02:10:54 +01:00
Sean Kim commented on pull request blender/blender#130253 2024-11-15 00:46:28 +01:00
Subdiv: Warn when no object is selected for subdivision_set

I don't think we should go further in this direction. There are many small scenarios where it can accidentally or intentionally happen to have an object active but not selected. Is it…

Sean Kim commented on issue blender/blender#130200 2024-11-14 23:58:45 +01:00
Vulkan: Repeated Crashes in Sculpt Mode

@PratikPB2123 I think the more likely root cause here based on their most recent comment is something related to Vulkan, not necessarily the brush being used - possibly a memory leak given the…

Sean Kim deleted branch calc-mesh-intersect-data from Sean-Kim/blender 2024-11-14 23:52:54 +01:00
Sean Kim pushed to main at blender/blender 2024-11-14 23:52:49 +01:00
1e357cdca8 Cleanup: Change calc_*_intersect_data functions to take depth by value
Sean Kim merged pull request blender/blender#130256 2024-11-14 23:52:49 +01:00
Cleanup: Change calc_*_intersect_data functions to take depth by value
Sean Kim commented on pull request blender/blender#130241 2024-11-14 23:51:14 +01:00
Subdiv: Start replacement of "converter" abstraction

Just small inline comments so far; changes seem sane but I haven't pulled this down to test at all yet.

Sean Kim commented on pull request blender/blender#130241 2024-11-14 23:51:13 +01:00
Subdiv: Start replacement of "converter" abstraction

for (const int face_index : src_faces.index_range())?

Sean Kim commented on pull request blender/blender#130241 2024-11-14 23:51:12 +01:00
Subdiv: Start replacement of "converter" abstraction

Do we need an UNUSED_VARS here to silence a possible warning? I'm not really sure why I haven't seen any of the other unused vars in this file give a warning while doing other changes.

Sean Kim commented on pull request blender/blender#130241 2024-11-14 23:51:10 +01:00
Subdiv: Start replacement of "converter" abstraction

nit: I personally think BLI_assert(!face.is_empty()) is clearer

Sean Kim commented on pull request blender/blender#130241 2024-11-14 23:51:09 +01:00
Subdiv: Start replacement of "converter" abstraction

nit: Should we update this to num_face_verts?

Sean Kim commented on pull request blender/blender#130254 2024-11-14 23:25:06 +01:00
Fix #110879: Multires relative subdivide navigation subdivides mesh

Ah, true. I forgot to put a note here that I was considering if a nested any would make this more readable.

Sean Kim commented on pull request blender/blender#130254 2024-11-14 23:23:44 +01:00
Fix #110879: Multires relative subdivide navigation subdivides mesh

Invalid is probably not the right word here - it's more that it seemed like something we didn't want. I think it's probably fine to expose this as an option but not set it for any of our keymaps,…

Sean Kim created pull request blender/blender#130256 2024-11-14 05:51:46 +01:00
Cleanup: Change calc_*_intersect_data functions to take depth by value
Sean Kim pushed to calc-mesh-intersect-data at Sean-Kim/blender 2024-11-14 05:50:05 +01:00
feae24ddd8 Cleanup: Change calc_*_intersect_data functions to take depth by value
6b7ba4c726 Refactor: Sculpt: Avoid storing extra undo data on geometry_push
9396c8f388 Workbench: Replace usage of legacy GLSL libraries by new ones
c6e7cdbc57 Merge branch 'blender-v4.3-release'
8f200d96b2 Fix: Nodes: group edit button unintentionally drawn on NodeCustomGroup
Compare 2270 commits »
Sean Kim commented on pull request blender/blender#130254 2024-11-14 04:11:27 +01:00
Fix #110879: Multires relative subdivide navigation subdivides mesh

I have this defaulted to True for backwards compatibility if there are scripts using this, but I think defaulting to False probably makes more sense from a design perspective, interested in thoughts here.