Cycles HIP rendering doesn't work with Radeon RX 6800 XT #106225

Closed
opened 2023-03-28 16:24:39 +02:00 by Emily Smirle · 6 comments

System Information
Operating system: Windows 10 Pro Version 10.0.19045 Build 19045
Graphics card: AMD Radeon RX 6800 XT (AMD Driver version 31.0.12044.3)
Processor: AMD Ryzen 7 1800X Eight-Core Processor, 3600 Mhz, 8 Core(s), 16 Logical Processor(s)

Blender Version
Confirmed Broken: 3.6 Alpha 2023-03-27 01:08 hash bb2dc141f2 (main branch)
Confirmed Broken: 3.6 Alpha 2023-03-20 14:55 hash 16fbadde36 (main branch)
Worked: 5.3.0 RC 2023.03.24 13:18 d5d8246441 (blender-v3.5-release branch)

Short description of error
Blender fails when I use Cycles as my rendering method, with the message HIP binary kernel for this graphics card compute capability (10.3) not found.

Exact steps for others to reproduce the error

  1. Start a factory-default session, with a factory-default startup.blend
  2. Go to Edit -> Preferences -> System
  3. Under Cycles Render Devices, select HIP, and confirm your AMD Radeon RX 6800 XT is checked as a valid rendering device. Leave CPU unchecked.
  4. Save preferences, close Preferences window
  5. Change Render engine to Cycles, Supported feature set, GPU compute.
  6. Change Viewport to Rendered

Scene does not render, error message HIP binary kernel for this graphics card compute capability (10.3) not found. is displayed at the top left of the screen.

Console error:

HIP binary kernel for this graphics card compute capability (10.3) not found.

Refer to the Cycles GPU rendering documentation for possible solutions:
https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html

The Radeon RX 6000 series is listed as supported on the URL provided. I am using AMD Driver version 31.0.12044.3, the minimum listed is 21.12.1

**System Information** Operating system: Windows 10 Pro Version 10.0.19045 Build 19045 Graphics card: AMD Radeon RX 6800 XT (AMD Driver version 31.0.12044.3) Processor: AMD Ryzen 7 1800X Eight-Core Processor, 3600 Mhz, 8 Core(s), 16 Logical Processor(s) **Blender Version** Confirmed Broken: 3.6 Alpha 2023-03-27 01:08 hash bb2dc141f22f (main branch) Confirmed Broken: 3.6 Alpha 2023-03-20 14:55 hash 16fbadde363c (main branch) Worked: 5.3.0 RC 2023.03.24 13:18 d5d8246441a5 (blender-v3.5-release branch) **Short description of error** Blender fails when I use Cycles as my rendering method, with the message `HIP binary kernel for this graphics card compute capability (10.3) not found.` **Exact steps for others to reproduce the error** 1. Start a factory-default session, with a factory-default startup.blend 2. Go to Edit -> Preferences -> System 3. Under Cycles Render Devices, select HIP, and confirm your `AMD Radeon RX 6800 XT` is checked as a valid rendering device. Leave CPU unchecked. 4. Save preferences, close Preferences window 5. Change Render engine to Cycles, Supported feature set, GPU compute. 6. Change Viewport to Rendered Scene does not render, error message `HIP binary kernel for this graphics card compute capability (10.3) not found.` is displayed at the top left of the screen. *Console error:* HIP binary kernel for this graphics card compute capability (10.3) not found. Refer to the Cycles GPU rendering documentation for possible solutions: https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html The Radeon RX 6000 series is listed as supported on the URL provided. I am using AMD Driver version 31.0.12044.3, the minimum listed is 21.12.1
Emily Smirle added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-03-28 16:24:40 +02:00

I feel like here needs a developer to tell us what's going on.

Something that can help identify the cause is the cycles log.
So please open Blender's installation directory and double click on the blender_debug_gpu.cmd. This will start Blender in debug mode and create log files.
Try to reproduce the error again.
Once you close Blender the Windows Explorer should open and show you up to two files, a debug log and the system information.
Add them to your bug report by clicking on the upload button below or via drag and drop.

I feel like here needs a developer to tell us what's going on. Something that can help identify the cause is the cycles log. So please open Blender's installation directory and double click on the `blender_debug_gpu.cmd`. This will start Blender in debug mode and create log files. Try to reproduce the error again. Once you close Blender the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them to your bug report by clicking on the upload button below or via drag and drop.
Author

Hello, I've done as requested, and attached the log files!

Hello, I've done as requested, and attached the log files!
Author

I took a peek in the Cycles\lib folder mentioned in the log and I see that the list is much shorter in 3.6 than in the 3.5 candidate:

in 3.6 (broken):

kernel_compute_75.ptx
kernel_optix.ptx
kernel_optix_osl.ptx
kernel_optix_osl_services.ptx
kernel_optix_shader_raytrace.ptx
kernel_sm_30.cubin
kernel_sm_35.cubin
kernel_sm_37.cubin
kernel_sm_50.cubin
kernel_sm_52.cubin
kernel_sm_60.cubin
kernel_sm_61.cubin
kernel_sm_70.cubin
kernel_sm_75.cubin
kernel_sm_86.cubin

in 3.5 (working):

kernel_compute_75.ptx
kernel_gfx1010.fatbin
kernel_gfx1011.fatbin
kernel_gfx1012.fatbin
kernel_gfx1030.fatbin
kernel_gfx1031.fatbin
kernel_gfx1032.fatbin
kernel_gfx1034.fatbin
kernel_gfx1035.fatbin
kernel_gfx1100.fatbin
kernel_gfx1101.fatbin
kernel_gfx1102.fatbin
kernel_gfx900.fatbin
kernel_gfx902.fatbin
kernel_gfx906.fatbin
kernel_gfx90c.fatbin
kernel_optix.ptx
kernel_optix_osl.ptx
kernel_optix_osl_services.ptx
kernel_optix_shader_raytrace.ptx
kernel_sm_30.cubin
kernel_sm_35.cubin
kernel_sm_37.cubin
kernel_sm_50.cubin
kernel_sm_52.cubin
kernel_sm_60.cubin
kernel_sm_61.cubin
kernel_sm_70.cubin
kernel_sm_75.cubin
kernel_sm_86.cubin

... and the missing files are the entire series of kernel_gfx*.fatbin

Can I work around the issue by copying those over into my 3.6 folder until a new build is up with the missing files? Or are these very version specific?

I took a peek in the Cycles\lib folder mentioned in the log and I see that the list is much shorter in 3.6 than in the 3.5 candidate: **in 3.6 (broken):** ``` kernel_compute_75.ptx kernel_optix.ptx kernel_optix_osl.ptx kernel_optix_osl_services.ptx kernel_optix_shader_raytrace.ptx kernel_sm_30.cubin kernel_sm_35.cubin kernel_sm_37.cubin kernel_sm_50.cubin kernel_sm_52.cubin kernel_sm_60.cubin kernel_sm_61.cubin kernel_sm_70.cubin kernel_sm_75.cubin kernel_sm_86.cubin ``` **in 3.5 (working):** ``` kernel_compute_75.ptx kernel_gfx1010.fatbin kernel_gfx1011.fatbin kernel_gfx1012.fatbin kernel_gfx1030.fatbin kernel_gfx1031.fatbin kernel_gfx1032.fatbin kernel_gfx1034.fatbin kernel_gfx1035.fatbin kernel_gfx1100.fatbin kernel_gfx1101.fatbin kernel_gfx1102.fatbin kernel_gfx900.fatbin kernel_gfx902.fatbin kernel_gfx906.fatbin kernel_gfx90c.fatbin kernel_optix.ptx kernel_optix_osl.ptx kernel_optix_osl_services.ptx kernel_optix_shader_raytrace.ptx kernel_sm_30.cubin kernel_sm_35.cubin kernel_sm_37.cubin kernel_sm_50.cubin kernel_sm_52.cubin kernel_sm_60.cubin kernel_sm_61.cubin kernel_sm_70.cubin kernel_sm_75.cubin kernel_sm_86.cubin ``` ... and the missing files are the entire series of kernel_gfx*.fatbin Can I work around the issue by copying those over into my 3.6 folder until a new build is up with the missing files? Or are these very version specific?
Author

Follow up: I experimented with copying the missing files over, and can confirm that while this DOES remove the error, it doesn't really WORK lol

Cycles:
cycles example

vs

Eevee Next:
eevee next example

Scene in this case is a ball on a shadow-catcher plane, with 3 area lights, one point light, and very dim world light.

Follow up: I experimented with copying the missing files over, and can confirm that while this DOES remove the error, it doesn't really WORK lol Cycles: ![cycles example](/attachments/66da35ca-2350-4215-a21a-b513869ac426) vs Eevee Next: ![eevee next example](/attachments/c4143c33-4ba0-4cae-a5ae-0db9c8046f37) Scene in this case is a ball on a shadow-catcher plane, with 3 area lights, one point light, and very dim world light.
500 KiB
455 KiB
Member

I thought HIP kernels weren't being compiled for Blender 3.6 due to bugs, and the AMD team is looking into fixing them.

#104786

I thought HIP kernels weren't being compiled for Blender 3.6 due to bugs, and the AMD team is looking into fixing them. #104786

This is indeed intentionally disabled.

This is indeed intentionally disabled.
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2023-04-19 16:27:25 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#106225
No description provided.