Addons contained in "addons-contrib" folder are not visible anymore. #106310

Closed
opened 2023-03-30 15:26:06 +02:00 by Daniele Viagi · 3 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.18

Blender Version
Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: 1be25cfff18b
Worked: (newest version of Blender that worked as expected)

Short description of error
[Is not more possible to see or activate addons trough "Blender Preferences" window - Add-ons, that are contained in the addons-contrib folder.]

Exact steps for others to reproduce the error
[- put an addon in addon-contrib folder

  • open EDIT ===> PREFERENCES ===> Add-ons
  • try to find it ]
    [Based on the default startup or an attached .blend file (as simple as possible)]
**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.18 **Blender Version** Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: `1be25cfff18b` Worked: (newest version of Blender that worked as expected) **Short description of error** [Is not more possible to see or activate addons trough "Blender Preferences" window - Add-ons, that are contained in the addons-contrib folder.] **Exact steps for others to reproduce the error** [- put an addon in addon-contrib folder - open EDIT ===> PREFERENCES ===> Add-ons - try to find it ] [Based on the default startup or an attached .blend file (as simple as possible)]
Daniele Viagi added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-03-30 15:26:07 +02:00

Seems to be same issue as with #106306, I will check with 3.5 release though, because my 3.5 beta has no addons in _contrib folder.

Seems to be same issue as with #106306, I will check with 3.5 release though, because my 3.5 beta has no addons in `_contrib` folder.
Member

contrib does not ship with official releases only test builds

https://wiki.blender.org/wiki/Process/Addons#Repositories

contrib does not ship with official releases only test builds https://wiki.blender.org/wiki/Process/Addons#Repositories

I was able to reproduce with 3.5 release. I will close this as duplicate of #106306. Feel free to subscribe there to receive updates

I was able to reproduce with 3.5 release. I will close this as duplicate of #106306. Feel free to subscribe there to receive updates
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-03-30 21:36:57 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#106310
No description provided.