3.5 Mac Intel Vega 56: frequent freezes #106360

Closed
opened 2023-03-31 08:18:22 +02:00 by Sander-Spolspoel · 10 comments

System Information
Operating system: MacOS 12.6.3
Graphics card:Radeon Pro Vega 56 8 GB

Blender Version
Broken: 3.5.0 2023-03-29
Worked: 3.4.1

Short description of error
Metal Viewport is ON, Autosave is ON at 2 minutes, compress file is OFF.

Computer hangs for long periods of time while working: 30-60 seconds. System is completely unresponsive: iStat Menu's in menubar stop updating too. When system become responsive again, fans start to spin up rapidly and computer turns out to be very hot.

Exact steps for others to reproduce the error
Just use 3.5 on Intel Mac for a while, happens on many types of projects. This behaviour was confirmed on BlenderArtists.org by others.

**System Information** Operating system: MacOS 12.6.3 Graphics card:Radeon Pro Vega 56 8 GB **Blender Version** Broken: 3.5.0 2023-03-29 Worked: 3.4.1 **Short description of error** Metal Viewport is ON, Autosave is ON at 2 minutes, compress file is OFF. Computer hangs for long periods of time while working: 30-60 seconds. System is completely unresponsive: iStat Menu's in menubar stop updating too. When system become responsive again, fans start to spin up rapidly and computer turns out to be very hot. **Exact steps for others to reproduce the error** Just use 3.5 on Intel Mac for a while, happens on many types of projects. This behaviour was confirmed on BlenderArtists.org by others.
Sander-Spolspoel added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-03-31 08:18:23 +02:00
Member

Hi, thanks for the report. Since the freeze is random can you check whether it happens with --factory-startup argument?
Can you replicate it with OpenGL backend?
Which shading mode was active before the freeze?
Also share a project file in which the freeze is happening.

Hi, thanks for the report. Since the freeze is random can you check whether it happens with [--factory-startup](https://docs.blender.org/manual/en/latest/advanced/command_line/arguments.html#:~:text=default%20for%20none.-,%2D%2Dfactory%2Dstartup,-Skip%20reading%20the) argument? Can you replicate it with OpenGL backend? Which shading mode was active before the freeze? Also share a project file in which the freeze is happening.
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-04-05 12:36:07 +02:00

Will have a look into this, thanks for the report.

Will have a look into this, thanks for the report.

I'm on working an M1 Macbook today and can already confirm that none of the problems I had are present here, I'll update this report when back on the Intel/Vega56 machine, adding as much info as I can about my setup.

I'm on working an M1 Macbook today and can already confirm that none of the problems I had are present here, I'll update this report when back on the Intel/Vega56 machine, adding as much info as I can about my setup.

I tested again on intel iMac Pro Vega 56 64Gb ram no other apps running. Scene is a shopping cart, 80 objects floating in the air above it, a rigid body sim make the objects fall into the cart. Scene is under NDA, can't share.

Metal viewport, Eevee renderer, 2 viewport samples (no viewport denoising), all materials are shader to rgb with colorRamp.

I can view, model meshes, tweak params, play the rigid body sim, change materials and
all is fine until I go to Rendered Viewport shading, which froze the iMac Pro completely. Mouse gone, device doesn't respons, even thermal management was gone (hot but fans don't respond). After about a minute, I was logged out of the Mac, which suddenly spun the fans up rapidly to cool the very hot iMac.

I tested again on intel iMac Pro Vega 56 64Gb ram no other apps running. Scene is a shopping cart, 80 objects floating in the air above it, a rigid body sim make the objects fall into the cart. Scene is under NDA, can't share. Metal viewport, Eevee renderer, 2 viewport samples (no viewport denoising), all materials are shader to rgb with colorRamp. I can view, model meshes, tweak params, play the rigid body sim, change materials and **all is fine until I go to Rendered Viewport shading**, which froze the iMac Pro completely. Mouse gone, device doesn't respons, even thermal management was gone (hot but fans don't respond). After about a minute, I was logged out of the Mac, which suddenly spun the fans up rapidly to cool the very hot iMac.

I ran the scene again launching Blender 3.5 from Terminal with factory startup, which crashed my GPU upon going to rendered viewport. Random triangles were drawn all over my 2 displays, even after force-quitting the Blender app.

I ran the scene again launching Blender 3.5 from Terminal with **factory startup, which crashed my GPU** upon going to rendered viewport. Random triangles were drawn all over my 2 displays, even after force-quitting the Blender app.

Metal Viewport in 3.5 is clearly not ready for production yet.
I have the same problems on my iMac Pro Vega64.
I can't pin it down to a certain shader, but it happens on many different files.
The moment I try to switch to rendered Viewport shading in Eevee the whole system gets stuck, even the clock is standing still. Then after some time I'm logged out and the fans whirl up.
I could not observe problems like this with openGL viewport.

Metal Viewport in 3.5 is clearly not ready for production yet. I have the same problems on my iMac Pro Vega64. I can't pin it down to a certain shader, but it happens on many different files. The moment I try to switch to rendered Viewport shading in Eevee the whole system gets stuck, even the clock is standing still. Then after some time I'm logged out and the fans whirl up. I could not observe problems like this with openGL viewport.

I'm just adding that 3.5.1 (MacOS Intel release version from 2023-04-25) does not fix these issues. Simple scenes with a reflective ball and HDRI sky work in Eevee rendered viewport, but more complex projects still freeze the whole Mac and log me out of the system.

I'm just adding that 3.5.1 (MacOS Intel release version from 2023-04-25) does not fix these issues. Simple scenes with a reflective ball and HDRI sky work in Eevee rendered viewport, but more complex projects still freeze the whole Mac and log me out of the system.
Pratik Borhade added
Status
Needs Triage
Platform
macOS
and removed
Status
Needs Information from User
labels 2023-06-01 07:33:05 +02:00
Member

Might be fixed already by #109358
Could you verify in 3.6LTS?: https://builder.blender.org/download/daily/

Might be fixed already by #109358 Could you verify in 3.6LTS?: https://builder.blender.org/download/daily/
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-07-06 10:25:45 +02:00

installed 3.6 on Intel (Vega 56) and opened a few projects, metal viewport.No problems so far.

installed 3.6 on Intel (Vega 56) and opened a few projects, metal viewport.No problems so far.
Member

Thanks. Will close then. Feel free to reopen or submit a new report when problem reappears.

Thanks. Will close then. Feel free to reopen or submit a new report when problem reappears.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-07-10 04:16:38 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#106360
No description provided.