Strange shading when motion blur is on (fixed in 3.6, request for backport) #106394

Closed
opened 2023-03-31 17:45:35 +02:00 by Vitaliy · 15 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.41

Blender Version
Broken: version: 3.4.1, branch: blender-v3.4-release, commit date: 2022-12-19 17:00, hash: rB55485cb379f7

This was "fixed" by e7a3a2c261
This is also "wrong" in 3.3 LTS.

Short description of error
Strange shading when motion blur is on.

Exact steps for others to reproduce the error
Open the attached .blend file, turn motion blur on and off, see differences in renders.

When motion blur is off, image in viewport and in render looks normal:
image

When motion blur is on AND there is at least one animated property on any object, the scene looks like this:
image

I figured that only deleting all animations fixes the issue, disabling them does nothing.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.41 **Blender Version** Broken: version: 3.4.1, branch: blender-v3.4-release, commit date: 2022-12-19 17:00, hash: `rB55485cb379f7` This was "fixed" by e7a3a2c2618767b5fac464957af5030fdf47e52f This is also "wrong" in 3.3 LTS. **Short description of error** Strange shading when motion blur is on. **Exact steps for others to reproduce the error** Open the attached .blend file, turn motion blur on and off, see differences in renders. When motion blur is off, image in viewport and in render looks normal: ![image](/attachments/f80a3f7e-b7c8-49f5-9158-c5d17a4b0b44) When motion blur is on AND there is at least one animated property on any object, the scene looks like this: ![image](/attachments/dfc816ce-9ec7-4687-a854-695537bfd4e8) I figured that only deleting all animations fixes the issue, disabling them does nothing.
Vitaliy added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-03-31 17:45:36 +02:00
Member

Hi, thanks for the report. I can confirm this in 3.5 but not in current master.
This is fixed between 896ba33336 - 3eff28a158
@lichtwerk , can you check which commit fixed it? I guess 70f3382c45 ?

Hi, thanks for the report. I can confirm this in 3.5 but not in current master. This is fixed between 896ba3333666 - 3eff28a158ca @lichtwerk , can you check which commit fixed it? I guess 70f3382c45cb8e8c79505b60eed7f9691dd645bf ?
Pratik Borhade added
Module
Render & Cycles
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-04-05 14:16:23 +02:00
Pratik Borhade added this to the 3.5 milestone 2023-04-05 14:16:30 +02:00
Member

This was "fixed" by e7a3a2c261
This is also "wrong" in 3.3 LTS.

Since this changed behavior (possibly not only in a 'fixing' manner), would like to ask the module first if this should be backported (both for 3.3 LTS as well as 3.5.1 corrective release).

CC @weizhen
CC @brecht

This was "fixed" by e7a3a2c2618767b5fac464957af5030fdf47e52f This is also "wrong" in 3.3 LTS. Since this changed behavior (possibly not only in a 'fixing' manner), would like to ask the module first if this should be backported (both for 3.3 LTS as well as 3.5.1 corrective release). CC @weizhen CC @brecht
Philipp Oeser changed title from Strange shading when motion blur is on. to Strange shading when motion blur is on (fixed in 3.6, request for backport) 2023-04-05 15:34:15 +02:00
Member

Might be related to #101726 since starting blender with -t 1 also fixes the issue? Also it's weird that the geometry normals aren't normalized.

Might be related to https://projects.blender.org/blender/blender/issues/101726 since starting blender with `-t 1` also fixes the issue? Also it's weird that the geometry normals aren't normalized.
Member

@weizhen : not sure I understand correctly. The issue is already fixed in 3.6. (by normalizing normals from your e7a3a2c261). Only question was if the fix should be backported.

@weizhen : not sure I understand correctly. The issue **is already fixed** in 3.6. (by normalizing normals from your e7a3a2c261). Only question was if the fix should be backported.
Member

@lichtwerk I mean, my fix was intended for custom normals which might be unnormalized, but the attached scene does not have custom normals, it is using the geometry normal, which in theory should already be normalized at that stage. I can look into why motion triangles could have unnormalized normals, I think it would be better if we backport that. Not sure if we should backport e7a3a2c261

@lichtwerk I mean, my fix was intended for custom normals which might be unnormalized, but the attached scene does not have custom normals, it is using the geometry normal, which in theory should already be normalized at that stage. I can look into why motion triangles could have unnormalized normals, I think it would be better if we backport that. Not sure if we should backport e7a3a2c261
Member

@lichtwerk I mean, my fix was intended for custom normals which might be unnormalized, but the attached scene does not have custom normals, it is using the geometry normal, which in theory should already be normalized at that stage. I can look into why motion triangles could have unnormalized normals, I think it would be better if we backport that. Not sure if we should backport e7a3a2c261

Ah, missed that, thx getting back.
It seems turning ON High Quality Normals in the solidify modifier also fixes this in 3.5, this might give us another hint.

image

> @lichtwerk I mean, my fix was intended for custom normals which might be unnormalized, but the attached scene does not have custom normals, it is using the geometry normal, which in theory should already be normalized at that stage. I can look into why motion triangles could have unnormalized normals, I think it would be better if we backport that. Not sure if we should backport e7a3a2c261 Ah, missed that, thx getting back. It seems turning ON `High Quality Normals` in the solidify modifier also fixes this in 3.5, this might give us another hint. ![image](/attachments/37cef30b-5cb6-4213-a986-340ccd09c3a8)
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-04-06 13:53:14 +02:00
Member

@lichtwerk could you backport 792da15d53 ?

@lichtwerk could you backport 792da15d53 ?
Member

@lichtwerk could you backport 792da15d53 ?

Done. Added in both 3.3, 3.5 backporting list.

> @lichtwerk could you backport 792da15d53 ? Done. Added in both [3.3](https://projects.blender.org/blender/blender/issues/100749), [3.5](https://projects.blender.org/blender/blender/issues/106258) backporting list.

This is not fixed in 3.6

This is not fixed in 3.6
Member

This is not fixed in 3.6

Just tested with version: 3.6.0 Alpha, branch: main, commit date: 2023-04-10 19:12, hash: 8dae0587686d and this seems fine on my side.

@vfxwolf : could you recheck in a fresh 3.6 build from https://builder.blender.org/download/daily/?

> This is not fixed in 3.6 Just tested with version: 3.6.0 Alpha, branch: main, commit date: 2023-04-10 19:12, hash: `8dae0587686d` and this seems fine on my side. @vfxwolf : could you recheck in a fresh 3.6 build from https://builder.blender.org/download/daily/?

Downloaded the latest 3.6 today.. problem is still there.. see attached

Downloaded the latest 3.6 today.. problem is still there.. see attached
Member

Can you still repro this with maybebug.blend as well? (I cant)

Can you still repro this with `maybebug.blend` as well? (I cant)

Can you still repro this with maybebug.blend as well? (I cant)

Had a look at the scene, and it seems to render without artifacts, BUT... there's a major difference, you're not using any deformation that I can see.

In my case, the bus has been diced and is being deformed by a mesh deform modifier, which itself is being deformed by an armature. As you can see in the clip attached. the glitching is pronounced and frequent.

So while I'm sure SOMETHING was fixed in 3.6.. it wasnt the long time issue of bad normals when a deforming object has autosmoothing ON and is rendered with motion blur.

> Can you still repro this with `maybebug.blend` as well? (I cant) Had a look at the scene, and it seems to render without artifacts, BUT... there's a major difference, you're not using any deformation that I can see. In my case, the bus has been diced and is being deformed by a mesh deform modifier, which itself is being deformed by an armature. As you can see in the clip attached. the glitching is pronounced and frequent. So while I'm sure SOMETHING was fixed in 3.6.. it wasnt the long time issue of bad normals when a deforming object has autosmoothing ON and is rendered with motion blur.
Member

Can you still repro this with maybebug.blend as well? (I cant)

Had a look at the scene, and it seems to render without artifacts, BUT... there's a major difference, you're not using any deformation that I can see.

In my case, the bus has been diced and is being deformed by a mesh deform modifier, which itself is being deformed by an armature. As you can see in the clip attached. the glitching is pronounced and frequent.

So while I'm sure SOMETHING was fixed in 3.6.. it wasnt the long time issue of bad normals when a deforming object has autosmoothing ON and is rendered with motion blur.

Since these issues seem to be different, has "your" issue been reported before?
If not, could you open a separate report for this?

> > Can you still repro this with `maybebug.blend` as well? (I cant) > > Had a look at the scene, and it seems to render without artifacts, BUT... there's a major difference, you're not using any deformation that I can see. > > In my case, the bus has been diced and is being deformed by a mesh deform modifier, which itself is being deformed by an armature. As you can see in the clip attached. the glitching is pronounced and frequent. > > So while I'm sure SOMETHING was fixed in 3.6.. it wasnt the long time issue of bad normals when a deforming object has autosmoothing ON and is rendered with motion blur. Since these issues seem to be different, has "your" issue been reported before? If not, could you open a separate report for this?

Can you still repro this with maybebug.blend as well? (I cant)

Had a look at the scene, and it seems to render without artifacts, BUT... there's a major difference, you're not using any deformation that I can see.

In my case, the bus has been diced and is being deformed by a mesh deform modifier, which itself is being deformed by an armature. As you can see in the clip attached. the glitching is pronounced and frequent.

So while I'm sure SOMETHING was fixed in 3.6.. it wasnt the long time issue of bad normals when a deforming object has autosmoothing ON and is rendered with motion blur.

Since these issues seem to be different, has "your" issue been reported before?
If not, could you open a separate report for this?

Indeed I have

blender/blender#106618

> > > Can you still repro this with `maybebug.blend` as well? (I cant) > > > > Had a look at the scene, and it seems to render without artifacts, BUT... there's a major difference, you're not using any deformation that I can see. > > > > In my case, the bus has been diced and is being deformed by a mesh deform modifier, which itself is being deformed by an armature. As you can see in the clip attached. the glitching is pronounced and frequent. > > > > So while I'm sure SOMETHING was fixed in 3.6.. it wasnt the long time issue of bad normals when a deforming object has autosmoothing ON and is rendered with motion blur. > > Since these issues seem to be different, has "your" issue been reported before? > If not, could you open a separate report for this? Indeed I have blender/blender#106618
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#106394
No description provided.