Node frame jitters when transformed #106565

Closed
opened 2023-04-04 20:26:23 +02:00 by Hadrien · 5 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 970/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.24

Blender Version
Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: 1be25cfff18b
Worked: 3.4
Short description of error
Node frame jitters when transformed

Exact steps for others to reproduce the error

  1. Transform frame
**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 970/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.24 **Blender Version** Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: `1be25cfff18b` Worked: 3.4 **Short description of error** Node frame jitters when transformed **Exact steps for others to reproduce the error** 1. Transform frame
Hadrien added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-04-04 20:26:24 +02:00
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-04-04 20:32:55 +02:00
Iliya Katushenock added
Status
Duplicate
and removed
Status
Archived
labels 2023-04-04 20:33:01 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Duplicate
labels 2023-04-04 20:34:43 +02:00

@lichtwerk Look like now rounding position cause jitters

@lichtwerk Look like now rounding position cause jitters
Member

@mod_moder : the rounding was a fix for particular jitter (when the mouse doesnt move), so now this is a tradeoff between slight jitter while moving (due to the rounding) vs. the more prominent jitter while the mouse is still.

The rounding commit is not in 3.5 though, it is already on the list for backporting to the upcoming 3.5.1 corrective release, see #106258.

So this is different in 3.6, @Hadrien , can you check a fresh 3.6 build from https://builder.blender.org/download/daily/ and report back if you consider this fixed (since this report is about the jitter in 3.5.0)?

@mod_moder : the rounding was a **fix** for particular jitter (when the mouse doesnt move), so now this is a tradeoff between slight jitter while moving (due to the rounding) vs. the more prominent jitter while the mouse is still. The rounding commit is not in 3.5 though, it is already on the list for backporting to the upcoming 3.5.1 corrective release, see #106258. So this is different in 3.6, @Hadrien , can you check a fresh 3.6 build from https://builder.blender.org/download/daily/ and report back if you consider this fixed (since this report is about the jitter in 3.5.0)?
Philipp Oeser added
Status
Needs Information from User
and removed
Status
Confirmed
labels 2023-04-05 08:56:58 +02:00
Author

@lichtwerk it doesn't happen in today's 3.6 build. However it seems the nodes can't align to the grid anymore. Should I open a new ticket ?

@lichtwerk it doesn't happen in today's 3.6 build. However it seems the nodes can't align to the grid anymore. Should I open a new ticket ?
Member

@lichtwerk it doesn't happen in today's 3.6 build.

OKi, good to hear the original issue is regarded fixed, will close this one then.

However it seems the nodes can't align to the grid anymore. Should I open a new ticket ?

Yes, please, feel free to ping me there to have a look.

> @lichtwerk it doesn't happen in today's 3.6 build. OKi, good to hear the original issue is regarded fixed, will close this one then. > However it seems the nodes can't align to the grid anymore. Should I open a new ticket ? Yes, please, feel free to ping me there to have a look.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-04-05 12:33:39 +02:00
Philipp Oeser added
Status
Resolved
and removed
Status
Archived
labels 2023-04-05 12:34:06 +02:00
Author

@lichtwerk #106594
I incorrectly assumed it was introduced in 3.5 but it seems to behave the same in 3.4 from my testing. I didn't manage to ping you from within the ticket description which is why I'm doing it here.

@lichtwerk https://projects.blender.org/blender/blender/issues/106594 I incorrectly assumed it was introduced in 3.5 but it seems to behave the same in 3.4 from my testing. I didn't manage to ping you from within the ticket description which is why I'm doing it here.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#106565
No description provided.