Physics / Simulation Nodes Baking User Interface #107181

Closed
opened 2023-04-20 16:50:49 +02:00 by Dalai Felinto · 2 comments

This proposal unifies the Physics panels to be closer to the modifiers. There is no functional change besides the user interface.

Then it adds the Simulation panel as a panel which is always visible for the objects. It is not part of the Add Physics.

Screenshot from 2023-04-20 16-47-37.png

Open questions:

  • Should Delete / Bake All Dynamics also take into account Simulation Nodes?
This proposal unifies the Physics panels to be closer to the modifiers. There is no functional change besides the user interface. Then it adds the Simulation panel as a panel which is always visible for the objects. It is not part of the Add Physics. ![Screenshot from 2023-04-20 16-47-37.png](/attachments/625fa27d-3656-4e3a-aaa4-1177b9478af5) Open questions: * Should Delete / Bake All Dynamics also take into account Simulation Nodes?
Dalai Felinto added the
Type
Design
label 2023-04-20 16:50:49 +02:00
Dalai Felinto added this to the Nodes & Physics project 2023-04-20 16:50:50 +02:00
Member
  • Physics are a subset of simulation rather than the other way around, putting "Simulation" in the "Physics" tab doesn't seem right
  • I imagined the future of the special "Physics" UI in Blender to be something more like a subcatalog of "Simulation" in the asset browser (and various "add behavior") dialogs. So it's not clear to me that the physics tab will even exist in the future, similar to the particle tab.
  • Frame start, end, sub-steps probably act more like operator properties for the "Bake" operator. I wonder if it's really worth always showing them in the UI. It's confusing because they look like "state" similar to the scene's frame range.
  • "frames in disk" -> "frames on disk" (or maybe even "10 baked frames stored" or something?)
  • Where does the checkbox to enable caching go in this design? We had talked about putting it in the same panel.
- Physics are a subset of simulation rather than the other way around, putting "Simulation" in the "Physics" tab doesn't seem right - I imagined the future of the special "Physics" UI in Blender to be something more like a subcatalog of "Simulation" in the asset browser (and various "add behavior") dialogs. So it's not clear to me that the physics tab will even exist in the future, similar to the particle tab. - Frame start, end, sub-steps probably act more like operator properties for the "Bake" operator. I wonder if it's really worth always showing them in the UI. It's confusing because they look like "state" similar to the scene's frame range. - "frames in disk" -> "frames on disk" (or maybe even "10 baked frames stored" or something?) - Where does the checkbox to enable caching go in this design? We had talked about putting it in the same panel.
Author
Owner

After more feedback, there is a final design on #107290. That is also the task that will keep track of the implementation.

For the records the design is:

Screenshot from 2023-04-24 12-19-03.png

After more feedback, there is a final design on #107290. That is also the task that will keep track of the implementation. For the records the design is: ![Screenshot from 2023-04-24 12-19-03.png](/attachments/122f529d-2f0d-4ed4-b8e2-beb9c822eba4)
Blender Bot added the
Status
Archived
label 2023-10-23 12:41:07 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#107181
No description provided.