User Interface: Re-design of Physics panel to unclutter interface and resembles Modifiers more #107326

Open
opened 2023-04-25 11:02:34 +02:00 by Dalai Felinto · 5 comments

The moment the Physics tab (soon to be called Simulation and Physics) has hardcoded operator buttons on top. To unclutter the UI it would be nice to do something closer to what we have in Modifier.

Current interface:
Screenshot from 2023-04-25 10-52-48.png

Proposal:
Screenshot from 2023-04-25 11-01-09.png

There should be no functionality changes. The "Add Physics" menu should gray out any Physics system that was already added since there can be only one per object.

Note: This mockup also show the changes we plan for Geometry Nodes. They are to be tackled separatedly (#107290).

The moment the Physics tab (soon to be called Simulation and Physics) has hardcoded operator buttons on top. To unclutter the UI it would be nice to do something closer to what we have in Modifier. Current interface: ![Screenshot from 2023-04-25 10-52-48.png](/attachments/d110b345-321a-4a40-a7ca-6279a7fd038d) Proposal: ![Screenshot from 2023-04-25 11-01-09.png](/attachments/1018ae1b-3128-4d46-93ce-ecea1311b67e) There should be no functionality changes. The "Add Physics" menu should gray out any Physics system that was already added since there can be only one per object. Note: This mockup also show the changes we plan for Geometry Nodes. They are to be tackled separatedly (#107290).
Dalai Felinto added the
Type
To Do
label 2023-04-25 11:02:34 +02:00
Dalai Felinto added this to the User Interface project 2023-04-25 11:02:35 +02:00

Is it alright if I add some feedback here? I've spent many many hours in the physics panel.

As a quick fix, this looks way better.

In the long run, IMO a UI list would be really helpful here. Some of the physics types have quite a few settings in panels and sub-panels, and it's already a lot of scrolling. If a few physics types are stacked on top of each other, it gets pretty crazy. For example, try working with fluid and dynamic paint for a while. With a UI list, it would be easy to switch between editing each system without scrolling so much, and the settings would have a little more breathing room as they would all be one less panel deep.

Otherwise, what's the use of sending people from the modifier stack to the physics panel, just to get the same UI? Why not just put all the settings in the modifier stack in that case?

My pie-in-the-sky dream would be to combine the particle tab and the physics tab into one UI list (working with smoke or dynamic paint particles requires constant switching between the two tabs), but that seems like it's way out of scope for this one.

Is it alright if I add some feedback here? I've spent many many hours in the physics panel. As a quick fix, this looks way better. In the long run, IMO a UI list would be really helpful here. Some of the physics types have quite a few settings in panels and sub-panels, and it's already a lot of scrolling. If a few physics types are stacked on top of each other, it gets pretty crazy. For example, try working with fluid and dynamic paint for a while. With a UI list, it would be easy to switch between editing each system without scrolling so much, and the settings would have a little more breathing room as they would all be one less panel deep. Otherwise, what's the use of sending people from the modifier stack to the physics panel, just to get the same UI? Why not just put all the settings in the modifier stack in that case? My pie-in-the-sky dream would be to combine the particle tab and the physics tab into one UI list (working with smoke or dynamic paint particles requires constant switching between the two tabs), but that seems like it's way out of scope for this one.

Hello, what exactly are you expecting in terms of the user interface and how do you see the design of the UI.
Moreover which files are to be modified because I am interested in taking care of them.

Hello, what exactly are you expecting in terms of the user interface and how do you see the design of the UI. Moreover which files are to be modified because I am interested in taking care of them.
Author
Owner

@Gangneron better to go to https://blender.chat/channel/user-interface-module to check with the UI developers where is this in the agenda, if someone would have time to iterate over it/review/...

@Gangneron better to go to https://blender.chat/channel/user-interface-module to check with the UI developers where is this in the agenda, if someone would have time to iterate over it/review/...

Thanks but it's already done

Thanks but it's already done
Member

Related task: Modifiers UI Overhaul #111538

Since the task proposes to integrate modifier-like physics into the Modifiers list.

Related task: [Modifiers UI Overhaul #111538](https://projects.blender.org/blender/blender/issues/111538) Since the task proposes to integrate modifier-like physics into the Modifiers list.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#107326
No description provided.