Regression: Vertex Group operators not defaulting to Active Vertex Group #108527

Closed
opened 2023-06-02 04:19:02 +02:00 by Daniel Salazar · 1 comment
Member

System Information
Operating system: Linux-5.19.0-43-generic-x86_64-with-glibc2.36 64 Bits, X11 UI
Graphics card: NVIDIA GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 530.41.03

Blender Version
Broken: version: 4.0.0 Alpha, 3.3 LTS
Worked: Blender 3.0

Short description of error
Most Vertex Group operators should default to Active Vertex Group.
Now most of them default to Deform Pose Bones.

This is an over-reach of the following fix that was meant only for the Normalize All operator:
https://archive.blender.org/developer/D14961

Exact steps for others to reproduce the error

  • Open the provided file
  • Trigger one of the following operators from the Weights menu in viewport header:
    • Invert
    • Clean
    • Quantize
    • Levels
    • Smooth
    • Limit Total

Notice how the operator defaults to Deform Pose Bones.
This is unintended and dangerous behavior and also doesn't make sense when your active vertex group has nothing to do with deformation. IE: Select a mask vextex group, hit smooth, nothing apparent happens. But behind the curtains, all your deformation groups are now smoothed!

**System Information** Operating system: Linux-5.19.0-43-generic-x86_64-with-glibc2.36 64 Bits, X11 UI Graphics card: NVIDIA GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 530.41.03 **Blender Version** Broken: version: 4.0.0 Alpha, 3.3 LTS Worked: Blender 3.0 **Short description of error** Most Vertex Group operators should default to Active Vertex Group. Now most of them default to Deform Pose Bones. This is an over-reach of the following fix that was meant **only** for the **Normalize All** operator: https://archive.blender.org/developer/D14961 **Exact steps for others to reproduce the error** - Open the provided file - Trigger one of the following operators from the _Weights_ menu in viewport header: - Invert - Clean - Quantize - Levels - Smooth - Limit Total Notice how the operator defaults to _Deform Pose Bones_. This is unintended and dangerous behavior and also doesn't make sense when your active vertex group has nothing to do with deformation. IE: Select a mask vextex group, hit smooth, nothing apparent happens. But behind the curtains, all your deformation groups are now smoothed!
Daniel Salazar added the
Priority
Normal
Status
Needs Triage
Type
Report
labels 2023-06-02 04:19:03 +02:00
Daniel Salazar changed title from Vertex Group operators now default to Deform Pose Bones instead of Active Vertex Group to Vertex Group operators not defaulting to Active Vertex Group 2023-06-02 04:23:04 +02:00
Daniel Salazar changed title from Vertex Group operators not defaulting to Active Vertex Group to Regression: Vertex Group operators not defaulting to Active Vertex Group 2023-06-02 04:23:13 +02:00
Member

Can confirm. Although manually selecting "Active Group" works, it does seem to be counter-intuitive as you would mostly just want to operate on the one group you can see rather than everything.

Can confirm. Although manually selecting "Active Group" works, it does seem to be counter-intuitive as you would mostly just want to operate on the one group you can see rather than everything.
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-06-15 15:36:11 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#108527
No description provided.