Cycles: Enabling/disabling OSL changes the look of pre-existing shader nodes #108992

Open
opened 2023-06-14 23:29:42 +02:00 by jack conradsen · 3 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.49

Blender Version
Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: 1be25cfff18b
Worked: (newest version of Blender that worked as expected)

Short description of error
I can't find much info on osl within blender. As i understand it, the point is to be able to write your own shaders with scripts, it shouldn't change the functionality of preexisting shader nodes.

Optix without OSL and CPU (with & without OSL) device renders darker droplets.

Exact steps for others to reproduce the error
In rendered view. Enable/disable OSL and see the water droplets look drasticly different (OSL looks more correct, but that should just be the default behavior then)

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.49 **Blender Version** Broken: version: 3.5.0, branch: blender-v3.5-release, commit date: 2023-03-29 02:56, hash: `1be25cfff18b` Worked: (newest version of Blender that worked as expected) **Short description of error** I can't find much info on osl within blender. As i understand it, the point is to be able to write your own shaders with scripts, it shouldn't change the functionality of preexisting shader nodes. Optix without OSL and CPU (with & without OSL) device renders darker droplets. **Exact steps for others to reproduce the error** In rendered view. Enable/disable OSL and see the water droplets look drasticly different (OSL looks more correct, but that should just be the default behavior then)
jack conradsen added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-06-14 23:29:43 +02:00
jack conradsen changed title from Enabling/disabling Open shading language changes the look of default shader nodes to Enabling/disabling Open shading language changes the look of preexsting shader nodes 2023-06-14 23:29:59 +02:00
YimingWu added the
Interest
Render & Cycles
label 2023-06-15 04:06:31 +02:00
Member

Can't replicate the issue on CPU (my device doesn't have a GPU right now), the problem is probably limited to GPU, on CPU it looks like whether enabling OSL or not, it renders as the "darker droplets" result. Changing light path settings doesn't seem to improve the situation either.

图片

Can't replicate the issue on CPU (my device doesn't have a GPU right now), the problem is probably limited to GPU, on CPU it looks like whether enabling OSL or not, it renders as the "darker droplets" result. Changing light path settings doesn't seem to improve the situation either. ![图片](/attachments/71b1ac4d-e1de-43ff-bb3e-17995effa6df)
Member

I can confirm the difference with Optix OSL
Guess the dark droplets are due to intersection with pool? (#96475)

I can confirm the difference with Optix OSL Guess the dark droplets are due to intersection with pool? (#96475)
Member

On previous versions, CPU (with & without OSL) and GPU rendering results are bit different
image

On previous versions, CPU (with & without OSL) and GPU rendering results are bit different ![image](/attachments/f2d7ac19-b450-4bac-80f8-4f091092c600)
1.3 MiB
Pratik Borhade changed title from Enabling/disabling Open shading language changes the look of preexsting shader nodes to Cycles: Enabling/disabling OSL changes the look of pre-existing shader nodes 2023-06-15 06:03:10 +02:00
Pratik Borhade added
Module
Render & Cycles
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-06-15 06:05:06 +02:00
Brecht Van Lommel added
Type
Bug
and removed
Type
Report
labels 2024-06-14 16:01:40 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#108992
No description provided.