Cycles HIP RT principled hair BSDF issue #109421

Closed
opened 2023-06-27 21:34:59 +02:00 by nathan · 5 comments

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: AMD Radeon RX 6800 XT ATI Technologies Inc. 4.5.0 Core Profile Context 23.5.2.230523

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
When rendering any geometry with the Principled Hair BSDF shader, the geometry becomes transparent and/or white, in the viewport and in a render.

I've attached two images and a simple fur setup I used to make this example.

  • One image is with standard HIP rendering, which produces expected results, meaning the fur is orange-ish and the ball is about the same color with visible faces.

  • The other one is wrong, the UV Sphere is strangely transparent and the fur is white and transparent. It does make for an interesting result though.

Exact steps for others to reproduce the error
Create a simple hair setup and assign a principled hair shader to it and enable HIP RT and render the scene.
I've also attached the file I used to produce the comparison images

**System Information** Operating system: Windows-10-10.0.19041-SP0 64 Bits Graphics card: AMD Radeon RX 6800 XT ATI Technologies Inc. 4.5.0 Core Profile Context 23.5.2.230523 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** When rendering any geometry with the Principled Hair BSDF shader, the geometry becomes transparent and/or white, in the viewport and in a render. I've attached two images and a simple fur setup I used to make this example. - One image is with standard HIP rendering, which produces expected results, meaning the fur is orange-ish and the ball is about the same color with visible faces. - The other one is wrong, the UV Sphere is strangely transparent and the fur is white and transparent. It does make for an interesting result though. **Exact steps for others to reproduce the error** Create a simple hair setup and assign a principled hair shader to it and enable HIP RT and render the scene. I've also attached the file I used to produce the comparison images
nathan added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-06-27 21:34:59 +02:00
Iliya Katushenock added the
Interest
Render & Cycles
label 2023-06-27 21:37:45 +02:00
Member

Probably related to #109418

Probably related to #109418
Brecht Van Lommel changed title from Render Issues with HIP RT and the Principled Hair BSDF Shader to Cycles HIP RT principled hair BSDF issue 2023-07-04 14:05:59 +02:00
CC @BrianSavery @salipour.
Brian Savery (AMD) self-assigned this 2023-07-10 04:02:39 +02:00

I noted on the Glass ticket that this change https://projects.blender.org/blender/blender/commit/4e104d77c701 seemed to be where it started. We'll test if that is the same here with this one.

I noted on the Glass ticket that this change https://projects.blender.org/blender/blender/commit/4e104d77c701 seemed to be where it started. We'll test if that is the same here with this one.

This has the same root cause as #109418, see that issue for an explanation of the problem and solution.

This has the same root cause as #109418, see that issue for an explanation of the problem and solution.
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2023-07-13 23:16:39 +02:00
Brecht Van Lommel added
Status
Resolved
and removed
Status
Archived
labels 2023-07-13 23:16:45 +02:00

This should be fixed by #110073

My comment from the other issue:
TLDR: Kernels were not being updated when the code changed. #110073 fixes this. Use the nightly or 4.0 alpha build

Long version:
We did some testing and here's what we found:
3.6 release build from Blender.org - ARTIFACTS
3.6.1 build from blender.org - FINE
4.0 alpha build from blender.org - FINE
Local builds, 3.6 or 4.0 branch - FINE

It seemed like there was a bad kernel being built, either from a SDK mismatch or something else. @brecht figured out that the kernels were not being marked as "dirty" and rebuilt when the source for them changed. See #110073. So what happened here is @LukasStockner changed the kernel code but the HIPRT kernels were not rebuilt (not his fault at all), so they mismatched Blender.

At any rate thanks everyone for helping find this. You can use a nightly build of 3.6 or 4.0 alpha and should fix the issue.

This should be fixed by https://projects.blender.org/blender/blender/pulls/110073 My comment from the other issue: TLDR: Kernels were not being updated when the code changed. #110073 fixes this. Use the nightly or 4.0 alpha build Long version: We did some testing and here's what we found: 3.6 release build from Blender.org - ARTIFACTS 3.6.1 build from blender.org - FINE 4.0 alpha build from blender.org - FINE Local builds, 3.6 or 4.0 branch - FINE It seemed like there was a bad kernel being built, either from a SDK mismatch or something else. @brecht figured out that the kernels were not being marked as "dirty" and rebuilt when the source for them changed. See #110073. So what happened here is @LukasStockner changed the kernel code but the HIPRT kernels were not rebuilt (not his fault at all), so they mismatched Blender. At any rate thanks everyone for helping find this. You can use a nightly build of 3.6 or 4.0 alpha and should fix the issue.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109421
No description provided.