HIP related bugs #109431

Closed
opened 2023-06-28 04:47:19 +02:00 by YimingWu · 9 comments
Member

There are multiple bug reports following the release of 3.6 on the stability and the consistency of HIP, combine them here for easier access:

Open

  • #111685 5700xt 22.20.27.09.230330 hangs (not sure if this is real crash yet)

Closed

  • #100353 Cycles HIP rendered viewport crashes system/GPU on Linux with RDNA2 GPU
  • #109417 Crashes
  • #109418 #109421 Material appears to be white
  • #109477 #110841 crash with RT enable
  • #109521 HIP binary kemel for this graphics card compute capability (9.0) not found.
  • #109562 libamdhip64.so library location/install issue
  • #111546 Crash on 23.8.1 with Radeon RX 6800XT
  • #111569 Crash on 23.7.2.230718
  • #112177 "Instant crash on high polygon", User pref erroneously shows two identical AMD cards instead of one.
  • #110392 Crash on driver AMD Adrenaline 23.7.1 and 23.7.2 but fine on AMD Adrenaline 23.5.2.
  • #109553 "Out of memory" when HIP is on but fine when off.
  • #109415 Geometry appears to be tearing up
  • #110459 Crashes
  • #112163 HIP binary kernel not found
  • #109811 Linux crash with HSA_STATUS_ERROR_INVALID_ISA: The instruction set architecture is invalid.
  • #111019 HIP and HIPRT Support for GFX1037 (AMD Radeon 610M iGPU)
  • #110777 AMD Radeon Pro W6800 not detected
  • #112608 6950 XT (navi21, LLVM 16.0.6, DRM 3.54, 6.5.3-300.fc39.x86_64) crash without backtrace, Fedora Linux 39
There are multiple bug reports following the release of 3.6 on the stability and the consistency of HIP, combine them here for easier access: ## Open - #111685 5700xt `22.20.27.09.230330` hangs (not sure if this is real crash yet) ## Closed - ~~#100353 Cycles HIP rendered viewport crashes system/GPU on Linux with RDNA2 GPU~~ - ~~#109417 Crashes~~ - ~~#109418 #109421 Material appears to be white~~ - ~~#109477 #110841 crash with RT enable~~ - ~~#109521 HIP binary kemel for this graphics card compute capability (9.0) not found.~~ - ~~#109562 libamdhip64.so library location/install issue~~ - ~~#111546 Crash on `23.8.1` with `Radeon RX 6800XT`~~ - ~~#111569 Crash on `23.7.2.230718`~~ - ~~#112177 "Instant crash on high polygon", User pref erroneously shows two identical AMD cards instead of one.~~ - ~~#110392 Crash on driver `AMD Adrenaline 23.7.1` and `23.7.2` but fine on `AMD Adrenaline 23.5.2`.~~ - ~~#109553 "Out of memory" when HIP is on but fine when off.~~ - ~~#109415 Geometry appears to be tearing up~~ - ~~#110459 Crashes~~ - ~~#112163 HIP binary kernel not found~~ - ~~#109811 Linux crash with `HSA_STATUS_ERROR_INVALID_ISA: The instruction set architecture is invalid.`~~ - ~~#111019 HIP and HIPRT Support for GFX1037 (AMD Radeon 610M iGPU)~~ - ~~#110777 AMD Radeon Pro W6800 not detected~~ - ~~#112608 6950 XT (navi21, LLVM 16.0.6, DRM 3.54, 6.5.3-300.fc39.x86_64) crash without backtrace, Fedora Linux 39~~
YimingWu added this to the 3.6 LTS milestone 2023-06-28 04:47:19 +02:00
YimingWu added the
Status
Needs Info from Developers
Type
To Do
Module
Render & Cycles
labels 2023-06-28 04:47:20 +02:00
YimingWu added this to the Render & Cycles project 2023-06-28 04:47:22 +02:00
Member
cc @BrianSavery

Thanks. We're also looking at the linux viewport issue. The one thing I'll mention is that a few of the reports mention using 23.5 driver. For Windows with HIPRT users should stick to https://www.amd.com/en/support/kb/release-notes/rn-rad-win-22-40-51-06-blender-3-6-beta as mentioned in the release notes.

Thanks. We're also looking at the linux viewport issue. The one thing I'll mention is that a few of the reports mention using 23.5 driver. For Windows with HIPRT users should stick to https://www.amd.com/en/support/kb/release-notes/rn-rad-win-22-40-51-06-blender-3-6-beta as mentioned in the release notes.

Hello. I'm not sure if I should have created a new issue or found an existing one that appears to have the same problem I encountered: crash during Cycles rendering with AMD HIP. I use Linux Mint 20.2, Linux kernel 6.2.0-3, GPU Radeon RX 6600, Blender 3.6.3 Release Candidate

When running from terminal, an error message appears before crash "Memory access fault by GPU node-1 (Agent handle: 0x7feed4dc1000) on address 0x7fed00007000. Reason: Page not present or supervisor privilege.".

The problem occurred only with one .blend file. I tried a couple of others and rendering works without issues. The problem file is Blender 3.2 splash screen. After cleaning up the scene, I narrowed down the cause. The crash happen when there are two objects in the scene, one having Cast Shadow Caustics (located in Object Properties > Shading > Caustics) enabled and another having Receive Shadow Caustics enabled, and a light source with Shadow Caustics enabled (located in Object Data Properties > Light). The objects must be in the camera view.

There is one thing that I have not been able to figure out. When experimenting with the splash screen scene, there is no crash if only the object with Cast Shadow Caustics enabled (water) is visible in the camera, but crashes when object with Receive Shadow Caustics enabled (ship) is visible. But when I experimented with the default Blender scene, by duplicating the cube and setting those parameters, Blender crashed independently of which of the objects is visible in the camera, even if only the cube with Cast Shadow Caustics is visible, which does not cause a crash in the splash screen scene.

I uploaded both scenes. In order to reduce size I replaced the boat mesh in the cleaned up splash screen scene with a cube (I replaced it in the Edit mode to preserve other parameters).

Hello. I'm not sure if I should have created a new issue or found an existing one that appears to have the same problem I encountered: crash during Cycles rendering with AMD HIP. I use Linux Mint 20.2, Linux kernel 6.2.0-3, GPU Radeon RX 6600, Blender 3.6.3 Release Candidate When running from terminal, an error message appears before crash "Memory access fault by GPU node-1 (Agent handle: 0x7feed4dc1000) on address 0x7fed00007000. Reason: Page not present or supervisor privilege.". The problem occurred only with one .blend file. I tried a couple of others and rendering works without issues. The problem file is [Blender 3.2 splash screen](https://cloud.blender.org/p/gallery/629f23f908e12d4ff15241d3). After cleaning up the scene, I narrowed down the cause. The crash happen when there are two objects in the scene, one having Cast Shadow Caustics (located in Object Properties > Shading > Caustics) enabled and another having Receive Shadow Caustics enabled, and a light source with Shadow Caustics enabled (located in Object Data Properties > Light). The objects must be in the camera view. There is one thing that I have not been able to figure out. When experimenting with the splash screen scene, there is no crash if only the object with Cast Shadow Caustics enabled (water) is visible in the camera, but crashes when object with Receive Shadow Caustics enabled (ship) is visible. But when I experimented with the default Blender scene, by duplicating the cube and setting those parameters, Blender crashed independently of which of the objects is visible in the camera, even if only the cube with Cast Shadow Caustics is visible, which does not cause a crash in the splash screen scene. I uploaded both scenes. In order to reduce size I replaced the boat mesh in the cleaned up splash screen scene with a cube (I replaced it in the Edit mode to preserve other parameters).
Author
Member

there is no crash if only the object with Cast Shadow Caustics enabled (water) is visible in the camera, but crashes when object with Receive Shadow Caustics enabled (ship) is visible.

This is a useful piece of information. Also thanks for the test file!

@BrianSavery @Sayak-Biswas or maybe @brecht may want to take a look.

> there is no crash if only the object with Cast Shadow Caustics enabled (water) is visible in the camera, but crashes when object with Receive Shadow Caustics enabled (ship) is visible. This is a useful piece of information. Also thanks for the test file! @BrianSavery @Sayak-Biswas or maybe @brecht may want to take a look.

Please create a new issue, let's not use this one to go into specific bugs.

Please create a new issue, let's not use this one to go into specific bugs.

Please create a new issue, let's not use this one to go into specific bugs.

#112084

> Please create a new issue, let's not use this one to go into specific bugs. #112084

Should this be added to the list? #100353

Should this be added to the list? https://projects.blender.org/blender/blender/issues/100353

"#100353 Cycles HIP rendered viewport crashes system/GPU on Linux with RDNA2 GPU" Should be closed now as it is fixed.

"#100353 Cycles HIP rendered viewport crashes system/GPU on Linux with RDNA2 GPU" Should be closed now as it is fixed.

There is only one open issue listed here now, and there is a plan to use labels for this kind of thing. So I don't think this summary issue serves a purpose anymore now.

There is only one open issue listed here now, and there is a plan to use labels for this kind of thing. So I don't think this summary issue serves a purpose anymore now.
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2024-06-11 19:26:54 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
7 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109431
No description provided.