Issue with Cycles Rendering Mode - Unexpected Blender Closure #109668

Closed
opened 2023-07-03 21:55:01 +02:00 by Botond-Kontrecz · 19 comments

**System Information
Operating system: Windows 10
Graphics card: Radeon 6700 XT

**Blender Version: I tried with 3.5, and 3.6, both broken

Short description of error: When attempting to switch to the Cycles render mode in Blender, the application consistently and unexpectedly shuts down, regardless of the Blender version or GPU driver utilized.

**Exact steps for others to reproduce the error: Don't know, sorry
Based on the default startup or an attached .blend file (as simple as possible): It happens regardless the blend file, regardless the settings, I tried the default startup, didn't work. Don't really know what to change, tried some things, but the issue persists

**System Information Operating system: Windows 10 Graphics card: Radeon 6700 XT **Blender Version: I tried with 3.5, and 3.6, both broken Short description of error: When attempting to switch to the Cycles render mode in Blender, the application consistently and unexpectedly shuts down, regardless of the Blender version or GPU driver utilized. **Exact steps for others to reproduce the error: Don't know, sorry Based on the default startup or an attached .blend file (as simple as possible): It happens regardless the blend file, regardless the settings, I tried the default startup, didn't work. Don't really know what to change, tried some things, but the issue persists
Botond-Kontrecz added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-07-03 21:55:02 +02:00
Member

Hi, thanks for the report. I suspect this is same as other HIP crash reports, see: #109431
Can you confirm? Does this happen when rendering with CPU device.

Hi, thanks for the report. I suspect this is same as other HIP crash reports, see: #109431 Can you confirm? Does this happen when rendering with CPU device.
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-07-04 06:56:17 +02:00

Hello! Thanks for the reply. It does happen when trying to turn on cycles, with cpu, and gpu also. It just stops for half a second, and closes itself. It happens when -I click on cycles, when in render view- or -I click render view, when cycles is turned on-

Hello! Thanks for the reply. It does happen when trying to turn on cycles, with cpu, and gpu also. It just stops for half a second, and closes itself. It happens when -I click on cycles, when in render view- or -I click render view, when cycles is turned on-
Member

Thanks. CPU device rendering did not trigger crash on my system.
Could you share crash logs?:

Please open Blender's installation directory and double click on the blender_debug_gpu.cmd. This will start Blender in debug mode and create log files. Try to reproduce the
error again. Once it crashes or you close Blender manually the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them
to your bug report by clicking on the upload button as shown in the screenshot below or via drag and drop. Please also upload the crash log located in C:\Users\[your username]\AppData\Local\Temp\[project name].crash.txt (or simply type %TEMP% into the path bar of the Windows Explorer).2019_12_04_upload_icon_developer_blender_org.png

Thanks. CPU device rendering did not trigger crash on my system. Could you share crash logs?: > Please open Blender's installation directory and double click on the `blender_debug_gpu.cmd`. This will start Blender in debug mode and create log files. Try to reproduce the error again. Once it crashes or you close Blender manually the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them to your bug report by clicking on the upload button as shown in the screenshot below or via drag and drop. Please also upload the crash log located in `C:\Users\[your username]\AppData\Local\Temp\[project name].crash.txt` (or simply type `%TEMP%` into the path bar of the Windows Explorer).![2019_12_04_upload_icon_developer_blender_org.png](https://archive.blender.org/developer/F8190038/2019_12_04_upload_icon_developer_blender_org.png)

I did it with both 3.5 and 3.6 versions, I labeled them so it is obvious which one is which. To be honest, once I opened the cmd file, and pressed a key, it opened up blender, and it closed right away. I don't know what happened, I tried to open it with "run as administrator" but same reaction.

I did it with both 3.5 and 3.6 versions, I labeled them so it is obvious which one is which. To be honest, once I opened the cmd file, and pressed a key, it opened up blender, and it closed right away. I don't know what happened, I tried to open it with "run as administrator" but same reaction.
Member

Thanks. Have you recently switched from NVIDIA graphics card to AMD?
If so, I'd suggest to remove the NVIDIA drivers which are still present in your system. see: #108810 / #108101 (comment)

Thanks. Have you recently switched from NVIDIA graphics card to AMD? If so, I'd suggest to remove the NVIDIA drivers which are still present in your system. see: #108810 / https://projects.blender.org/blender/blender/issues/108101#issuecomment-950374

I am sorry about it, but that didn't solve the problem. I deleted every driver, and installed a new one (amd obviously), but the problem is the same. the blender_system_info.txt is still empty. I attached a system information file, hope it helps. I really am terribly sorry for all the trouble I am causing you.

I am sorry about it, but that didn't solve the problem. I deleted every driver, and installed a new one (amd obviously), but the problem is the same. the blender_system_info.txt is still empty. I attached a system information file, hope it helps. I really am terribly sorry for all the trouble I am causing you.
Member

Maybe try the clean install as others has done with the help of DDU?

Maybe try the clean install as others has done with the help of DDU?

I already did that, I used ddu

I already did that, I used ddu
Member

Thanks. Delete config folder then load fresh settings. See if that solves the problem: https://docs.blender.org/manual/en/dev/advanced/blender_directory_layout.html#path-layout

Thanks. Delete config folder then load fresh settings. See if that solves the problem: https://docs.blender.org/manual/en/dev/advanced/blender_directory_layout.html#path-layout

So I deleted this folder: C:\Users*USER*\AppData\Roaming\Blender Foundation\Blender\3.5\config
The problem is still here. I am on the edge of installing a windows on a large storage pendrive, and trying it on that. Could it worth something?

So I deleted this folder: C:\Users\*USER*\AppData\Roaming\Blender Foundation\Blender\3.5\config The problem is still here. I am on the edge of installing a windows on a large storage pendrive, and trying it on that. Could it worth something?
Member

Not really sure about it.
Does crash happen when generating system info from blender Help > Save system info?

Not really sure about it. Does crash happen when generating system info from blender `Help > Save system info`?

actually, it does. At least it leaves the file, although it is still empty...

actually, it does. At least it leaves the file, although it is still empty...
Member

Thanks for verifying.
system info attached here has captured some traces of Nvidia drivers. Hard to tell whether they are responsible for crash.

Thanks for verifying. system info attached [here](https://projects.blender.org/blender/blender/issues/109668#issuecomment-972952) has captured some traces of Nvidia drivers. Hard to tell whether they are responsible for crash.

So I tried to delete everything with DDU, except geforce experience, it didn't solve the problem, of course. What is interesting is when I press cycles, in non-render mode and in cpu mode, it is good, no problem with it. If I don't have (in edit> system) HIP turned on, and it is just at "none", blender crashes when I try to switch cycles settings to gpu compute

So I tried to delete everything with DDU, except geforce experience, it didn't solve the problem, of course. What is interesting is when I press cycles, in non-render mode and in cpu mode, it is good, no problem with it. If I don't have (in edit> system) HIP turned on, and it is just at "none", blender crashes when I try to switch cycles settings to gpu compute
Member

Thanks, out of ideas now so resetting the status.

Thanks, out of ideas now so resetting the status.

Actually, one of my thoughts was that an older gpu could solve the problem. But than I remembered the problem actually started when I had older gpu driver... I have no idea what could cause it.......

Actually, one of my thoughts was that an older gpu could solve the problem. But than I remembered the problem actually started when I had older gpu driver... I have no idea what could cause it.......
Pratik Borhade added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-07-05 13:21:54 +02:00

So i may have installed a windows on usb. It is as slow as it can be, but the thing is... I don't have any problems with cycles... The thing is, I wpuldn't want to reinstall blender, it is just so much work. Any ideas?

So i may have installed a windows on usb. It is as slow as it can be, but the thing is... I don't have any problems with cycles... The thing is, I wpuldn't want to reinstall blender, it is just so much work. Any ideas?

huhuhh
I solved the problem, installed windows with media creation tool using "upgrade" so none of my original files got deleted, only system files. Thank you for your help, I really appreciate it! <33

huhuhh I solved the problem, installed windows with media creation tool using "upgrade" so none of my original files got deleted, only system files. Thank you for your help, I really appreciate it! <33
Member

Will close this thread since you've managed to solve the problem.
Feel free to reopen or submit a new report if problem reappears.

Will close this thread since you've managed to solve the problem. Feel free to reopen or submit a new report if problem reappears.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-07-06 04:50:28 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109668
No description provided.