Brush settings > Texture > Mapping mode Area Plane creates a smaller mapping, cause tiling effect. #109992

Closed
opened 2023-07-12 03:27:44 +02:00 by Apraxas · 11 comments

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1650/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 526.47

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Broken also: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-11 13:57, hash: 0a13a7841c27
Broken also: version: 4.0.0 Alpha, branch: main, commit date: 2023-07-11 20:50, hash: c728fa0663b6

Worked: version: 3.3.8, branch: master, commit date: 2023-06-21 15:18, hash: 9b3a508cd511

Problem:

Brush settings > Texture > Mapping mode Area Plane creates a smaller mapping cause tiling effect.

Previously, Area Plane and View Plane will create the same dab size.

Exact steps for others to reproduce the error

  • Load This File in 3.5, draw, feature appears to be normal.
  • do the same thing in 3.6, feature appears to be a bit smaller and getting tiled.

Original description:

There appears to be a bug in the falloff when using Alpha brushes, as it causes a tiling effect at the edges, most noticeable when it is set to constant.

However, this issue does not occur in older versions of blender (It is unclear when this bug was introduced)
Tested on 3.3.8 by opening the exact same blender file, with identical brush settings.

3.6/4.0 3.5 and previous
image image

A work around I found was to edit the falloff like below, but since this issue doesn't happen in older versions, I can only assume it is a bug. (There is the chance the issue has nothing to do with the falloff and instead it is about how blender is reading the texture, but I've got no clue)

image

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1650/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 526.47 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Broken also: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-11 13:57, hash: `0a13a7841c27` Broken also: version: 4.0.0 Alpha, branch: main, commit date: 2023-07-11 20:50, hash: `c728fa0663b6` Worked: version: 3.3.8, branch: master, commit date: 2023-06-21 15:18, hash: `9b3a508cd511` Problem: `Brush settings > Texture > Mapping` mode `Area Plane` creates a smaller mapping cause tiling effect. Previously, `Area Plane` and `View Plane` will create the same dab size. **Exact steps for others to reproduce the error** - Load [This File](https://projects.blender.org/attachments/25339554-897a-4926-9d4c-506f8370676d) in 3.5, draw, feature appears to be normal. - do the same thing in 3.6, feature appears to be a bit smaller and getting tiled. -------- **Original description:** There appears to be a bug in the falloff when using Alpha brushes, as it causes a tiling effect at the edges, most noticeable when it is set to constant. However, this issue does not occur in older versions of blender (It is unclear when this bug was introduced) Tested on 3.3.8 by opening the exact same blender file, with identical brush settings. | 3.6/4.0 | 3.5 and previous | |--|--| | ![image](/attachments/fda02627-bb0b-4422-a5c1-6b8509bbf2d5) | ![image](/attachments/50398eb4-8c38-434b-934b-08fa5b309f76) | A work around I found was to edit the falloff like below, but since this issue doesn't happen in older versions, I can only assume it is a bug. (There is the chance the issue has nothing to do with the falloff and instead it is about how blender is reading the texture, but I've got no clue) ![image](/attachments/ffd6acb4-5fe9-417a-b768-f28f14696037)
Apraxas added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-07-12 03:27:45 +02:00
Member

I believe you are using an older brush set/texture configuration. There's a "Vector Displacement" option added inside "Texture"drop-down menu but it's not enabled by default, it has caused confusion before. Very likely the same cause as #106814

I believe you are using an older brush set/texture configuration. There's a "Vector Displacement" option added inside "Texture"drop-down menu but it's not enabled by default, it has caused confusion before. Very likely the same cause as #106814
Author

Hi. Thank you for checking, but I don't believe the issue has to do with the VDM setting being On or Off.

This issue is happening with brushes using normal alpha textures, not Vector Displacement Maps.
In fact, turning on the VDM checkbox would only make the brush act incorrectly.

Extra info: The same issue happens even if I remake the brush from scratch by opening the alpha texture and setting everything manually, so it has nothing to do with appending issues either.

image

Hi. Thank you for checking, but I don't believe the issue has to do with the VDM setting being On or Off. This issue is happening with brushes using normal alpha textures, not Vector Displacement Maps. In fact, turning on the VDM checkbox would only make the brush act incorrectly. Extra info: The same issue happens even if I remake the brush from scratch by opening the alpha texture and setting everything manually, so it has nothing to do with appending issues either. ![image](/attachments/33b316c9-8199-4ce5-93c1-de95df406050)
427 KiB
Member

@Apraxas Ok I see. So the "small bump" on top of the sphere are made by a different brush right? Your blend file didn't pack the texture so we could not check. Could you upload the blend file with packed texture by using File > External Data > Pack Resources? Also you could delete the sphere so the file is smaller.

From the screenshot I feel this might be a problem with normal.

@Apraxas Ok I see. So the "small bump" on top of the sphere are made by a different brush right? Your blend file didn't pack the texture so we could not check. Could you upload the blend file with packed texture by using `File > External Data > Pack Resources`? Also you could delete the sphere so the file is smaller. From the screenshot I feel this might be a problem with normal.
Author

@ChengduLittleA
Heya! Thank you. I appreciate your taking the time to check this issue.

I have done as indicated and uploaded a new file. (You'll have to subdivide the bare bones sphere yourself, though)

@ChengduLittleA Heya! Thank you. I appreciate your taking the time to check this issue. I have done as indicated and uploaded a new file. (You'll have to subdivide the bare bones sphere yourself, though)
Member

Ok I see. Now I understood you meant that the small bumps are wrongly tiled and should not be visible. Yes can confirm that under 3.6.0

Compared to 3.5, the broken brush seems to be "smaller" (can be verified from looking at the distance from the tip of the bump to the cursor).

Ok I see. Now I understood you meant that the small bumps are wrongly tiled and should not be visible. Yes can confirm that under 3.6.0 Compared to 3.5, the broken brush seems to be "smaller" (can be verified from looking at the distance from the tip of the bump to the cursor).
Author

Thank you. I have tested several alpha textures that worked perfectly on 3.3.8, and almost all of them have some issue or other, like small holes at the edges (if the brush is supposed to carve into the mesh) or bumps like this one (if it is supposed to displace it upwards)

Thank you. I have tested several alpha textures that worked perfectly on 3.3.8, and almost all of them have some issue or other, like small holes at the edges (if the brush is supposed to carve into the mesh) or bumps like this one (if it is supposed to displace it upwards)
YimingWu added
Module
Sculpt, Paint & Texture
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-07-12 05:54:46 +02:00
Member

Two ways to mitigate this issue for now under 3.6:

  • Change Brush settings tab > Texture > Mapping from Area Plane to View Plane (This also fixes the dab size issue, so suspect "Area Plane" mode is problematic)
  • Change Texture Settings tab > Image > Mapping from Repeat to Clip or Extend (This will keep the dab size a tad smaller than normal)
Two ways to mitigate this issue for now under 3.6: - Change `Brush settings tab > Texture > Mapping` from `Area Plane` to `View Plane` (This also fixes the dab size issue, so suspect "Area Plane" mode is problematic) - Change `Texture Settings tab > Image > Mapping` from `Repeat` to `Clip` or `Extend` (This will keep the dab size a tad smaller than normal)
YimingWu changed title from Alpha Brushes - Falloff bugged and causes tiling to `Brush settings > Texture > Mapping` mode `Area Plane` creates a smaller mapping, cause tiling effect. 2023-07-12 06:03:34 +02:00
Member

Would assume this is related to #106895?

Would assume this is related to #106895?
Member
@JulienKaspar : ^^
Member

@lichtwerk You're right. Also #109201 was made to resolve this issue.

But I see a separate bug that this report highlights. Area & View Plane should be consistent, but they are not. The report can stay open for that 👍

Since these fixes should be done for 4.0 I'll raise the priority.

@lichtwerk You're right. Also #109201 was made to resolve this issue. But I see a separate bug that this report highlights. Area & View Plane should be consistent, but they are not. The report can stay open for that 👍 Since these fixes should be done for 4.0 I'll raise the priority.
Julien Kaspar added
Type
Bug
Priority
High
and removed
Type
Report
Priority
Normal
labels 2023-07-12 13:45:08 +02:00
Member

This has been fixed by 8141ee90f4. Closing.

This has been fixed by 8141ee90f4. Closing.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-08-23 10:57:49 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109992
No description provided.