Mesh to curve in 3.6.1 merges points #110454

Closed
opened 2023-07-25 11:18:48 +02:00 by Juan Manuel Lynch · 2 comments

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.79

Blender Version
Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: 8bda729ef4dc
Worked: (3.6.0)

Short description of error
Not exactly an error.
After updating to 3.6.1 from 3.6.0 I noticed my geometry nodetree wasn't working properlly, after some searching I find out the problem was the Mesh to curve node in 3.6.1, it merges points from an already splitted mesh into one spline instead of keeping each edge as a single spline. If merging points is the correct behaiviour there should at least be an option no to do so.

Exact steps for others to reproduce the error
Open the attached blend file in both versions to see the difference in the number of splines outputed

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.79 **Blender Version** Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: `8bda729ef4dc` Worked: (3.6.0) **Short description of error** Not exactly an error. After updating to 3.6.1 from 3.6.0 I noticed my geometry nodetree wasn't working properlly, after some searching I find out the problem was the Mesh to curve node in 3.6.1, it merges points from an already splitted mesh into one spline instead of keeping each edge as a single spline. If merging points is the correct behaiviour there should at least be an option no to do so. **Exact steps for others to reproduce the error** Open the attached blend file in both versions to see the difference in the number of splines outputed
Juan Manuel Lynch added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-07-25 11:18:49 +02:00
Member

Here looks like from 3.6, 3.6.1 and 4.0 they both result in 2 entries in Spline, and 4 Control Point. Unable to confirm this bug...

Here looks like from 3.6, 3.6.1 and 4.0 they both result in 2 entries in `Spline`, and 4 `Control Point`. Unable to confirm this bug...
YimingWu added the
Interest
Geometry Nodes
label 2023-07-25 15:57:02 +02:00
Iliya Katushenock added the
Interest
Nodes & Physics
label 2023-07-25 21:53:48 +02:00

As far as I can see, it's most likely a duplicate of #109236. Please subscribe in #109236 if you want to see further updates.

As far as I can see, it's most likely a duplicate of #109236. Please subscribe in #109236 if you want to see further updates.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-07-25 21:56:21 +02:00
Iliya Katushenock added
Status
Duplicate
and removed
Status
Archived
labels 2023-07-25 21:56:29 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110454
No description provided.