the yellow dots on each object are gone and too small #110631

Closed
opened 2023-07-30 16:21:20 +02:00 by Mim7 · 22 comments

System Information
Operating system: Linux-6.2.0-25-generic-x86_64-with-glibc2.37 64 Bits, X11 UI
Graphics card: NVC1 Mesa 4.3 (Core Profile) Mesa 23.0.4-0ubuntu1~23.04.1

Blender Version
Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: 8bda729ef4dc
Worked: (newest version of Blender that worked as expected)

Short description of error
the yellow dots on each object are gone and too small

please help me !

**System Information** Operating system: Linux-6.2.0-25-generic-x86_64-with-glibc2.37 64 Bits, X11 UI Graphics card: NVC1 Mesa 4.3 (Core Profile) Mesa 23.0.4-0ubuntu1~23.04.1 **Blender Version** Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: `8bda729ef4dc` Worked: (newest version of Blender that worked as expected) **Short description of error** the yellow dots on each object are gone and too small please help me !
Mim7 added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-07-30 16:21:21 +02:00
Member

Hi, this can be configured in User Preferences > Themes > 3D Viewport > Vertex Size and Object Origin Size. Also, see if reverting to factory default helps :)

There's a slight chance that this being a driver issue, where it somehow GL doesn't draw points greater than 1px, but very unlikely.

Hi, this can be configured in `User Preferences > Themes > 3D Viewport > Vertex Size` and `Object Origin Size`. Also, see if reverting to factory default helps :) There's a slight chance that this being a driver issue, where it somehow GL doesn't draw points greater than 1px, but very unlikely.
YimingWu added
Status
Needs Information from User
Interest
EEVEE & Viewport
and removed
Status
Needs Triage
labels 2023-07-31 04:54:14 +02:00
Author

Object Origin Size Error !

Object Origin Size Error !
Member

@Mim7 please try update your graphics driver. From the look of it you are using Mesa driver for integrated graphics? Try install packages specifically for intel/amd and see if it makes any difference. Thanks!

@Mim7 please try update your graphics driver. From the look of it you are using Mesa driver for integrated graphics? Try install packages specifically for intel/amd and see if it makes any difference. Thanks!
Author

I've reported the appearance but the report is gone. I changed to the Nvidia 390 driver, the camera display and lights get an error like this (my camera and lights are not this bad): https://blenderartists.org/t/help-camera-looks-broken/1269304

I've reported the appearance but the report is gone. I changed to the Nvidia 390 driver, the camera display and lights get an error like this (my camera and lights are not this bad): https://blenderartists.org/t/help-camera-looks-broken/1269304
Member

@Mim7 , From the look of the system information, you are probably on a laptop with switchable graphics? In that case you probably need to force nvidia card by using sudo prime-select nvidia.

@Mim7 , From the look of the system information, you are probably on a laptop with switchable graphics? In that case you probably need to force nvidia card by using `sudo prime-select nvidia`.
Author

if I select nvidia ( sudo prime-select nvidia ) then the problem goes like this (my camera and lights are not this bad): https://blenderartists.org/t/help-camera-looks-broken/1269304

if my driver is NVC1 Mesa 4.3 then the problem is like the one above: #110631 (comment)

this is definitely a bug of blender or driver . the yellow dot is gone, I'm waiting for the fix.

if I select nvidia ( sudo prime-select nvidia ) then the problem goes like this (my camera and lights are not this bad): https://blenderartists.org/t/help-camera-looks-broken/1269304 if my driver is NVC1 Mesa 4.3 then the problem is like the one above: https://projects.blender.org/blender/blender/issues/110631#issue-100762 this is definitely a bug of blender or driver . the yellow dot is gone, I'm waiting for the fix.
Author

New Error Wind !

New Error Wind !
Member

if I select nvidia ( sudo prime-select nvidia ) then the problem goes like this

This apparently looks perfectly fine to me? Am I missing something?

New Error Wind !

Is this from the mesa driver or nvidia?

> if I select nvidia ( sudo prime-select nvidia ) then the problem goes like this This apparently looks perfectly fine to me? Am I missing something? > New Error Wind ! Is this from the mesa driver or nvidia?
Author

Is this from the mesa driver or nvidia?

mesa , i can't change driver anymore to Nvidia 390 because it can black screen my OS ( ubuntu ) .

This apparently looks perfectly fine to me? Am I missing something?

It means ?

> Is this from the mesa driver or nvidia? mesa , i can't change driver anymore to Nvidia 390 because it can black screen my OS ( ubuntu ) . > This apparently looks perfectly fine to me? Am I missing something? It means ?
Author

New Object Error !

New Object Error !
Member

New Object Error !

Hi @Mim7 this is not a problem with blender. It's due to the way curve modifier is used and it's giving expected result.

New Error Wind !

This is displayed correctly. The arrow on the side is the gizmo for manipulating strength.

mesa , i can't change driver anymore to Nvidia 390 because it can black screen my OS ( ubuntu ) .

You'll need to find a driver version that's from Nvidia and also does work correctly with your ubuntu. The ubuntu package nvidia-driver-xxx should work fine. Also for generic mesa driver, it's best to try different packaged version and see which one works.

Since when using nvidia the display works correctly, I think we can close this issue.

>New Object Error ! Hi @Mim7 this is not a problem with blender. It's due to the way curve modifier is used and it's giving expected result. > New Error Wind ! This is displayed correctly. The arrow on the side is the gizmo for manipulating strength. > mesa , i can't change driver anymore to Nvidia 390 because it can black screen my OS ( ubuntu ) . You'll need to find a driver version that's from Nvidia and also does work correctly with your ubuntu. The ubuntu package `nvidia-driver-xxx` should work fine. Also for generic mesa driver, it's best to try different packaged version and see which one works. Since when using nvidia the display works correctly, I think we can close this issue.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-08-06 10:19:52 +02:00
Author

Hi @ChengduLittleA this is what happens when i use the nvidia 390 driver, i've been looking for a solution but it doesn't work. [ picture below - sudo prime-select nvidia ] .

if i use mesa driver then this #110631 (comment) happens

Hi @ChengduLittleA this is what happens when i use the nvidia 390 driver, i've been looking for a solution but it doesn't work. [ picture below - sudo prime-select nvidia ] . if i use mesa driver then this https://projects.blender.org/blender/blender/issues/110631#issuecomment-990462 happens
Author

My System Info

My System Info
Member

Hi @Mim7 the system info shows that the video driver is still Mesa... If you have successfully selected nvidia card, the vendor section should say NVIDIA or something.

renderer:	'NVC1'
vendor:	'Mesa'
version:	'4.3 (Core Profile) Mesa 23.0.4-0ubuntu1~23.04.1'

This particular error effect is similar to #111162 (Is your iGPU a intel HD Graphics 4400/4600 too?), you could try this build and see if it resolves this particular display issue. Thanks!

Hi @Mim7 the system info shows that the video driver is still Mesa... If you have successfully selected nvidia card, the vendor section should say NVIDIA or something. ``` renderer: 'NVC1' vendor: 'Mesa' version: '4.3 (Core Profile) Mesa 23.0.4-0ubuntu1~23.04.1' ``` This particular error effect is similar to #111162 (Is your iGPU a intel HD Graphics 4400/4600 too?), you could try [this build](https://builder.blender.org/download/patch/PR111708/) and see if it resolves this particular display issue. Thanks!
YimingWu reopened this issue 2023-09-05 07:06:24 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2023-09-05 07:06:27 +02:00
YimingWu added
Module
EEVEE & Viewport
Status
Needs Info from Developers
and removed
Status
Needs Triage
labels 2023-09-05 07:06:38 +02:00
Author

If I change, it looks like this. Blender 3.6.2

If I change, it looks like this. Blender 3.6.2
Author

My Blender Crash !

My [Blender](https://builder.blender.org/download/patch/PR111708/) Crash !
Author

Hi @ChengduLittleA I have tried it but it still gives an error.

Hi @ChengduLittleA I have tried it but it still gives an error.
Member

@Mim7 have you cleaned your Mesa shader cache? See #111162 (comment)

@Mim7 have you cleaned your Mesa shader cache? See https://projects.blender.org/blender/blender/issues/111162#issuecomment-1006544
Author

Hi @ChengduLittleA the problem has been resolved . thanks

@Mim7 have you cleaned your Mesa shader cache? See #111162 (comment)

still has problems when I use it
renderer: 'NVC1'
vendor: 'Mesa'

Hi @ChengduLittleA the problem has been resolved . thanks > @Mim7 have you cleaned your Mesa shader cache? See https://projects.blender.org/blender/blender/issues/111162#issuecomment-1006544 still has problems when I use it renderer: 'NVC1' vendor: 'Mesa'
11 KiB
Member

@Mim7 I think you somehow need to ensure that you are running blender using your nvidia card. Either you could try disabling cpu integrated graphics from BIOS, or you will need to fiddle around prime-select (which is unfortunately a hassle from what I know).

@Mim7 I think you somehow need to ensure that you are running blender using your nvidia card. Either you could try disabling cpu integrated graphics from BIOS, or you will need to fiddle around `prime-select` (which is unfortunately a hassle from what I know).
Author

Hi @ChengduLittleA My Ubuntu gives an error if prime-select nvidia because the driver is too old. the problem solved when I used it ( renderer: 'Mesa Intel(R) HD Graphics 4000 (IVB GT2)'
vendor: 'Intel' ) with #111162 (comment) . Thanks

Hi @ChengduLittleA My Ubuntu gives an error if prime-select nvidia because the driver is too old. the problem solved when I used it ( renderer: 'Mesa Intel(R) HD Graphics 4000 (IVB GT2)' vendor: 'Intel' ) with https://projects.blender.org/blender/blender/issues/111162#issuecomment-1006544 . Thanks
Member

I see, so it's that you can't really select the nvidia card due to driver issue. Then this probably needs to be solved on your side.

Anyways since you can use blender now with intel graphics with that solution, I'll close this report. Thanks for sticking around :D

I see, so it's that you can't really select the nvidia card due to driver issue. Then this probably needs to be solved on your side. Anyways since you can use blender now with intel graphics with that solution, I'll close this report. Thanks for sticking around :D
Blender Bot added
Status
Archived
and removed
Status
Needs Info from Developers
labels 2023-09-18 05:29:08 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110631
No description provided.