Invalid value in hipTexObjectCreate #110808

Closed
opened 2023-08-04 18:34:01 +02:00 by widarr · 5 comments

System Information
Operating system: Linux-6.4.6-1-MANJARO-x86_64-with-glibc2.37 64 Bits, X11 UI
Graphics card: AMD Radeon Graphics (gfx1100, LLVM 15.0.7, DRM 3.52, 6.4.6-1-MANJARO) AMD 4.6 (Core Profile) Mesa 23.0.4
(AMD Navi31 [Radeon Pro W7900] driver: amdgpu)

Blender Version
Broken: version: 3.6.0, branch: makepkg (modified), commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
When I load my scene in Blender with cycles I get following error message and the scene is not loaded (Blender does not crash):
Invalid value in hipTexObjectCreate(&cmem->texobject, &resDesc, &texDesc, __null)(intern/cycles/device/hip/device_impl.cpp:854)

Exact steps for others to reproduce the error
As described above this only happens when I use cycles, eevee works fine.
I'm using the Radeon Pro W7900 with the open source driver (amdgpu) and Cycles Render Devices set to HIP
I did not get this error message with my old Graphics card (GeForce RTX 3080Ti) with the closed source driver
and Cycles Render Devices set to CUDA. When I switch back to Materials Preview the scene looks normal.
The scene also works like expected when I just switch back to CPU rendering (whereas much slower)
I have tested some other simpler scenes with this new setup and it worked, no error.

**System Information** Operating system: Linux-6.4.6-1-MANJARO-x86_64-with-glibc2.37 64 Bits, X11 UI Graphics card: AMD Radeon Graphics (gfx1100, LLVM 15.0.7, DRM 3.52, 6.4.6-1-MANJARO) AMD 4.6 (Core Profile) Mesa 23.0.4 (AMD Navi31 [Radeon Pro W7900] driver: amdgpu) **Blender Version** Broken: version: 3.6.0, branch: makepkg (modified), commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** When I load my scene in Blender with cycles I get following error message and the scene is not loaded (Blender does not crash): Invalid value in hipTexObjectCreate(&cmem->texobject, &resDesc, &texDesc, __null)(intern/cycles/device/hip/device_impl.cpp:854) **Exact steps for others to reproduce the error** As described above this only happens when I use cycles, eevee works fine. I'm using the Radeon Pro W7900 with the open source driver (amdgpu) and Cycles Render Devices set to HIP I did not get this error message with my old Graphics card (GeForce RTX 3080Ti) with the closed source driver and Cycles Render Devices set to CUDA. When I switch back to Materials Preview the scene looks normal. The scene also works like expected when I just switch back to CPU rendering (whereas much slower) I have tested some other simpler scenes with this new setup and it worked, no error.
widarr added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-04 18:34:01 +02:00

Are you using a virtual machine?

Are you using a virtual machine?
Iliya Katushenock added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-08-04 19:03:10 +02:00
Author

No, just native Blender on Manjaro Linux

No, just native Blender on Manjaro Linux
Iliya Katushenock added
Status
Needs Triage
Platform
Linux
and removed
Status
Needs Information from User
labels 2023-08-04 23:11:18 +02:00
Member

Hi, could you try with closed source driver: https://www.amd.com/en/support/professional-graphics/amd-radeon-pro/amd-radeon-pro-w7000-series/amd-radeon-pro-w7900

Any chance you can share .blend file with us?
I suspect the error is due the textures present in your file.

Hi, could you try with closed source driver: https://www.amd.com/en/support/professional-graphics/amd-radeon-pro/amd-radeon-pro-w7000-series/amd-radeon-pro-w7900 Any chance you can share .blend file with us? I suspect the error is due the textures present in your file.
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-08-07 05:14:54 +02:00
Author

Hiho!

I found the error causing thing myself!

In my scene I used a 16k exr starmap from NASA as background: https://svs.gsfc.nasa.gov/4851
The same error occured on Linux and Windows!
When I removed the texture it worked normally again (except the now magenta background)
The implementation of HIP support under Blender seems to not handle large textures well

It worked with the 16k in the same blender version but with the nVidia RTX 3080Ti and closed source drivers.

@PratikPB2123 I tested the professional closed driver before, it behaved very unstable on my (dual GPU) system, thats why I use the OpenSource driver now.
On Windows I tested this with the professional driver and I got the same error. Without the aforementioned texture it works on both systems with closed source and open source drivers

It seems to work with the 8k version!

Hiho! I found the error causing thing myself! In my scene I used a 16k exr starmap from NASA as background: https://svs.gsfc.nasa.gov/4851 The same error occured on Linux and Windows! When I removed the texture it worked normally again (except the now magenta background) The implementation of HIP support under Blender seems to not handle large textures well It worked with the 16k in the same blender version but with the nVidia RTX 3080Ti and closed source drivers. @PratikPB2123 I tested the professional closed driver before, it behaved very unstable on my (dual GPU) system, thats why I use the OpenSource driver now. On Windows I tested this with the professional driver and I got the same error. Without the aforementioned texture it works on both systems with closed source and open source drivers It seems to work with the 8k version!
Member

Good to know you found the cause :)
This is a known issue unfortunately on AMD/HIP devices: #91571

Image texture size is limited, could detect this and resize or show user better error (#94057, #93109)

Good to know you found the cause :) This is a known issue unfortunately on AMD/HIP devices: #91571 > [Image texture size is limited, could detect this and resize or show user better error (#94057, #93109)](https://projects.blender.org/blender/blender/issues/91571#:~:text=Image%20texture%20size%20is%20limited%2C%20could%20detect%20this%20and%20resize%20or%20show%20user%20better%20error%20(%2394057%2C%20%2393109))
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-08-14 08:01:03 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110808
No description provided.