Grease Pencil vertex paint select is using sculpt mode selection mode #110966

Open
opened 2023-08-09 16:04:34 +02:00 by Julien Kaspar · 3 comments
Member

System Information
Operating system: Linux-6.4.6-gentoo-x86_64-AMD_Ryzen_Threadripper_1950X_16-Core_Processor-with-glibc2.37 64 Bits, X11 UI
Graphics card: AMD Radeon RX 7900 XT (gfx1100, LLVM 15.0.7, DRM 3.52, 6.4.6-gentoo) AMD 4.6 (Core Profile) Mesa 23.3.0-devel (git-50c29e1ffa)

Blender Version
Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-08-08 20:16, hash: 5cdec2f12ab0
Worked:

Short description of error
When selecting with mouse clicks the selection mode in the header determines which component is selected.
In Grease Pencil sculpt mode this behaves as expected. If it's set to "points", selecting will select points. If it's set to "stroke" it will select entire strokes.

When switching to vertex paint mode this is not the case. Instead it will select components based on the selection mode that is set in sculpt mode.

The ideal behavior imo would be to have all grease pencil modes share the active selection mode.
This makes it easier to manage and simpler to use.

Exact steps for others to reproduce the error

  • Change the keymap preferences to right click select (Selection shortcuts in left click select are partially broken atm)
  • Add a Gpencil Monkey
  • Switch to Sculpt Mode
  • Enable point selection mode
  • Select some points with RMB and Shift RMB
  • Switch to Vertex Paint mode
  • Make sure to use stroke selection mode
  • Select some strokes with RMB and Shift RMB (Notice how it will instead select points)
**System Information** Operating system: Linux-6.4.6-gentoo-x86_64-AMD_Ryzen_Threadripper_1950X_16-Core_Processor-with-glibc2.37 64 Bits, X11 UI Graphics card: AMD Radeon RX 7900 XT (gfx1100, LLVM 15.0.7, DRM 3.52, 6.4.6-gentoo) AMD 4.6 (Core Profile) Mesa 23.3.0-devel (git-50c29e1ffa) **Blender Version** Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-08-08 20:16, hash: `5cdec2f12ab0` Worked: **Short description of error** When selecting with mouse clicks the selection mode in the header determines which component is selected. In Grease Pencil sculpt mode this behaves as expected. If it's set to "points", selecting will select points. If it's set to "stroke" it will select entire strokes. When switching to vertex paint mode this is not the case. Instead it will select components based on the selection mode that is set in sculpt mode. The ideal behavior imo would be to have all grease pencil modes share the active selection mode. This makes it easier to manage and simpler to use. **Exact steps for others to reproduce the error** - Change the keymap preferences to right click select (Selection shortcuts in left click select are partially broken atm) - Add a Gpencil Monkey - Switch to Sculpt Mode - Enable point selection mode - Select some points with `RMB` and `Shift RMB` - Switch to Vertex Paint mode - Make sure to use stroke selection mode - Select some strokes with `RMB` and `Shift RMB` (Notice how it will instead select points)
Member

Can confirm

Can confirm
Member

Looks like a long standing problem (broken in 2.83 too)
Is this a known issue/limitation?
@antoniov ^


oh, even LMB selection fails to select points/strokes in other interaction modes (never noticed this before 😅 )

Looks like a long standing problem (broken in 2.83 too) Is this a known issue/limitation? @antoniov ^ - - - oh, even LMB selection fails to select points/strokes in other interaction modes (never noticed this before 😅 )
Author
Member

oh, even LMB selection fails to select points/strokes in other interaction modes (never noticed this before 😅 )

#110960 will at least handle that 👍

> oh, even LMB selection fails to select points/strokes in other interaction modes (never noticed this before 😅 ) #110960 will at least handle that 👍
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110966
No description provided.