Blender 3.6.2 Crashes when trying to add geometry nodes to meshes (with PolyHaven asset library in place) #111358

Closed
opened 2023-08-21 19:35:57 +02:00 by Rotem Yaari · 13 comments

System Information
Operating system: macOS 13.5.1 (22G90)
Graphics card: M1 Max

Blender Version
Broken: 3.6.2
Worked: 3.6.1?

Short description of error
Start Blender -> Go to Geometry nodes tab on default cube -> Click New -> Shift+A for adding a node -> Blender crashes

Exact steps for others to reproduce the error
Start Blender -> Go to Geometry nodes tab on default cube -> Click New -> Shift+A for adding a node -> Blender crashes

**System Information** Operating system: macOS 13.5.1 (22G90) Graphics card: M1 Max **Blender Version** Broken: 3.6.2 Worked: 3.6.1? **Short description of error** Start Blender -> Go to Geometry nodes tab on default cube -> Click New -> Shift+A for adding a node -> Blender crashes **Exact steps for others to reproduce the error** Start Blender -> Go to Geometry nodes tab on default cube -> Click New -> Shift+A for adding a node -> Blender crashes
Rotem Yaari added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-21 19:35:58 +02:00
Member

Hi @vmalloc , could you give us the crash log (Instructions here) and system info (Help > Save System Info) file please? Thanks!

It probably will have something to do with ARM thing

Hi @vmalloc , could you give us the crash log ([Instructions here](https://docs.blender.org/manual/en/3.6/troubleshooting/crash.html#macos)) and system info (Help > Save System Info) file please? Thanks! It probably will have something to do with ARM thing
YimingWu added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-08-22 03:34:39 +02:00
Author

Attaching requested files here:

Attaching requested files here:
Member

Seems to crash with the Asset System.

Could you try with your Asset Libraries disabled?
Or just try with File > Defaults > Load Factory Settings?

Seems to crash with the Asset System. Could you try with your Asset Libraries disabled? Or just try with File > Defaults > Load Factory Settings?
Author

@lichtwerk I had one external asset library (used by the PolyHaven addon). I removed and re-added it and the problem seems to be gone... I still think it's worth fixing, but at least now it doesn't crash. Thanks!

@lichtwerk I had one external asset library (used by the PolyHaven addon). I removed and re-added it and the problem seems to be gone... I still think it's worth fixing, but at least now it doesn't crash. Thanks!
Philipp Oeser added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-08-22 11:04:14 +02:00
Philipp Oeser changed title from Blender 3.6.2 Crashes when trying to add geometry nodes to meshes to Blender 3.6.2 Crashes when trying to add geometry nodes to meshes (with PolyHaven asset library in place) 2023-08-22 11:04:51 +02:00
Member

@vmalloc hi, can you check in recent 4.0 build?: https://builder.blender.org/download/daily/
Crash log suggests, crash occurred while iterating through asset file items. Could it be some asset responsible for crash? Could you identify the culprit>

Thread 35 Crashed: 0 Blender 0x100c5a850 blo_decode_and_check(FileData*, ReportList*) + 312 1 Blender 0x1019be65c filelist_readjob_recursive_dir_add_items(bool, FileListReadJob*, bool const*, bool*, float*) + 836 2 Blender 0x1019bfad0 void blender::FunctionRef::callback_fn(long, blender::asset_system::AssetLibrary&) + 128 3 Blender 0x100c568d4 blender::asset_system::AssetLibraryService::foreach_loaded_asset_library(blender::FunctionRef, bool) const + 204 4 Blender 0x1019be130 filelist_readjob_all_asset_library(FileListReadJob*, bool*, bool*, float*) + 252 5 Blender 0x100c2542c do_job_thread + 40 6 libsystem_pthread.dylib 0x1a949ffa8 _pthread_start + 148 7 libsystem_pthread.dylib 0x1a949ada0 thread_start + 8
@vmalloc hi, can you check in recent 4.0 build?: https://builder.blender.org/download/daily/ Crash log suggests, crash occurred while iterating through asset file items. Could it be some asset responsible for crash? Could you identify the culprit> <details> <summary> Thread 35 Crashed: </summary> 0 Blender 0x100c5a850 blo_decode_and_check(FileData*, ReportList*) + 312 1 Blender 0x1019be65c filelist_readjob_recursive_dir_add_items(bool, FileListReadJob*, bool const*, bool*, float*) + 836 2 Blender 0x1019bfad0 void blender::FunctionRef<void (blender::asset_system::AssetLibrary&)>::callback_fn<filelist_readjob_all_asset_library(FileListReadJob*, bool*, bool*, float*)::$_1>(long, blender::asset_system::AssetLibrary&) + 128 3 Blender 0x100c568d4 blender::asset_system::AssetLibraryService::foreach_loaded_asset_library(blender::FunctionRef<void (blender::asset_system::AssetLibrary&)>, bool) const + 204 4 Blender 0x1019be130 filelist_readjob_all_asset_library(FileListReadJob*, bool*, bool*, float*) + 252 5 Blender 0x100c2542c do_job_thread + 40 6 libsystem_pthread.dylib 0x1a949ffa8 _pthread_start + 148 7 libsystem_pthread.dylib 0x1a949ada0 thread_start + 8 </details>
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-09-05 06:55:23 +02:00
Author

@PratikPB2123 Unfortunately since disabling the asset library I wasn't able to reproduce it... It is possible it is some leftover left by the PH add-on, but I can't say for sure....

@PratikPB2123 Unfortunately since disabling the asset library I wasn't able to reproduce it... It is possible it is some leftover left by the PH add-on, but I can't say for sure....
Member

Ok. Any chance you can still enable the poly heaven asset/add-on and identify the root problem?

Ok. Any chance you can still enable the poly heaven asset/add-on and identify the root problem?
Member

Perhaps related to #111246 / #111235

Perhaps related to #111246 / #111235
Author

I will try to re-enable it from scratch and see if it reproduces. Will update

I will try to re-enable it from scratch and see if it reproduces. Will update
Author

Yes it seems like the PolyHaven addon is consistently crashing Blender for me...

Yes it seems like the PolyHaven addon is consistently crashing Blender for me...
Member

In that case, best to report the crash to PolyHevan authors.
BTW, as mentioned in my previous comment, similar crash has been fixed recently, see: #111246 / #111235
So I'd suggest you to verify the crash in 4.0 build: https://builder.blender.org/download/daily/

In that case, best to report the crash to PolyHevan authors. BTW, as mentioned in my previous comment, similar crash has been fixed recently, see: #111246 / #111235 So I'd suggest you to verify the crash in 4.0 build: https://builder.blender.org/download/daily/
Author

@PratikPB2123 It seems the 4.0 build solves the issue for me! Thanks!

@PratikPB2123 It seems the 4.0 build solves the issue for me! Thanks!
Member

Thanks. Closing the report.

Thanks. Closing the report.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-09-06 04:50:15 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111358
No description provided.