Blender crashes when trying to open the asset browser #111246

Closed
opened 2023-08-18 03:20:01 +02:00 by Piero · 8 comments

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.61

Blender Version
Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: e53e55951e7a
Worked: (newest version of Blender that worked as expected)

Short description of error
A similar issue was reported before: #106255 (comment)

Exact steps for others to reproduce the error
With Blender 3.6.1, the issue wasn't gone, but I was at least able to open the asset browser, and drop a few of them into the viewport before Blender would crash.

With the latest update 3.6.2, now just trying to open the asset browser causes Blender to crash right away.

See the screen capture attached.
The log file is attached too.

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.61 **Blender Version** Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: `e53e55951e7a` Worked: (newest version of Blender that worked as expected) **Short description of error** A similar issue was reported before: https://projects.blender.org/blender/blender/issues/106255#issuecomment-932005 **Exact steps for others to reproduce the error** With Blender 3.6.1, the issue wasn't gone, but I was at least able to open the asset browser, and drop a few of them into the viewport before Blender would crash. With the latest update 3.6.2, now just trying to open the asset browser causes Blender to crash right away. See the screen capture attached. The log file is attached too.
Piero added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-18 03:20:02 +02:00
Member

Hi, thanks for the report. I'm not able to confirm in 4.0 and 3.6

Could you check with factory reset?: File > Defaults > Load Factory Settings
Very likely a particular file/asset from the library folder is causing the crash. Could you identify the exact culprit, then share it here?

Hi, thanks for the report. I'm not able to confirm in 4.0 and 3.6 Could you check with factory reset?: `File > Defaults > Load Factory Settings` Very likely a particular file/asset from the library folder is causing the crash. Could you identify the exact culprit, then share it here?
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-08-18 05:28:23 +02:00
Iliya Katushenock added the
Interest
Asset Browser
Interest
Overrides
labels 2023-08-18 12:15:50 +02:00
Member

Could it be because the file browser property is set to maximized area?: #111297

Could it be because the file browser property is set to `maximized area`?: #111297
Author

Thanks for looking into this, @PratikPB2123

I can confirm the culprit is Poly Haven Assets. Once I deleted its path, the asset browser worked fine.
There's something wrong with their assets, or their plugin, that's causing this issue.

I think it's safe to assume we can close the bug I submitted here.

Thanks

Thanks for looking into this, @PratikPB2123 I can confirm the culprit is Poly Haven Assets. Once I deleted its path, the asset browser worked fine. There's something wrong with their assets, or their plugin, that's causing this issue. I think it's safe to assume we can close the bug I submitted here. Thanks

Someone else has reported a similar bug, with the same stack trace, to Poly Haven as well: https://github.com/Poly-Haven/polyhavenassets/issues/81

I believe this is a legitimate bug we need to fix on Blender side but for that we do need to be able to reproduce this consistently. I'll keep an eye out on their tracker as well.

@mont29 Do you see something obvious in the is_minversion_older_than_blender code path that would cause an access violation? My first thought is that fd->filesdna might really be null, but we won't see the assert in retail builds etc.

Someone else has reported a similar bug, with the same stack trace, to Poly Haven as well: https://github.com/Poly-Haven/polyhavenassets/issues/81 I believe this is a legitimate bug we need to fix on Blender side but for that we do need to be able to reproduce this consistently. I'll keep an eye out on their tracker as well. @mont29 Do you see something obvious in the `is_minversion_older_than_blender` code path that would cause an access violation? My first thought is that `fd->filesdna` might really be null, but we won't see the assert in retail builds etc.
Pratik Borhade added
Status
Needs Info from Developers
and removed
Status
Needs Information from User
labels 2023-08-21 06:18:01 +02:00
Bastien Montagne added
Status
Needs Information from User
and removed
Status
Needs Info from Developers
labels 2023-08-21 09:58:08 +02:00

If the read blend file is corrupted, then yes, sure... but there's not much that can be done here tbh. Especially if we do not have the broken file (or a full proper backtrace at least)!

Note that if fd->filesdna is null, it would have been caught in the first step of the caller function blo_decode_and_check (if (read_file_dna(fd, &error_message) == false)).

And the report on polyhaven is not the same, since in their case it does report a missing DNA block.

If the read blend file is corrupted, then yes, sure... but there's not much that can be done here tbh. Especially if we do not have the broken file (or a full proper backtrace at least)! Note that if `fd->filesdna` is null, it would have been caught in the first step of the caller function `blo_decode_and_check` (`if (read_file_dna(fd, &error_message) == false)`). And the report on polyhaven is not the same, since in their case it does report a missing DNA block.
Member

Is this related #111235 ?

Is this related #111235 ?

This is indeed almost certainly the same issue as #111235, can be merged imho.

This is indeed almost certainly the same issue as #111235, can be merged imho.

Closing as a duplicate since the other bug provided the necessary file to reproduce/fix the issue.

Closing as a duplicate since the other bug provided the necessary file to reproduce/fix the issue.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-08-21 20:27:38 +02:00
Jesse Yurkovich added
Status
Duplicate
and removed
Status
Archived
labels 2023-08-21 20:27:46 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111246
No description provided.