NLA crash moving sound strip (fixed in main, needs backport) #111724

Closed
opened 2023-08-31 10:08:50 +02:00 by Nettan-Yonas · 3 comments

System Information

Processor: 11th Gen Intel(R) Core(TM) i3-1115G4 @ 3.00GHz 2.90 GHz
Installed RAM: 8.00 GB (7.65 GB usable)
Device ID: 9568953E-8453-43DA-8292-560F821E6656
Product ID: 00330-80000-00000-AA155
System type: 64-bit operating system, x64-based processor
Pen and touch: Touch support with 10 touch points

Operating system: Windows 11
Graphics card: Intel (R) UHD Graphics

Blender Version : Blender 3.6.1
Broken: (The non-linear animation panel)
Worked: (newest version of Blender that worked as expected)

Short description of error: In non-linear animation panel, if I add a sound and then try to move it, Blender crashes.

Exact steps for others to reproduce the error

  1. Add a speaker.
  2. Go to non-linear animation window.
  3. You will find the audio. Hold and drag it around.
  4. The file closes (Blender crashes).
    Based on the default startup or an attached .blend file (as simple as possible).
**System Information** Processor: 11th Gen Intel(R) Core(TM) i3-1115G4 @ 3.00GHz 2.90 GHz Installed RAM: 8.00 GB (7.65 GB usable) Device ID: 9568953E-8453-43DA-8292-560F821E6656 Product ID: 00330-80000-00000-AA155 System type: 64-bit operating system, x64-based processor Pen and touch: Touch support with 10 touch points Operating system: Windows 11 Graphics card: Intel (R) UHD Graphics **Blender Version** : Blender 3.6.1 Broken: (The non-linear animation panel) Worked: (newest version of Blender that worked as expected) **Short description of error**: In non-linear animation panel, if I add a sound and then try to move it, Blender crashes. **Exact steps for others to reproduce the error** 1) Add a speaker. 2) Go to non-linear animation window. 3) You will find the audio. Hold and drag it around. 4) The file closes (Blender crashes). Based on the default startup or an attached .blend file (as simple as possible).
Nettan-Yonas added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-08-31 10:08:50 +02:00
Member

Can confirm in 3.6, this is fixed in 4.0 though.
Let me see if this is on the backport list #109399 already (otherwise will add the commit there)...

Confirming for now until this is backported.

Can confirm in 3.6, this is fixed in 4.0 though. Let me see if this is on the backport list #109399 already (otherwise will add the commit there)... Confirming for now until this is backported.
Philipp Oeser added
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-08-31 11:16:54 +02:00
Philipp Oeser changed title from Non-Linear Animation Panel to NLA crash moving sound strip (fixed in main, needs backport) 2023-08-31 11:18:21 +02:00
Member
#110161 ?
Member

#110161 ?

Ah, yep, added 5b3398a673 to LTS #109399 now.
So we can close this as a duplicate of #110161.

> #110161 ? Ah, yep, added 5b3398a673 to LTS #109399 now. So we can close this as a duplicate of #110161.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-08-31 11:23:05 +02:00
Philipp Oeser added
Status
Duplicate
and removed
Status
Archived
labels 2023-08-31 11:23:14 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111724
No description provided.