segfault on f3 when mouse hover focus off foreground window #111774

Closed
opened 2023-09-01 09:31:46 +02:00 by Miles Cooley · 10 comments

System Information
Operating system: macOS-10.15.7-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GT 650M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-14.0.32 355.11.11.10.10.143

Blender Version
Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: 8bda729ef4dc
Already broken: 3.0
Worked: 2.93.18

Short description of error
The application crashes upon using the Search Menu keyboard shortcut, under the condition that the mouse hover focus is not over the foreground window.

Exact steps for others to reproduce the error
UPDATE: must enable Developer Extras for crash to occur!
New file.
Make the window not fullscreen so you can see some desktop.
Hover mouse over desktop.
Press F3 key to open Search Menu.
Observe notification of segmentation fault.

Alternatively, open a preferences window or secondary blender window and mouse over the main window and press F3, that's how I found it.

Before 3.0 the same steps will cause the menu to appear in the foreground window as close as it can get itself to the mouse outside.
UPDATE: checked Developer Extras and it was on, yet no crash prior to 3.0

**System Information** Operating system: macOS-10.15.7-x86_64-i386-64bit 64 Bits Graphics card: NVIDIA GeForce GT 650M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-14.0.32 355.11.11.10.10.143 **Blender Version** Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: `8bda729ef4dc` Already broken: 3.0 Worked: 2.93.18 **Short description of error** The application crashes upon using the Search Menu keyboard shortcut, under the condition that the mouse hover focus is not over the foreground window. **Exact steps for others to reproduce the error** UPDATE: must enable Developer Extras for crash to occur! New file. Make the window not fullscreen so you can see some desktop. Hover mouse over desktop. Press F3 key to open Search Menu. Observe notification of segmentation fault. Alternatively, open a preferences window or secondary blender window and mouse over the main window and press F3, that's how I found it. Before 3.0 the same steps will cause the menu to appear in the foreground window as close as it can get itself to the mouse outside. UPDATE: checked Developer Extras and it was on, yet no crash prior to 3.0
Miles Cooley added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-09-01 09:31:47 +02:00
Member

Hi, similar crash has been fixed in 4.0: #111212
Could you check again in recent builds: https://builder.blender.org/download/daily/

Hi, similar crash has been fixed in 4.0: #111212 Could you check again in recent builds: https://builder.blender.org/download/daily/
Member

Already broken: 3.0

Oh, I did not notice this earlier. Could you share crash logs?: https://docs.blender.org/manual/en/dev/troubleshooting/crash.html

> Already broken: 3.0 Oh, I did not notice this earlier. Could you share crash logs?: https://docs.blender.org/manual/en/dev/troubleshooting/crash.html
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-09-01 10:57:06 +02:00
Author

Here's the log copied from the crash window on my Mac.

I am currently downloading the build of 400f7c22bc to test.

Here's the log copied from the crash window on my Mac. I am currently downloading the build of 400f7c22bc98 to test.
Author

Ah, I guess I will not be testing 4.0

Blender - Platform Unsupported
Your graphics card or macOS version is not supported

Upgrading to the latest macOS version may improve Blender support

The program will now close.

Ah, I guess I will not be testing 4.0 > Blender - Platform Unsupported > Your graphics card or macOS version is not supported > > Upgrading to the latest macOS version may improve Blender support > > The program will now close.
Member

Thanks. Could you try 3.6.3 build?: https://builder.blender.org/download/daily/
From crash logs, this may not be Mac specific.
Also try factory reset: File > Defaults > Load Factory Settings

Thanks. Could you try 3.6.3 build?: https://builder.blender.org/download/daily/ From crash logs, this may not be Mac specific. Also try factory reset: `File > Defaults > Load Factory Settings`
Author

Yes, 3.6.3 is the same, and the factory reset fixes it in the several 3.X versions I tested. So I suppose the steps to reproduce require some modification of settings. I've attached my default file. Is there a way to list just the settings which aren't factory?

Yes, 3.6.3 is the same, and the factory reset fixes it in the several 3.X versions I tested. So I suppose the steps to reproduce require some modification of settings. I've attached my default file. Is there a way to list just the settings which aren't factory?
Member

Thanks. I was able to repro crash but it was same as #111212 (crashed in keyframe_jump_poll)

  • Disable developers extra
  • Disable add-on one by one
    This might help to reveal the culprit
Thanks. I was able to repro crash but it was same as #111212 (crashed in `keyframe_jump_poll`) - Disable `developers extra` - Disable add-on one by one This might help to reveal the culprit
Author

Oh yes, the crash only occurs if Developer Extras is enabled, regardless of the Experimental options.

Oh yes, the crash only occurs if Developer Extras is enabled, regardless of the Experimental options.
Member

Thanks. Either an add-on or the poll function of keyframe jump operator is triggering the crash.
Could you try 3.6.3 build? (Fix of #111212 is now backported): https://builder.blender.org/download/daily/

Thanks. Either an add-on or the poll function of `keyframe jump` operator is triggering the crash. Could you try 3.6.3 build? (Fix of #111212 is now backported): https://builder.blender.org/download/daily/
Member

Either an add-on or the poll function of keyframe jump operator is triggering the crash.

Will close this for now since this is likely fixed already. If culprit is an add-on, feel free to submit a new report at: https://projects.blender.org/blender/blender-addons/issues

> Either an add-on or the poll function of keyframe jump operator is triggering the crash. Will close this for now since this is likely fixed already. If culprit is an add-on, feel free to submit a new report at: https://projects.blender.org/blender/blender-addons/issues
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-10-20 11:39:57 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111774
No description provided.